aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am68
1 files changed, 68 insertions, 0 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
new file mode 100644
index 000000000..55ef757c2
--- /dev/null
+++ b/src/core/Makefile.am
@@ -0,0 +1,68 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3plugindir = $(libdir)/gnunet
4
5if MINGW
6 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
7endif
8
9if USE_COVERAGE
10 AM_CFLAGS = -fprofile-arcs -ftest-coverage
11endif
12
13
14lib_LTLIBRARIES = \
15 libgnunetcore.la
16
17libgnunetcore_la_SOURCES = \
18 core_api.c core.h
19libgnunetcore_la_LIBADD = \
20 $(top_builddir)/src/arm/libgnunetarm.la \
21 $(top_builddir)/src/util/libgnunetutil.la \
22 $(GN_LIBINTL)
23libgnunetcore_la_LDFLAGS = \
24 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
25 -version-info 0:0:0
26
27
28bin_PROGRAMS = \
29 gnunet-service-core
30
31gnunet_service_core_SOURCES = \
32 gnunet-service-core.c
33gnunet_service_core_LDADD = \
34 $(top_builddir)/src/hello/libgnunethello.la \
35 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
36 $(top_builddir)/src/transport/libgnunettransport.la \
37 $(top_builddir)/src/util/libgnunetutil.la \
38 $(GN_LIBINTL)
39
40
41check_PROGRAMS = \
42 test_core_api_start_only \
43 test_core_api
44
45TESTS = $(check_PROGRAMS)
46
47test_core_api_SOURCES = \
48 test_core_api.c
49test_core_api_LDADD = \
50 $(top_builddir)/src/arm/libgnunetarm.la \
51 $(top_builddir)/src/core/libgnunetcore.la \
52 $(top_builddir)/src/transport/libgnunettransport.la \
53 $(top_builddir)/src/util/libgnunetutil.la
54
55
56test_core_api_start_only_SOURCES = \
57 test_core_api_start_only.c
58test_core_api_start_only_LDADD = \
59 $(top_builddir)/src/arm/libgnunetarm.la \
60 $(top_builddir)/src/core/libgnunetcore.la \
61 $(top_builddir)/src/util/libgnunetutil.la
62
63
64EXTRA_DIST = \
65 test_core_api_data.conf \
66 test_core_api_peer1.conf \
67 test_core_api_peer2.conf
68