aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am145
1 files changed, 0 insertions, 145 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
deleted file mode 100644
index d2d3a2d7f..000000000
--- a/src/core/Makefile.am
+++ /dev/null
@@ -1,145 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8pkgcfg_DATA = \
9 core.conf
10
11if USE_COVERAGE
12 AM_CFLAGS = --coverage -O0
13 XLIB = -lgcov
14endif
15
16
17lib_LTLIBRARIES = \
18 libgnunetcore.la
19
20libgnunetcore_la_SOURCES = \
21 core_api.c core.h \
22 core_api_monitor_peers.c
23libgnunetcore_la_LIBADD = \
24 $(top_builddir)/src/util/libgnunetutil.la \
25 $(GN_LIBINTL) $(XLIB)
26libgnunetcore_la_LDFLAGS = \
27 $(GN_LIB_LDFLAGS) \
28 -version-info 0:1:0
29
30
31libexec_PROGRAMS = \
32 gnunet-service-core
33
34bin_PROGRAMS = \
35 gnunet-core
36
37gnunet_service_core_SOURCES = \
38 gnunet-service-core.c gnunet-service-core.h \
39 gnunet-service-core_kx.c gnunet-service-core_kx.h \
40 gnunet-service-core_sessions.c gnunet-service-core_sessions.h \
41 gnunet-service-core_typemap.c gnunet-service-core_typemap.h
42gnunet_service_core_LDADD = \
43 $(top_builddir)/src/statistics/libgnunetstatistics.la \
44 $(top_builddir)/src/transport/libgnunettransport.la \
45 $(top_builddir)/src/util/libgnunetutil.la \
46 $(GN_LIBINTL) $(Z_LIBS)
47
48
49gnunet_core_SOURCES = \
50 gnunet-core.c
51gnunet_core_LDADD = \
52 libgnunetcore.la \
53 $(top_builddir)/src/util/libgnunetutil.la
54gnunet_core_LDFLAGS = \
55 $(GN_LIBINTL)
56
57if HAVE_TESTING
58 TESTING_TESTS = \
59 test_core_api_send_to_self
60endif
61
62check_PROGRAMS = \
63 test_core_api_start_only \
64 test_core_api \
65 test_core_api_reliability \
66 test_core_quota_compliance_symmetric \
67 test_core_quota_compliance_asymmetric_send_limited \
68 test_core_quota_compliance_asymmetric_recv_limited \
69 $(TESTING_TESTS)
70
71if ENABLE_TEST_RUN
72AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
73TESTS = $(check_PROGRAMS)
74endif
75
76test_core_api_SOURCES = \
77 test_core_api.c
78test_core_api_LDADD = \
79 libgnunetcore.la \
80 $(top_builddir)/src/transport/libgnunettransport.la \
81 $(top_builddir)/src/ats/libgnunetats.la \
82 $(top_builddir)/src/util/libgnunetutil.la
83
84test_core_api_reliability_SOURCES = \
85 test_core_api_reliability.c
86test_core_api_reliability_LDADD = \
87 libgnunetcore.la \
88 $(top_builddir)/src/transport/libgnunettransport.la \
89 $(top_builddir)/src/ats/libgnunetats.la \
90 $(top_builddir)/src/util/libgnunetutil.la
91
92test_core_api_send_to_self_SOURCES = \
93 test_core_api_send_to_self.c
94test_core_api_send_to_self_LDADD = \
95 libgnunetcore.la \
96 $(top_builddir)/src/testing/libgnunettesting.la \
97 $(top_builddir)/src/transport/libgnunettransport.la \
98 $(top_builddir)/src/util/libgnunetutil.la
99
100test_core_api_start_only_SOURCES = \
101 test_core_api_start_only.c
102test_core_api_start_only_LDADD = \
103 $(top_builddir)/src/testing/libgnunettesting.la \
104 libgnunetcore.la \
105 $(top_builddir)/src/util/libgnunetutil.la
106
107test_core_quota_compliance_symmetric_SOURCES = \
108 test_core_quota_compliance.c
109test_core_quota_compliance_symmetric_LDADD = \
110 libgnunetcore.la \
111 $(top_builddir)/src/transport/libgnunettransport.la \
112 $(top_builddir)/src/ats/libgnunetats.la \
113 $(top_builddir)/src/util/libgnunetutil.la \
114 $(top_builddir)/src/statistics/libgnunetstatistics.la
115
116test_core_quota_compliance_asymmetric_send_limited_SOURCES = \
117 test_core_quota_compliance.c
118test_core_quota_compliance_asymmetric_send_limited_LDADD = \
119 libgnunetcore.la \
120 $(top_builddir)/src/transport/libgnunettransport.la \
121 $(top_builddir)/src/ats/libgnunetats.la \
122 $(top_builddir)/src/util/libgnunetutil.la \
123 $(top_builddir)/src/statistics/libgnunetstatistics.la
124
125test_core_quota_compliance_asymmetric_recv_limited_SOURCES = \
126 test_core_quota_compliance.c
127test_core_quota_compliance_asymmetric_recv_limited_LDADD = \
128 libgnunetcore.la \
129 $(top_builddir)/src/transport/libgnunettransport.la \
130 $(top_builddir)/src/ats/libgnunetats.la \
131 $(top_builddir)/src/util/libgnunetutil.la \
132 $(top_builddir)/src/statistics/libgnunetstatistics.la
133
134EXTRA_DIST = \
135 test_core_defaults.conf \
136 test_core_api_data.conf \
137 test_core_api_peer1.conf \
138 test_core_api_peer2.conf \
139 test_core_api_send_to_self.conf \
140 test_core_quota_asymmetric_recv_limited_peer1.conf \
141 test_core_quota_asymmetric_recv_limited_peer2.conf \
142 test_core_quota_asymmetric_send_limit_peer1.conf \
143 test_core_quota_asymmetric_send_limit_peer2.conf \
144 test_core_quota_peer1.conf \
145 test_core_quota_peer2.conf