aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datacache/Makefile.am')
-rw-r--r--src/datacache/Makefile.am200
1 files changed, 0 insertions, 200 deletions
diff --git a/src/datacache/Makefile.am b/src/datacache/Makefile.am
deleted file mode 100644
index ecb02d1c3..000000000
--- a/src/datacache/Makefile.am
+++ /dev/null
@@ -1,200 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8dist_pkgcfg_DATA = \
9 datacache.conf
10
11if USE_COVERAGE
12 AM_CFLAGS = --coverage -O0
13 XLIBS = -lgcov
14endif
15
16if HAVE_SQLITE
17 SQLITE_PLUGIN = libgnunet_plugin_datacache_sqlite.la
18endif
19if HAVE_POSTGRESQL
20 POSTGRES_PLUGIN = libgnunet_plugin_datacache_postgres.la
21endif
22
23lib_LTLIBRARIES = \
24 libgnunetdatacache.la
25
26libgnunetdatacache_la_SOURCES = \
27 datacache.c
28libgnunetdatacache_la_LIBADD = \
29 $(top_builddir)/src/statistics/libgnunetstatistics.la \
30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(GN_LIBINTL)
32libgnunetdatacache_la_LDFLAGS = \
33 $(GN_LIB_LDFLAGS) \
34 -version-info 0:1:0
35
36
37plugin_LTLIBRARIES = \
38 $(SQLITE_PLUGIN) \
39 $(POSTGRES_PLUGIN) \
40 libgnunet_plugin_datacache_heap.la
41
42# Real plugins should of course go into
43# plugin_LTLIBRARIES
44noinst_LTLIBRARIES = \
45 libgnunet_plugin_datacache_template.la
46
47
48libgnunet_plugin_datacache_sqlite_la_SOURCES = \
49 plugin_datacache_sqlite.c
50libgnunet_plugin_datacache_sqlite_la_LIBADD = \
51 $(top_builddir)/src/statistics/libgnunetstatistics.la \
52 $(top_builddir)/src/sq/libgnunetsq.la \
53 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
54 $(LTLIBINTL)
55libgnunet_plugin_datacache_sqlite_la_LDFLAGS = \
56 $(GN_PLUGIN_LDFLAGS)
57
58libgnunet_plugin_datacache_heap_la_SOURCES = \
59 plugin_datacache_heap.c
60libgnunet_plugin_datacache_heap_la_LIBADD = \
61 $(top_builddir)/src/statistics/libgnunetstatistics.la \
62 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
63 $(LTLIBINTL)
64libgnunet_plugin_datacache_heap_la_LDFLAGS = \
65 $(GN_PLUGIN_LDFLAGS)
66
67libgnunet_plugin_datacache_postgres_la_SOURCES = \
68 plugin_datacache_postgres.c
69libgnunet_plugin_datacache_postgres_la_LIBADD = \
70 $(top_builddir)/src/pq/libgnunetpq.la \
71 $(top_builddir)/src/statistics/libgnunetstatistics.la \
72 $(top_builddir)/src/util/libgnunetutil.la \
73 $(GN_PLUGIN_LDFLAGS) -lpq
74libgnunet_plugin_datacache_postgres_la_CPPFLAGS = \
75 $(POSTGRESQL_CPPFLAGS) $(AM_CPPFLAGS)
76libgnunet_plugin_datacache_postgres_la_LDFLAGS = \
77 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
78
79libgnunet_plugin_datacache_template_la_SOURCES = \
80 plugin_datacache_template.c
81libgnunet_plugin_datacache_template_la_LIBADD = \
82 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
83 $(LTLIBINTL)
84libgnunet_plugin_datacache_template_la_LDFLAGS = \
85 $(GN_PLUGIN_LDFLAGS)
86
87
88if HAVE_TESTING
89if HAVE_SQLITE
90if HAVE_BENCHMARKS
91 SQLITE_BENCHMARKS = \
92 perf_datacache_sqlite
93endif
94SQLITE_TESTS = \
95 test_datacache_sqlite \
96 test_datacache_quota_sqlite \
97 $(SQLITE_BENCHMARKS)
98endif
99
100if HAVE_BENCHMARKS
101 HEAP_BENCHMARKS = \
102 perf_datacache_heap
103endif
104HEAP_TESTS = \
105 test_datacache_heap \
106 test_datacache_quota_heap \
107 $(HEAP_BENCHMARKS)
108
109if HAVE_POSTGRESQL
110if HAVE_BENCHMARKS
111 POSTGRES_BENCHMARKS = \
112 perf_datacache_postgres
113endif
114POSTGRES_TESTS = \
115 test_datacache_postgres \
116 test_datacache_quota_postgres \
117 $(POSTGRES_BENCHMARKS)
118endif
119endif
120
121check_PROGRAMS = \
122 $(SQLITE_TESTS) \
123 $(HEAP_TESTS) \
124 $(POSTGRES_TESTS)
125
126if ENABLE_TEST_RUN
127AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
128TESTS = $(check_PROGRAMS)
129endif
130
131test_datacache_sqlite_SOURCES = \
132 test_datacache.c
133test_datacache_sqlite_LDADD = \
134 $(top_builddir)/src/testing/libgnunettesting.la \
135 libgnunetdatacache.la \
136 $(top_builddir)/src/util/libgnunetutil.la
137
138test_datacache_quota_sqlite_SOURCES = \
139 test_datacache_quota.c
140test_datacache_quota_sqlite_LDADD = \
141 $(top_builddir)/src/testing/libgnunettesting.la \
142 libgnunetdatacache.la \
143 $(top_builddir)/src/util/libgnunetutil.la
144
145perf_datacache_sqlite_SOURCES = \
146 perf_datacache.c
147perf_datacache_sqlite_LDADD = \
148 $(top_builddir)/src/testing/libgnunettesting.la \
149 libgnunetdatacache.la \
150 $(top_builddir)/src/util/libgnunetutil.la
151
152test_datacache_heap_SOURCES = \
153 test_datacache.c
154test_datacache_heap_LDADD = \
155 $(top_builddir)/src/testing/libgnunettesting.la \
156 libgnunetdatacache.la \
157 $(top_builddir)/src/util/libgnunetutil.la
158
159test_datacache_quota_heap_SOURCES = \
160 test_datacache_quota.c
161test_datacache_quota_heap_LDADD = \
162 $(top_builddir)/src/testing/libgnunettesting.la \
163 libgnunetdatacache.la \
164 $(top_builddir)/src/util/libgnunetutil.la
165
166perf_datacache_heap_SOURCES = \
167 perf_datacache.c
168perf_datacache_heap_LDADD = \
169 $(top_builddir)/src/testing/libgnunettesting.la \
170 libgnunetdatacache.la \
171 $(top_builddir)/src/util/libgnunetutil.la
172
173test_datacache_postgres_SOURCES = \
174 test_datacache.c
175test_datacache_postgres_LDADD = \
176 $(top_builddir)/src/testing/libgnunettesting.la \
177 libgnunetdatacache.la \
178 $(top_builddir)/src/util/libgnunetutil.la
179
180test_datacache_quota_postgres_SOURCES = \
181 test_datacache_quota.c
182test_datacache_quota_postgres_LDADD = \
183 $(top_builddir)/src/testing/libgnunettesting.la \
184 libgnunetdatacache.la \
185 $(top_builddir)/src/util/libgnunetutil.la
186
187perf_datacache_postgres_SOURCES = \
188 perf_datacache.c
189perf_datacache_postgres_LDADD = \
190 $(top_builddir)/src/testing/libgnunettesting.la \
191 libgnunetdatacache.la \
192 $(top_builddir)/src/util/libgnunetutil.la
193
194EXTRA_DIST = \
195 test_datacache_data_sqlite.conf \
196 perf_datacache_data_sqlite.conf \
197 test_datacache_data_heap.conf \
198 perf_datacache_data_heap.conf \
199 test_datacache_data_postgres.conf \
200 perf_datacache_data_postgres.conf