aboutsummaryrefslogtreecommitdiff
path: root/src/datacache/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datacache/Makefile.am')
-rw-r--r--src/datacache/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/datacache/Makefile.am b/src/datacache/Makefile.am
index 7a89da852..941072396 100644
--- a/src/datacache/Makefile.am
+++ b/src/datacache/Makefile.am
@@ -19,7 +19,7 @@ endif
19if HAVE_SQLITE 19if HAVE_SQLITE
20 SQLITE_PLUGIN = libgnunet_plugin_datacache_sqlite.la 20 SQLITE_PLUGIN = libgnunet_plugin_datacache_sqlite.la
21endif 21endif
22if HAVE_POSTGRES 22if HAVE_POSTGRESQL
23 POSTGRES_PLUGIN = libgnunet_plugin_datacache_postgres.la 23 POSTGRES_PLUGIN = libgnunet_plugin_datacache_postgres.la
24endif 24endif
25 25
@@ -68,11 +68,11 @@ libgnunet_plugin_datacache_postgres_la_LIBADD = \
68 $(top_builddir)/src/postgres/libgnunetpostgres.la \ 68 $(top_builddir)/src/postgres/libgnunetpostgres.la \
69 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 69 $(top_builddir)/src/statistics/libgnunetstatistics.la \
70 $(top_builddir)/src/util/libgnunetutil.la \ 70 $(top_builddir)/src/util/libgnunetutil.la \
71 $(GN_PLUGIN_LDFLAGS) $(POSTGRES_LDFLAGS) -lpq 71 $(GN_PLUGIN_LDFLAGS) -lpq
72libgnunet_plugin_datacache_postgres_la_CPPFLAGS = \ 72libgnunet_plugin_datacache_postgres_la_CPPFLAGS = \
73 $(POSTGRES_CPPFLAGS) $(AM_CPPFLAGS) 73 $(POSTGRESQL_CPPFLAGS) $(AM_CPPFLAGS)
74libgnunet_plugin_datacache_postgres_la_LDFLAGS = \ 74libgnunet_plugin_datacache_postgres_la_LDFLAGS = \
75 $(GN_PLUGIN_LDFLAGS) $(POSTGRES_LDFLAGS) -lpq 75 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
76 76
77libgnunet_plugin_datacache_template_la_SOURCES = \ 77libgnunet_plugin_datacache_template_la_SOURCES = \
78 plugin_datacache_template.c 78 plugin_datacache_template.c
@@ -104,7 +104,7 @@ HEAP_TESTS = \
104 test_datacache_quota_heap \ 104 test_datacache_quota_heap \
105 $(HEAP_BENCHMARKS) 105 $(HEAP_BENCHMARKS)
106 106
107if HAVE_POSTGRES 107if HAVE_POSTGRESQL
108if HAVE_BENCHMARKS 108if HAVE_BENCHMARKS
109 POSTGRES_BENCHMARKS = \ 109 POSTGRES_BENCHMARKS = \
110 perf_datacache_postgres 110 perf_datacache_postgres