aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am321
1 files changed, 0 insertions, 321 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
deleted file mode 100644
index 07ae004b3..000000000
--- a/src/datastore/Makefile.am
+++ /dev/null
@@ -1,321 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 datastore.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIBS = -lgcov
16endif
17
18
19lib_LTLIBRARIES = \
20 libgnunetdatastore.la
21
22libgnunetdatastore_la_SOURCES = \
23 datastore_api.c datastore.h
24libgnunetdatastore_la_LIBADD = \
25 $(top_builddir)/src/statistics/libgnunetstatistics.la \
26 $(top_builddir)/src/util/libgnunetutil.la \
27 $(GN_LIBINTL)
28libgnunetdatastore_la_LDFLAGS = \
29 $(GN_LIB_LDFLAGS) \
30 -version-info 1:0:0
31
32bin_PROGRAMS = \
33 gnunet-datastore
34
35libexec_PROGRAMS = \
36 gnunet-service-datastore
37
38gnunet_service_datastore_SOURCES = \
39 gnunet-service-datastore.c
40gnunet_service_datastore_LDADD = \
41 $(top_builddir)/src/statistics/libgnunetstatistics.la \
42 $(top_builddir)/src/util/libgnunetutil.la \
43 $(GN_LIBINTL)
44
45gnunet_datastore_SOURCES = \
46 gnunet-datastore.c
47gnunet_datastore_LDADD = \
48 libgnunetdatastore.la \
49 $(top_builddir)/src/util/libgnunetutil.la \
50 $(GN_LIBINTL)
51
52
53if HAVE_MYSQL
54 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la
55if HAVE_BENCHMARKS
56 MYSQL_BENCHMARKS = \
57 perf_datastore_api_mysql \
58 perf_plugin_datastore_mysql
59endif
60 MYSQL_TESTS = \
61 test_datastore_api_mysql \
62 test_datastore_api_management_mysql \
63 test_plugin_datastore_mysql \
64 $(MYSQL_BENCHMARKS)
65endif
66if HAVE_SQLITE
67 SQLITE_PLUGIN = libgnunet_plugin_datastore_sqlite.la
68if HAVE_BENCHMARKS
69 SQLITE_BENCHMARKS = \
70 perf_datastore_api_sqlite \
71 perf_plugin_datastore_sqlite
72endif
73 SQLITE_TESTS = \
74 test_datastore_api_sqlite \
75 test_datastore_api_management_sqlite \
76 test_plugin_datastore_sqlite \
77 $(SQLITE_BENCHMARKS)
78endif
79if HAVE_POSTGRESQL
80 POSTGRES_PLUGIN = libgnunet_plugin_datastore_postgres.la
81if HAVE_BENCHMARKS
82 POSTGRES_BENCHMARKS = \
83 perf_datastore_api_postgres \
84 perf_plugin_datastore_postgres
85endif
86 POSTGRES_TESTS = \
87 test_datastore_api_postgres \
88 test_datastore_api_management_postgres \
89 test_plugin_datastore_postgres \
90 $(POSTGRES_BENCHMARKS)
91endif
92
93plugin_LTLIBRARIES = \
94 $(SQLITE_PLUGIN) \
95 $(MYSQL_PLUGIN) \
96 $(POSTGRES_PLUGIN) \
97 libgnunet_plugin_datastore_heap.la
98
99# Real plugins should of course go into
100# plugin_LTLIBRARIES
101noinst_LTLIBRARIES = \
102 libgnunet_plugin_datastore_template.la
103
104
105libgnunet_plugin_datastore_sqlite_la_SOURCES = \
106 plugin_datastore_sqlite.c
107libgnunet_plugin_datastore_sqlite_la_LIBADD = \
108 $(top_builddir)/src/sq/libgnunetsq.la \
109 $(top_builddir)/src/statistics/libgnunetstatistics.la \
110 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
111 $(LTLIBINTL)
112libgnunet_plugin_datastore_sqlite_la_LDFLAGS = \
113 $(GN_PLUGIN_LDFLAGS)
114
115
116libgnunet_plugin_datastore_heap_la_SOURCES = \
117 plugin_datastore_heap.c
118libgnunet_plugin_datastore_heap_la_LIBADD = \
119 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
120 $(LTLIBINTL)
121libgnunet_plugin_datastore_heap_la_LDFLAGS = \
122 $(GN_PLUGIN_LDFLAGS)
123
124
125libgnunet_plugin_datastore_mysql_la_SOURCES = \
126 plugin_datastore_mysql.c
127libgnunet_plugin_datastore_mysql_la_LIBADD = \
128 $(top_builddir)/src/my/libgnunetmy.la \
129 $(top_builddir)/src/mysql/libgnunetmysql.la \
130 $(top_builddir)/src/statistics/libgnunetstatistics.la \
131 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) $(Z_LIBS) -lmysqlclient
132libgnunet_plugin_datastore_mysql_la_LDFLAGS = \
133 $(GN_PLUGIN_LDFLAGS) $(MYSQL_LDFLAGS) -lmysqlclient
134libgnunet_plugin_datastore_mysql_la_CPPFLAGS = \
135 $(MYSQL_CPPFLAGS) $(AM_CPPFLAGS)
136
137libgnunet_plugin_datastore_postgres_la_SOURCES = \
138 plugin_datastore_postgres.c
139libgnunet_plugin_datastore_postgres_la_LIBADD = \
140 $(top_builddir)/src/statistics/libgnunetstatistics.la \
141 $(top_builddir)/src/pq/libgnunetpq.la \
142 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq
143libgnunet_plugin_datastore_postgres_la_LDFLAGS = \
144 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
145libgnunet_plugin_datastore_postgres_la_CPPFLAGS = \
146 $(POSTGRESQL_CPPFLAGS) $(AM_CPPFLAGS)
147
148
149libgnunet_plugin_datastore_template_la_SOURCES = \
150 plugin_datastore_template.c
151libgnunet_plugin_datastore_template_la_LIBADD = \
152 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
153 $(LTLIBINTL)
154libgnunet_plugin_datastore_template_la_LDFLAGS = \
155 $(GN_PLUGIN_LDFLAGS)
156
157check_PROGRAMS = \
158 test_datastore_api_heap \
159 test_datastore_api_management_heap \
160 perf_datastore_api_heap \
161 perf_plugin_datastore_heap \
162 test_plugin_datastore_heap \
163 $(SQLITE_TESTS) \
164 $(MYSQL_TESTS) \
165 $(POSTGRES_TESTS)
166
167if ENABLE_TEST_RUN
168AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
169TESTS = $(check_PROGRAMS)
170endif
171
172test_datastore_api_heap_SOURCES = \
173 test_datastore_api.c
174test_datastore_api_heap_LDADD = \
175 $(top_builddir)/src/testing/libgnunettesting.la \
176 libgnunetdatastore.la \
177 $(top_builddir)/src/util/libgnunetutil.la
178
179test_datastore_api_management_heap_SOURCES = \
180 test_datastore_api_management.c
181test_datastore_api_management_heap_LDADD = \
182 $(top_builddir)/src/testing/libgnunettesting.la \
183 libgnunetdatastore.la \
184 $(top_builddir)/src/util/libgnunetutil.la
185
186perf_datastore_api_heap_SOURCES = \
187 perf_datastore_api.c
188perf_datastore_api_heap_LDADD = \
189 $(top_builddir)/src/testing/libgnunettesting.la \
190 libgnunetdatastore.la \
191 $(top_builddir)/src/util/libgnunetutil.la
192
193perf_plugin_datastore_heap_SOURCES = \
194 perf_plugin_datastore.c
195perf_plugin_datastore_heap_LDADD = \
196 $(top_builddir)/src/testing/libgnunettesting.la \
197 $(top_builddir)/src/util/libgnunetutil.la
198
199test_plugin_datastore_heap_SOURCES = \
200 test_plugin_datastore.c
201test_plugin_datastore_heap_LDADD = \
202 $(top_builddir)/src/testing/libgnunettesting.la \
203 $(top_builddir)/src/util/libgnunetutil.la
204
205
206test_datastore_api_sqlite_SOURCES = \
207 test_datastore_api.c
208test_datastore_api_sqlite_LDADD = \
209 $(top_builddir)/src/testing/libgnunettesting.la \
210 libgnunetdatastore.la \
211 $(top_builddir)/src/util/libgnunetutil.la
212
213test_datastore_api_management_sqlite_SOURCES = \
214 test_datastore_api_management.c
215test_datastore_api_management_sqlite_LDADD = \
216 $(top_builddir)/src/testing/libgnunettesting.la \
217 libgnunetdatastore.la \
218 $(top_builddir)/src/util/libgnunetutil.la
219
220perf_datastore_api_sqlite_SOURCES = \
221 perf_datastore_api.c
222perf_datastore_api_sqlite_LDADD = \
223 $(top_builddir)/src/testing/libgnunettesting.la \
224 libgnunetdatastore.la \
225 $(top_builddir)/src/util/libgnunetutil.la
226
227perf_plugin_datastore_sqlite_SOURCES = \
228 perf_plugin_datastore.c
229perf_plugin_datastore_sqlite_LDADD = \
230 $(top_builddir)/src/testing/libgnunettesting.la \
231 $(top_builddir)/src/util/libgnunetutil.la
232
233test_plugin_datastore_sqlite_SOURCES = \
234 test_plugin_datastore.c
235test_plugin_datastore_sqlite_LDADD = \
236 $(top_builddir)/src/testing/libgnunettesting.la \
237 $(top_builddir)/src/util/libgnunetutil.la
238
239
240test_datastore_api_mysql_SOURCES = \
241 test_datastore_api.c
242test_datastore_api_mysql_LDADD = \
243 $(top_builddir)/src/testing/libgnunettesting.la \
244 libgnunetdatastore.la \
245 $(top_builddir)/src/util/libgnunetutil.la
246
247test_datastore_api_management_mysql_SOURCES = \
248 test_datastore_api_management.c
249test_datastore_api_management_mysql_LDADD = \
250 $(top_builddir)/src/testing/libgnunettesting.la \
251 libgnunetdatastore.la \
252 $(top_builddir)/src/util/libgnunetutil.la
253
254perf_datastore_api_mysql_SOURCES = \
255 perf_datastore_api.c
256perf_datastore_api_mysql_LDADD = \
257 $(top_builddir)/src/testing/libgnunettesting.la \
258 libgnunetdatastore.la \
259 $(top_builddir)/src/util/libgnunetutil.la
260
261test_plugin_datastore_mysql_SOURCES = \
262 test_plugin_datastore.c
263test_plugin_datastore_mysql_LDADD = \
264 $(top_builddir)/src/testing/libgnunettesting.la \
265 $(top_builddir)/src/util/libgnunetutil.la
266
267perf_plugin_datastore_mysql_SOURCES = \
268 perf_plugin_datastore.c
269perf_plugin_datastore_mysql_LDADD = \
270 $(top_builddir)/src/testing/libgnunettesting.la \
271 $(top_builddir)/src/util/libgnunetutil.la
272
273
274test_datastore_api_postgres_SOURCES = \
275 test_datastore_api.c
276test_datastore_api_postgres_LDADD = \
277 $(top_builddir)/src/testing/libgnunettesting.la \
278 libgnunetdatastore.la \
279 $(top_builddir)/src/util/libgnunetutil.la
280
281test_datastore_api_management_postgres_SOURCES = \
282 test_datastore_api_management.c
283test_datastore_api_management_postgres_LDADD = \
284 $(top_builddir)/src/testing/libgnunettesting.la \
285 libgnunetdatastore.la \
286 $(top_builddir)/src/util/libgnunetutil.la
287
288perf_datastore_api_postgres_SOURCES = \
289 perf_datastore_api.c
290perf_datastore_api_postgres_LDADD = \
291 $(top_builddir)/src/testing/libgnunettesting.la \
292 libgnunetdatastore.la \
293 $(top_builddir)/src/util/libgnunetutil.la
294
295test_plugin_datastore_postgres_SOURCES = \
296 test_plugin_datastore.c
297test_plugin_datastore_postgres_LDADD = \
298 $(top_builddir)/src/testing/libgnunettesting.la \
299 $(top_builddir)/src/util/libgnunetutil.la
300
301perf_plugin_datastore_postgres_SOURCES = \
302 perf_plugin_datastore.c
303perf_plugin_datastore_postgres_LDADD = \
304 $(top_builddir)/src/testing/libgnunettesting.la \
305 $(top_builddir)/src/util/libgnunetutil.la
306
307
308EXTRA_DIST = \
309 test_defaults.conf \
310 test_datastore_api_data_sqlite.conf \
311 perf_plugin_datastore_data_sqlite.conf \
312 test_plugin_datastore_data_sqlite.conf \
313 test_datastore_api_data_heap.conf \
314 perf_plugin_datastore_data_heap.conf \
315 test_plugin_datastore_data_heap.conf \
316 test_datastore_api_data_mysql.conf \
317 perf_plugin_datastore_data_mysql.conf \
318 test_plugin_datastore_data_mysql.conf \
319 test_datastore_api_data_postgres.conf \
320 perf_plugin_datastore_data_postgres.conf \
321 test_plugin_datastore_data_postgres.conf