aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
new file mode 100644
index 000000000..839df983d
--- /dev/null
+++ b/src/datastore/Makefile.am
@@ -0,0 +1,69 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3plugindir = $(libdir)/gnunet
4
5if MINGW
6 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
7endif
8
9if USE_COVERAGE
10 AM_CFLAGS = --coverage -O0
11 XLIBS = -lgcov
12endif
13
14
15lib_LTLIBRARIES = \
16 libgnunetdatastore.la
17
18libgnunetdatastore_la_SOURCES = \
19 datastore_api.c datastore.h
20libgnunetdatastore_la_LIBADD = \
21 $(top_builddir)/src/util/libgnunetutil.la \
22 $(GN_LIBINTL)
23libgnunetdatastore_la_LDFLAGS = \
24 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
25 -version-info 0:0:0
26
27
28bin_PROGRAMS = \
29 gnunet-service-datastore
30
31gnunet_service_datastore_SOURCES = \
32 gnunet-service-datastore.c plugin_datastore.h
33gnunet_service_datastore_LDADD = \
34 $(top_builddir)/src/util/libgnunetutil.la \
35 $(GN_LIBINTL)
36
37
38plugin_LTLIBRARIES = \
39 libgnunet_plugin_datastore_sqlite.la \
40 libgnunet_plugin_datastore_template.la
41
42
43libgnunet_plugin_datastore_sqlite_la_SOURCES = \
44 plugin_datastore_sqlite.c
45libgnunet_plugin_datastore_sqlite_la_LIBADD = \
46 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3
47libgnunet_plugin_datastore_sqlite_la_LDFLAGS = \
48 $(GN_PLUGIN_LDFLAGS)
49
50libgnunet_plugin_datastore_template_la_SOURCES = \
51 plugin_datastore_template.c
52libgnunet_plugin_datastore_template_la_LIBADD = \
53 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS)
54libgnunet_plugin_datastore_template_la_LDFLAGS = \
55 $(GN_PLUGIN_LDFLAGS)
56
57
58#check_PROGRAMS = \
59# test_datastore_api
60#
61#TESTS = $(check_PROGRAMS)
62#
63#test_datastore_api_SOURCES = \
64# test_datastore_api.c
65#test_datastore_api_LDADD = \
66# $(top_builddir)/src/datastore/libgnunetdatastore.la \
67# $(top_builddir)/src/util/libgnunetutil.la
68
69