aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 57639fa37..c2acc2ffe 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -32,6 +32,8 @@ libgnunetdatastore_la_LDFLAGS = \
32 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 32 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
33 -version-info 1:0:0 33 -version-info 1:0:0
34 34
35bin_PROGRAMS = \
36 gnunet-datastore
35 37
36libexec_PROGRAMS = \ 38libexec_PROGRAMS = \
37 gnunet-service-datastore 39 gnunet-service-datastore
@@ -43,6 +45,13 @@ gnunet_service_datastore_LDADD = \
43 $(top_builddir)/src/util/libgnunetutil.la \ 45 $(top_builddir)/src/util/libgnunetutil.la \
44 $(GN_LIBINTL) 46 $(GN_LIBINTL)
45 47
48gnunet_datastore_SOURCES = \
49 gnunet-datastore.c
50gnunet_datastore_LDADD = \
51 $(top_builddir)/src/datastore/libgnunetdatastore.la \
52 $(top_builddir)/src/util/libgnunetutil.la \
53 $(GN_LIBINTL)
54
46if HAVE_MYSQL 55if HAVE_MYSQL
47 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la 56 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la
48if HAVE_BENCHMARKS 57if HAVE_BENCHMARKS