aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am227
1 files changed, 0 insertions, 227 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
deleted file mode 100644
index 919eca438..000000000
--- a/src/dht/Makefile.am
+++ /dev/null
@@ -1,227 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 dht.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIB = -lgcov
16endif
17
18lib_LTLIBRARIES = \
19 libgnunetdht.la
20
21libgnunetdht_la_SOURCES = \
22 dht_api.c dht.h
23libgnunetdht_la_LIBADD = \
24 $(top_builddir)/src/util/libgnunetutil.la \
25 $(XLIB) \
26 $(LTLIBINTL)
27libgnunetdht_la_LDFLAGS = \
28 $(GN_LIB_LDFLAGS) \
29 -version-info 3:0:0
30
31
32plugin_LTLIBRARIES = \
33 libgnunet_plugin_block_dht.la
34
35libgnunet_plugin_block_dht_la_SOURCES = \
36 plugin_block_dht.c
37libgnunet_plugin_block_dht_la_LIBADD = \
38 $(top_builddir)/src/hello/libgnunethello.la \
39 $(top_builddir)/src/block/libgnunetblock.la \
40 $(top_builddir)/src/block/libgnunetblockgroup.la \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(LTLIBINTL)
43libgnunet_plugin_block_dht_la_LDFLAGS = \
44 $(GN_PLUGIN_LDFLAGS)
45
46
47libexec_PROGRAMS = \
48 gnunet-service-dht
49
50bin_PROGRAMS = \
51 gnunet-dht-monitor \
52 gnunet-dht-get \
53 gnunet-dht-put
54
55if HAVE_TESTING
56noinst_PROGRAMS = \
57 gnunet-dht-profiler
58endif
59
60gnunet_service_dht_SOURCES = \
61 gnunet-service-dht.c gnunet-service-dht.h \
62 gnunet-service-dht_datacache.c gnunet-service-dht_datacache.h \
63 gnunet-service-dht_hello.c gnunet-service-dht_hello.h \
64 gnunet-service-dht_nse.c gnunet-service-dht_nse.h \
65 gnunet-service-dht_neighbours.c gnunet-service-dht_neighbours.h \
66 gnunet-service-dht_routing.c gnunet-service-dht_routing.h
67gnunet_service_dht_LDADD = \
68 $(top_builddir)/src/statistics/libgnunetstatistics.la \
69 $(top_builddir)/src/core/libgnunetcore.la \
70 $(top_builddir)/src/nse/libgnunetnse.la \
71 $(top_builddir)/src/ats/libgnunetats.la \
72 $(top_builddir)/src/transport/libgnunettransport.la \
73 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
74 $(top_builddir)/src/hello/libgnunethello.la \
75 $(top_builddir)/src/block/libgnunetblock.la \
76 $(top_builddir)/src/datacache/libgnunetdatacache.la \
77 $(top_builddir)/src/util/libgnunetutil.la \
78 -lm
79gnunet_service_dht_LDFLAGS = \
80 $(GN_LIBINTL)
81
82gnunet_dht_get_SOURCES = \
83 gnunet-dht-get.c
84gnunet_dht_get_LDADD = \
85 libgnunetdht.la \
86 $(top_builddir)/src/core/libgnunetcore.la \
87 $(top_builddir)/src/util/libgnunetutil.la
88gnunet_dht_get_LDFLAGS = \
89 $(GN_LIBINTL)
90
91gnunet_dht_put_SOURCES = \
92 gnunet-dht-put.c
93gnunet_dht_put_LDADD = \
94 libgnunetdht.la \
95 $(top_builddir)/src/core/libgnunetcore.la \
96 $(top_builddir)/src/util/libgnunetutil.la
97gnunet_dht_put_LDFLAGS = \
98 $(GN_LIBINTL)
99
100gnunet_dht_monitor_SOURCES = \
101 gnunet-dht-monitor.c
102gnunet_dht_monitor_LDADD = \
103 libgnunetdht.la \
104 $(top_builddir)/src/core/libgnunetcore.la \
105 $(top_builddir)/src/util/libgnunetutil.la
106gnunet_dht_monitor_LDFLAGS = \
107 $(GN_LIBINTL)
108
109gnunet_dht_profiler_SOURCES = \
110 gnunet_dht_profiler.c
111gnunet_dht_profiler_LDADD = \
112 libgnunetdht.la \
113 $(top_builddir)/src/core/libgnunetcore.la \
114 $(top_builddir)/src/util/libgnunetutil.la \
115 $(top_builddir)/src/testing/libgnunettesting.la \
116 $(top_builddir)/src/testbed/libgnunettestbed.la
117gnunet_dht_profiler_LDFLAGS = \
118 $(GN_LIBINTL)
119
120if HAVE_TESTING
121noinst_LIBRARIES = libgnunetdhttest.a
122endif
123
124libgnunetdhttest_a_SOURCES = \
125 dht_test_lib.c dht_test_lib.h
126libgnunetdhttest_a_LIBADD = \
127 $(top_builddir)/src/util/libgnunetutil.la \
128 $(top_builddir)/src/testbed/libgnunettestbed.la \
129 libgnunetdht.la
130
131if HAVE_TESTING
132check_PROGRAMS = \
133 test_dht_api \
134 test_dht_twopeer \
135 test_dht_multipeer \
136 test_dht_line \
137 test_dht_2dtorus \
138 test_dht_monitor
139endif
140
141if HAVE_EXPERIMENTAL
142# These tests still do not work as testbed does
143# not support the respective topology op
144 NEW_TESTS = test_dht_2dtorus test_dht_multipeer
145endif
146
147if ENABLE_TEST_RUN
148AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
149TESTS = test_dht_api $(check_SCRIPTS) \
150 test_dht_twopeer \
151 test_dht_line \
152 test_dht_monitor \
153 $(NEW_TESTS)
154endif
155
156test_dht_api_SOURCES = \
157 test_dht_api.c
158test_dht_api_LDADD = \
159 $(top_builddir)/src/util/libgnunetutil.la \
160 $(top_builddir)/src/testing/libgnunettesting.la \
161 $(top_builddir)/src/hello/libgnunethello.la \
162 libgnunetdht.la
163
164test_dht_twopeer_SOURCES = \
165 test_dht_topo.c
166test_dht_twopeer_LDADD = \
167 libgnunetdhttest.a \
168 $(top_builddir)/src/util/libgnunetutil.la \
169 libgnunetdhttest.a \
170 $(top_builddir)/src/testbed/libgnunettestbed.la \
171 libgnunetdht.la
172
173test_dht_2dtorus_SOURCES = \
174 test_dht_topo.c
175test_dht_2dtorus_LDADD = \
176 libgnunetdhttest.a \
177 $(top_builddir)/src/util/libgnunetutil.la \
178 $(top_builddir)/src/testbed/libgnunettestbed.la \
179 libgnunetdht.la
180
181test_dht_line_SOURCES = \
182 test_dht_topo.c
183test_dht_line_LDADD = \
184 libgnunetdhttest.a \
185 $(top_builddir)/src/util/libgnunetutil.la \
186 $(top_builddir)/src/testbed/libgnunettestbed.la \
187 libgnunetdht.la
188
189test_dht_multipeer_SOURCES = \
190 test_dht_topo.c
191test_dht_multipeer_LDADD = \
192 libgnunetdhttest.a \
193 $(top_builddir)/src/util/libgnunetutil.la \
194 $(top_builddir)/src/statistics/libgnunetstatistics.la \
195 $(top_builddir)/src/testbed/libgnunettestbed.la \
196 libgnunetdht.la
197
198test_dht_monitor_SOURCES = \
199 test_dht_monitor.c
200test_dht_monitor_LDADD = \
201 libgnunetdhttest.a \
202 $(top_builddir)/src/util/libgnunetutil.la \
203 $(top_builddir)/src/testbed/libgnunettestbed.la \
204 libgnunetdht.la
205
206EXTRA_DIST = \
207 $(check_SCRIPTS) \
208 gnunet-service-dht_clients.c \
209 test_dht_api_data.conf \
210 test_dht_api_peer1.conf \
211 test_dht_monitor.conf \
212 test_dht_multipeer.conf \
213 test_dht_2dtorus.conf \
214 test_dht_line.conf \
215 test_dht_tools.conf \
216 test_dht_tools.py.in \
217 test_dht_multipeer_topology.dat
218
219if HAVE_PYTHON
220check_SCRIPTS = \
221 test_dht_tools.py
222endif
223
224SUFFIXES = .py.in .py
225.py.in.py:
226 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/$< > $@
227 chmod +x $@