aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index ad1d05d25..b2bbf5897 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -22,7 +22,6 @@ endif
22lib_LTLIBRARIES = \ 22lib_LTLIBRARIES = \
23 libgnunetdht.la 23 libgnunetdht.la
24 24
25
26libgnunetdht_la_SOURCES = \ 25libgnunetdht_la_SOURCES = \
27 dht_api.c dht.h 26 dht_api.c dht.h
28libgnunetdht_la_LIBADD = \ 27libgnunetdht_la_LIBADD = \
@@ -32,6 +31,23 @@ libgnunetdht_la_LDFLAGS = \
32 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 31 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
33 -version-info 0:0:0 32 -version-info 0:0:0
34 33
34
35plugin_LTLIBRARIES = \
36 libgnunet_plugin_block_dht.la
37
38libgnunet_plugin_block_dht_la_SOURCES = \
39 plugin_block_dht.c
40libgnunet_plugin_block_dht_la_LIBADD = \
41 $(top_builddir)/src/hello/libgnunethello.la \
42 $(top_builddir)/src/block/libgnunetblock.la \
43 $(top_builddir)/src/util/libgnunetutil.la
44libgnunet_plugin_block_dht_la_LDFLAGS = \
45 $(GN_PLUGIN_LDFLAGS)
46libgnunet_plugin_block_dht_la_DEPENDENCIES = \
47 $(top_builddir)/src/block/libgnunetblock.la
48
49
50
35bin_PROGRAMS = \ 51bin_PROGRAMS = \
36 gnunet-service-dht \ 52 gnunet-service-dht \
37 gnunet-dht-get \ 53 gnunet-dht-get \