aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index f8918616f..b9e7c5d67 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -56,7 +56,8 @@ noinst_PROGRAMS = \
56 gnunet-dht-monitor \ 56 gnunet-dht-monitor \
57 gnunet-dht-get \ 57 gnunet-dht-get \
58 gnunet-dht-put \ 58 gnunet-dht-put \
59 gnunet-dht-profiler 59 gnunet-dht-profiler\
60 gnunet-dht-r5n-profiler
60 61
61gnunet_service_dht_SOURCES = \ 62gnunet_service_dht_SOURCES = \
62 gnunet-service-dht.c gnunet-service-dht.h \ 63 gnunet-service-dht.c gnunet-service-dht.h \
@@ -139,6 +140,16 @@ gnunet_dht_profiler_LDADD = \
139gnunet_dht_profiler_DEPENDENCIES = \ 140gnunet_dht_profiler_DEPENDENCIES = \
140 libgnunetdht.la 141 libgnunetdht.la
141 142
143gnunet_dht_r5n_profiler_SOURCES = \
144 gnunet_dht_r5n_profiler.c
145gnunet_dht_r5n_profiler_LDADD = \
146 $(top_builddir)/src/dht/libgnunetdht.la \
147 $(top_builddir)/src/core/libgnunetcore.la \
148 $(top_builddir)/src/util/libgnunetutil.la \
149 $(top_builddir)/src/testbed/libgnunettestbed.la
150gnunet_dht_r5n_profiler_DEPENDENCIES = \
151 libgnunetdht.la
152
142if HAVE_TESTING 153if HAVE_TESTING
143noinst_LIBRARIES = libgnunetdhttest.a 154noinst_LIBRARIES = libgnunetdhttest.a
144endif 155endif