aboutsummaryrefslogtreecommitdiff
path: root/src/dns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dns/Makefile.am')
-rw-r--r--src/dns/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/dns/Makefile.am b/src/dns/Makefile.am
index f7376a111..99e78d7d6 100644
--- a/src/dns/Makefile.am
+++ b/src/dns/Makefile.am
@@ -20,8 +20,11 @@ HIJACKBIN = gnunet-helper-hijack-dns gnunet-helper-dns
20install-exec-hook: 20install-exec-hook:
21 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-hijack-dns || true 21 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-hijack-dns || true
22 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-hijack-dns || true 22 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-hijack-dns || true
23 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-dns || true 23 $(SUDO_BINARY) chown root $(bindir)/gnunet-helper-dns || true
24 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-dns || true 24 $(SUDO_BINARY) chgrp $(GNUNETDNS_GROUP) $(bindir)/gnunet-helper-dns || true
25 $(SUDO_BINARY) chmod 4750 $(bindir)/gnunet-helper-dns || true
26 $(SUDO_BINARY) chgrp $(GNUNETDNS_GROUP) $(bindir)/gnunet-service-dns-new || true
27 $(SUDO_BINARY) chmod 2755 $(bindir)/gnunet-helper-dns || true
25else 28else
26install-exec-hook: 29install-exec-hook:
27endif 30endif