aboutsummaryrefslogtreecommitdiff
path: root/src/dv/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/dv/Makefile.am')
-rw-r--r--src/dv/Makefile.am100
1 files changed, 0 insertions, 100 deletions
diff --git a/src/dv/Makefile.am b/src/dv/Makefile.am
deleted file mode 100644
index c44321151..000000000
--- a/src/dv/Makefile.am
+++ /dev/null
@@ -1,100 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if MINGW
5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
6endif
7
8if USE_COVERAGE
9 AM_CFLAGS = --coverage -O0
10 XLIB = -lgcov
11endif
12
13plugindir = $(libdir)/gnunet
14
15libexecdir= $(pkglibdir)/libexec/
16
17pkgcfgdir= $(pkgdatadir)/config.d/
18
19pkgcfg_DATA = \
20 dv.conf
21
22lib_LTLIBRARIES = libgnunetdv.la
23
24plugin_LTLIBRARIES = libgnunet_plugin_transport_dv.la
25
26libgnunetdv_la_SOURCES = \
27 dv_api.c dv.h
28libgnunetdv_la_LIBADD = \
29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(GN_LIBINTL) $(XLIB)
31libgnunetdv_la_LDFLAGS = \
32 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
33 -version-info 0:0:0
34
35
36noinst_PROGRAMS = \
37 gnunet-dv
38
39libexec_PROGRAMS = \
40 gnunet-service-dv
41
42gnunet_service_dv_SOURCES = \
43 gnunet-service-dv.c dv.h
44gnunet_service_dv_LDADD = \
45 $(top_builddir)/src/ats/libgnunetats.la \
46 $(top_builddir)/src/set/libgnunetset.la \
47 $(top_builddir)/src/statistics/libgnunetstatistics.la \
48 $(top_builddir)/src/core/libgnunetcore.la \
49 $(top_builddir)/src/util/libgnunetutil.la \
50 $(GN_LIBINTL)
51
52gnunet_dv_SOURCES = \
53 gnunet-dv.c dv.h
54gnunet_dv_LDADD = \
55 libgnunetdv.la \
56 $(top_builddir)/src/util/libgnunetutil.la \
57 $(GN_LIBINTL)
58
59libgnunet_plugin_transport_dv_la_SOURCES = \
60 plugin_transport_dv.c
61libgnunet_plugin_transport_dv_la_LIBADD = \
62 libgnunetdv.la \
63 $(top_builddir)/src/ats/libgnunetats.la \
64 $(top_builddir)/src/hello/libgnunethello.la \
65 $(top_builddir)/src/util/libgnunetutil.la
66libgnunet_plugin_transport_dv_la_LDFLAGS = \
67 $(GN_PLUGIN_LDFLAGS)
68
69if HAVE_TESTING
70check_PROGRAMS = \
71 test_transport_blacklist \
72 test_transport_dv
73endif
74
75if ENABLE_TEST_RUN
76 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
77 TESTS = $(check_PROGRAMS)
78endif
79
80test_transport_dv_SOURCES = \
81 test_transport_dv.c
82test_transport_dv_LDADD = \
83 $(top_builddir)/src/testbed/libgnunettestbed.la \
84 $(top_builddir)/src/core/libgnunetcore.la \
85 $(top_builddir)/src/transport/libgnunettransport.la \
86 $(top_builddir)/src/util/libgnunetutil.la
87
88test_transport_blacklist_SOURCES = \
89 test_transport_blacklist.c
90test_transport_blacklist_LDADD = \
91 $(top_builddir)/src/testbed/libgnunettestbed.la \
92 $(top_builddir)/src/core/libgnunetcore.la \
93 $(top_builddir)/src/transport/libgnunettransport.la \
94 $(top_builddir)/src/util/libgnunetutil.la
95
96EXTRA_DIST = \
97 test_transport_dv_data.conf \
98 test_transport_blacklist_data.conf \
99 template_dv.conf
100