summaryrefslogtreecommitdiff
path: root/src/exit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/exit/Makefile.am')
-rw-r--r--src/exit/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/exit/Makefile.am b/src/exit/Makefile.am
index b7286349d..bca0f1d9f 100644
--- a/src/exit/Makefile.am
+++ b/src/exit/Makefile.am
@@ -14,10 +14,18 @@ plugindir = $(libdir)/gnunet
14dist_pkgcfg_DATA = \ 14dist_pkgcfg_DATA = \
15 exit.conf 15 exit.conf
16 16
17if HAVE_SUDO
18SUDO_OR_DOAS_BINARY= $(SUDO_BINARY)
19else
20if HAVE_DOAS_BINARY
21SUDO_OR_DOAS_BINARY= $(DOAS_BINARY)
22endif
23endif
24
17if LINUX 25if LINUX
18EXITBIN = gnunet-helper-exit 26EXITBIN = gnunet-helper-exit
19install-exec-hook: 27install-exec-hook:
20 $(top_srcdir)/src/exit/install-exit-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_BINARY) || true 28 $(top_srcdir)/src/exit/install-exit-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_OR_DOAS_BINARY) || true
21else 29else
22install-exec-hook: 30install-exec-hook:
23endif 31endif