aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am571
1 files changed, 0 insertions, 571 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
deleted file mode 100644
index 5b6ba2376..000000000
--- a/src/fs/Makefile.am
+++ /dev/null
@@ -1,571 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9pkgcfgdir= $(pkgdatadir)/config.d/
10
11libexecdir= $(pkglibdir)/libexec/
12
13pkgcfg_DATA = \
14 fs.conf
15
16plugindir = $(libdir)/gnunet
17
18
19lib_LTLIBRARIES = libgnunetfs.la
20
21plugin_LTLIBRARIES = \
22 libgnunet_plugin_block_fs.la
23
24if HAVE_TESTING
25noinst_LIBRARIES = libgnunetfstest.a
26endif
27
28libgnunetfs_la_SOURCES = \
29 fs_api.c fs_api.h fs.h \
30 fs_directory.c \
31 fs_dirmetascan.c \
32 fs_download.c \
33 fs_file_information.c \
34 fs_getopt.c \
35 fs_list_indexed.c \
36 fs_publish.c \
37 fs_publish_ksk.c \
38 fs_publish_ublock.c fs_publish_ublock.h \
39 fs_misc.c \
40 fs_namespace.c \
41 fs_search.c \
42 fs_sharetree.c \
43 fs_tree.c fs_tree.h \
44 fs_unindex.c \
45 fs_uri.c
46
47libgnunetfs_la_LIBADD = \
48 $(top_builddir)/src/datastore/libgnunetdatastore.la \
49 $(top_builddir)/src/statistics/libgnunetstatistics.la \
50 $(top_builddir)/src/util/libgnunetutil.la \
51 $(GN_LIBINTL) $(XLIB) $(LIBGCRYPT_LIBS) -lunistring
52
53if HAVE_LIBEXTRACTOR
54libgnunetfs_la_LIBADD += \
55 -lextractor
56endif
57
58libgnunetfs_la_LDFLAGS = \
59 $(GN_LIB_LDFLAGS) \
60 -version-info 3:1:1
61
62
63libgnunetfstest_a_SOURCES = \
64 fs_test_lib.c fs_test_lib.h
65
66libgnunetfstest_a_LIBADD = \
67 $(top_builddir)/src/testing/libgnunettesting.la \
68 $(top_builddir)/src/testbed/libgnunettestbed.la
69
70libexec_PROGRAMS = \
71 gnunet-helper-fs-publish \
72 gnunet-service-fs
73
74if HAVE_TESTING
75noinst_PROGRAMS = \
76 gnunet-fs-profiler \
77 gnunet-daemon-fsprofiler
78endif
79
80bin_PROGRAMS = \
81 gnunet-auto-share \
82 gnunet-directory \
83 gnunet-download \
84 gnunet-publish \
85 gnunet-search \
86 gnunet-fs \
87 gnunet-unindex
88
89gnunet_directory_SOURCES = \
90 gnunet-directory.c
91gnunet_directory_LDADD = \
92 libgnunetfs.la \
93 $(top_builddir)/src/util/libgnunetutil.la \
94 $(GN_LIBINTL)
95
96if HAVE_LIBEXTRACTOR
97gnunet_directory_LDADD += \
98 -lextractor
99endif
100
101gnunet_fs_profiler_SOURCES = \
102 gnunet-fs-profiler.c
103gnunet_fs_profiler_LDADD = \
104 $(top_builddir)/src/testing/libgnunettesting.la \
105 $(top_builddir)/src/testbed/libgnunettestbed.la \
106 $(top_builddir)/src/util/libgnunetutil.la \
107 $(GN_LIBINTL)
108
109gnunet_fs_SOURCES = \
110 gnunet-fs.c
111gnunet_fs_LDADD = \
112 libgnunetfs.la \
113 $(top_builddir)/src/util/libgnunetutil.la \
114 $(GN_LIBINTL)
115
116if HAVE_LIBEXTRACTOR
117gnunet_fs_LDADD += \
118 -lextractor
119endif
120
121gnunet_download_SOURCES = \
122 gnunet-download.c
123gnunet_download_LDADD = \
124 libgnunetfs.la \
125 $(top_builddir)/src/util/libgnunetutil.la \
126 $(GN_LIBINTL)
127
128gnunet_publish_SOURCES = \
129 gnunet-publish.c
130gnunet_publish_LDADD = \
131 $(top_builddir)/src/identity/libgnunetidentity.la \
132 libgnunetfs.la \
133 $(top_builddir)/src/util/libgnunetutil.la \
134 $(GN_LIBINTL)
135
136if HAVE_LIBEXTRACTOR
137gnunet_publish_LDADD += \
138 -lextractor
139endif
140
141gnunet_auto_share_SOURCES = \
142 gnunet-auto-share.c
143gnunet_auto_share_LDADD = \
144 $(top_builddir)/src/util/libgnunetutil.la \
145 $(GN_LIBINTL)
146
147if HAVE_LIBEXTRACTOR
148gnunet_auto_share_LDADD += \
149 -lextractor
150endif
151
152gnunet_helper_fs_publish_SOURCES = \
153 gnunet-helper-fs-publish.c
154gnunet_helper_fs_publish_LDADD = \
155 $(top_builddir)/src/util/libgnunetutil.la \
156 $(GN_LIBINTL)
157
158if HAVE_LIBEXTRACTOR
159gnunet_helper_fs_publish_LDADD += \
160 -lextractor
161endif
162
163gnunet_search_SOURCES = \
164 gnunet-search.c
165gnunet_search_LDADD = \
166 libgnunetfs.la \
167 $(top_builddir)/src/util/libgnunetutil.la \
168 $(GN_LIBINTL)
169
170if HAVE_LIBEXTRACTOR
171gnunet_search_LDADD += \
172 -lextractor
173endif
174
175
176gnunet_daemon_fsprofiler_SOURCES = \
177 gnunet-daemon-fsprofiler.c
178gnunet_daemon_fsprofiler_LDADD = \
179 libgnunetfs.la \
180 $(top_builddir)/src/statistics/libgnunetstatistics.la \
181 $(top_builddir)/src/util/libgnunetutil.la \
182 $(GN_LIBINTL)
183
184gnunet_service_fs_SOURCES = \
185 gnunet-service-fs.c gnunet-service-fs.h \
186 gnunet-service-fs_cp.c gnunet-service-fs_cp.h \
187 gnunet-service-fs_indexing.c gnunet-service-fs_indexing.h \
188 gnunet-service-fs_pe.c gnunet-service-fs_pe.h \
189 gnunet-service-fs_pr.c gnunet-service-fs_pr.h \
190 gnunet-service-fs_push.c gnunet-service-fs_push.h \
191 gnunet-service-fs_put.c gnunet-service-fs_put.h \
192 gnunet-service-fs_cadet_client.c gnunet-service-fs_cadet.h \
193 gnunet-service-fs_cadet_server.c
194gnunet_service_fs_LDADD = \
195 libgnunetfs.la \
196 $(top_builddir)/src/dht/libgnunetdht.la \
197 $(top_builddir)/src/block/libgnunetblock.la \
198 $(top_builddir)/src/datastore/libgnunetdatastore.la \
199 $(top_builddir)/src/statistics/libgnunetstatistics.la \
200 $(top_builddir)/src/cadet/libgnunetcadet.la \
201 $(top_builddir)/src/ats/libgnunetats.la \
202 $(top_builddir)/src/core/libgnunetcore.la \
203 $(top_builddir)/src/util/libgnunetutil.la \
204 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
205 $(GN_LIBINTL) -lm
206
207gnunet_unindex_SOURCES = \
208 gnunet-unindex.c
209gnunet_unindex_LDADD = \
210 libgnunetfs.la \
211 $(top_builddir)/src/util/libgnunetutil.la \
212 $(GN_LIBINTL)
213
214libgnunet_plugin_block_fs_la_SOURCES = \
215 plugin_block_fs.c
216libgnunet_plugin_block_fs_la_LIBADD = \
217 $(top_builddir)/src/block/libgnunetblockgroup.la \
218 $(top_builddir)/src/block/libgnunetblock.la \
219 libgnunetfs.la \
220 $(top_builddir)/src/util/libgnunetutil.la \
221 $(LTLIBINTL)
222libgnunet_plugin_block_fs_la_LDFLAGS = \
223 $(GN_PLUGIN_LDFLAGS)
224
225if HAVE_BENCHMARKS
226 FS_BENCHMARKS = \
227 perf_gnunet_service_fs_p2p \
228 perf_gnunet_service_fs_p2p_dht \
229 perf_gnunet_service_fs_p2p_index \
230 perf_gnunet_service_fs_p2p_respect
231endif
232
233if HAVE_TESTING
234check_PROGRAMS = \
235 test_plugin_block_fs \
236 test_fs_directory \
237 test_fs_download \
238 test_fs_download_cadet \
239 test_fs_download_indexed \
240 test_fs_download_persistence \
241 test_fs_file_information \
242 test_fs_getopt \
243 test_fs_list_indexed \
244 test_fs_namespace \
245 test_fs_namespace_list_updateable \
246 test_fs_publish \
247 test_fs_publish_persistence \
248 test_fs_search \
249 test_fs_search_with_and \
250 test_fs_search_probes \
251 test_fs_search_persistence \
252 test_fs_start_stop \
253 test_fs_test_lib \
254 test_fs_unindex \
255 test_fs_unindex_persistence \
256 test_fs_uri \
257 test_gnunet_service_fs_migration \
258 test_gnunet_service_fs_p2p \
259 test_gnunet_service_fs_p2p_cadet \
260 $(FS_BENCHMARKS)
261endif
262
263test_plugin_block_fs_SOURCES = \
264 test_plugin_block_fs.c
265test_plugin_block_fs_LDADD = \
266 $(top_builddir)/src/block/libgnunetblock.la \
267 $(top_builddir)/src/util/libgnunetutil.la
268
269if HAVE_PYTHON
270check_SCRIPTS = \
271 test_gnunet_fs_rec.py \
272 test_gnunet_fs_idx.py
273
274if HAVE_LIBEXTRACTOR
275check_SCRIPTS += \
276 test_gnunet_fs_psd.py
277endif
278endif
279
280
281if ENABLE_TEST_RUN
282AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; $(MONKEY)
283TESTS = \
284 test_fs_directory \
285 test_fs_download \
286 test_fs_download_indexed \
287 test_fs_download_persistence \
288 test_fs_file_information \
289 test_fs_list_indexed \
290 test_fs_namespace \
291 test_fs_namespace_list_updateable \
292 test_fs_publish \
293 test_fs_publish_persistence \
294 test_fs_search \
295 test_fs_search_with_and \
296 test_fs_search_probes \
297 test_fs_search_persistence \
298 test_fs_start_stop \
299 test_fs_unindex \
300 test_fs_unindex_persistence \
301 test_fs_uri \
302 test_fs_test_lib \
303 test_gnunet_service_fs_migration \
304 test_gnunet_service_fs_p2p \
305 test_gnunet_service_fs_p2p_cadet \
306 perf_gnunet_service_fs_p2p \
307 perf_gnunet_service_fs_p2p_index \
308 perf_gnunet_service_fs_p2p_respect \
309 $(check_SCRIPTS)
310endif
311
312
313test_fs_directory_SOURCES = \
314 test_fs_directory.c
315test_fs_directory_LDADD = \
316 libgnunetfs.la \
317 $(top_builddir)/src/util/libgnunetutil.la
318
319if HAVE_LIBEXTRACTOR
320test_fs_directory_LDADD += \
321 -lextractor
322endif
323
324
325test_fs_download_SOURCES = \
326 test_fs_download.c
327test_fs_download_LDADD = \
328 $(top_builddir)/src/testing/libgnunettesting.la \
329 libgnunetfs.la \
330 $(top_builddir)/src/util/libgnunetutil.la
331
332test_fs_download_indexed_SOURCES = \
333 test_fs_download.c
334test_fs_download_indexed_LDADD = \
335 $(top_builddir)/src/testing/libgnunettesting.la \
336 libgnunetfs.la \
337 $(top_builddir)/src/util/libgnunetutil.la
338
339test_fs_download_cadet_SOURCES = \
340 test_fs_download.c
341test_fs_download_cadet_LDADD = \
342 $(top_builddir)/src/testing/libgnunettesting.la \
343 libgnunetfs.la \
344 $(top_builddir)/src/util/libgnunetutil.la
345
346test_fs_download_persistence_SOURCES = \
347 test_fs_download_persistence.c
348test_fs_download_persistence_LDADD = \
349 $(top_builddir)/src/testing/libgnunettesting.la \
350 libgnunetfs.la \
351 $(top_builddir)/src/util/libgnunetutil.la
352
353test_fs_file_information_SOURCES = \
354 test_fs_file_information.c
355test_fs_file_information_LDADD = \
356 libgnunetfs.la \
357 $(top_builddir)/src/util/libgnunetutil.la
358
359if HAVE_LIBEXTRACTOR
360test_fs_file_information_LDADD += \
361 -lextractor
362endif
363
364
365test_fs_getopt_SOURCES = \
366 test_fs_getopt.c
367test_fs_getopt_LDADD = \
368 libgnunetfs.la \
369 $(top_builddir)/src/util/libgnunetutil.la
370
371test_fs_list_indexed_SOURCES = \
372 test_fs_list_indexed.c
373test_fs_list_indexed_LDADD = \
374 $(top_builddir)/src/testing/libgnunettesting.la \
375 libgnunetfs.la \
376 $(top_builddir)/src/util/libgnunetutil.la
377
378test_fs_namespace_SOURCES = \
379 test_fs_namespace.c
380test_fs_namespace_LDADD = \
381 $(top_builddir)/src/testing/libgnunettesting.la \
382 libgnunetfs.la \
383 $(top_builddir)/src/util/libgnunetutil.la
384
385test_fs_namespace_list_updateable_SOURCES = \
386 test_fs_namespace_list_updateable.c
387test_fs_namespace_list_updateable_LDADD = \
388 $(top_builddir)/src/testing/libgnunettesting.la \
389 libgnunetfs.la \
390 $(top_builddir)/src/util/libgnunetutil.la
391
392test_fs_publish_SOURCES = \
393 test_fs_publish.c
394test_fs_publish_LDADD = \
395 $(top_builddir)/src/testing/libgnunettesting.la \
396 libgnunetfs.la \
397 $(top_builddir)/src/util/libgnunetutil.la
398
399test_fs_publish_persistence_SOURCES = \
400 test_fs_publish_persistence.c
401test_fs_publish_persistence_LDADD = \
402 $(top_builddir)/src/testing/libgnunettesting.la \
403 libgnunetfs.la \
404 $(top_builddir)/src/util/libgnunetutil.la
405
406test_fs_search_SOURCES = \
407 test_fs_search.c
408test_fs_search_LDADD = \
409 $(top_builddir)/src/testing/libgnunettesting.la \
410 libgnunetfs.la \
411 $(top_builddir)/src/util/libgnunetutil.la
412
413test_fs_search_with_and_SOURCES = \
414 test_fs_search_with_and.c
415test_fs_search_with_and_LDADD = \
416 $(top_builddir)/src/testing/libgnunettesting.la \
417 libgnunetfs.la \
418 $(top_builddir)/src/util/libgnunetutil.la
419
420test_fs_search_probes_SOURCES = \
421 test_fs_search_probes.c
422test_fs_search_probes_LDADD = \
423 $(top_builddir)/src/testing/libgnunettesting.la \
424 libgnunetfs.la \
425 $(top_builddir)/src/util/libgnunetutil.la
426
427test_fs_search_persistence_SOURCES = \
428 test_fs_search_persistence.c
429test_fs_search_persistence_LDADD = \
430 $(top_builddir)/src/testing/libgnunettesting.la \
431 libgnunetfs.la \
432 $(top_builddir)/src/util/libgnunetutil.la
433
434test_fs_start_stop_SOURCES = \
435 test_fs_start_stop.c
436test_fs_start_stop_LDADD = \
437 $(top_builddir)/src/testing/libgnunettesting.la \
438 libgnunetfs.la \
439 $(top_builddir)/src/util/libgnunetutil.la
440
441test_fs_unindex_SOURCES = \
442 test_fs_unindex.c
443test_fs_unindex_LDADD = \
444 $(top_builddir)/src/testing/libgnunettesting.la \
445 libgnunetfs.la \
446 $(top_builddir)/src/util/libgnunetutil.la
447
448test_fs_unindex_persistence_SOURCES = \
449 test_fs_unindex_persistence.c
450test_fs_unindex_persistence_LDADD = \
451 $(top_builddir)/src/testing/libgnunettesting.la \
452 libgnunetfs.la \
453 $(top_builddir)/src/util/libgnunetutil.la
454
455test_fs_uri_SOURCES = \
456 test_fs_uri.c
457test_fs_uri_LDADD = \
458 libgnunetfs.la \
459 $(top_builddir)/src/util/libgnunetutil.la
460
461test_fs_test_lib_SOURCES = \
462 test_fs_test_lib.c
463test_fs_test_lib_LDADD = \
464 libgnunetfstest.a \
465 $(top_builddir)/src/testbed/libgnunettestbed.la \
466 libgnunetfs.la \
467 $(top_builddir)/src/util/libgnunetutil.la
468
469test_gnunet_service_fs_p2p_SOURCES = \
470 test_gnunet_service_fs_p2p.c
471test_gnunet_service_fs_p2p_LDADD = \
472 libgnunetfstest.a \
473 $(top_builddir)/src/testbed/libgnunettestbed.la \
474 libgnunetfs.la \
475 $(top_builddir)/src/util/libgnunetutil.la
476
477test_gnunet_service_fs_p2p_cadet_SOURCES = \
478 test_gnunet_service_fs_p2p.c
479test_gnunet_service_fs_p2p_cadet_LDADD = \
480 libgnunetfstest.a \
481 $(top_builddir)/src/testbed/libgnunettestbed.la \
482 libgnunetfs.la \
483 $(top_builddir)/src/util/libgnunetutil.la
484
485test_gnunet_service_fs_migration_SOURCES = \
486 test_gnunet_service_fs_migration.c
487test_gnunet_service_fs_migration_LDADD = \
488 libgnunetfstest.a \
489 $(top_builddir)/src/testbed/libgnunettestbed.la \
490 libgnunetfs.la \
491 $(top_builddir)/src/util/libgnunetutil.la
492
493perf_gnunet_service_fs_p2p_SOURCES = \
494 perf_gnunet_service_fs_p2p.c
495perf_gnunet_service_fs_p2p_LDADD = \
496 libgnunetfstest.a \
497 $(top_builddir)/src/statistics/libgnunetstatistics.la \
498 $(top_builddir)/src/testbed/libgnunettestbed.la \
499 libgnunetfs.la \
500 $(top_builddir)/src/util/libgnunetutil.la
501
502perf_gnunet_service_fs_p2p_index_SOURCES = \
503 perf_gnunet_service_fs_p2p.c
504perf_gnunet_service_fs_p2p_index_LDADD = \
505 libgnunetfstest.a \
506 $(top_builddir)/src/statistics/libgnunetstatistics.la \
507 $(top_builddir)/src/testbed/libgnunettestbed.la \
508 libgnunetfs.la \
509 $(top_builddir)/src/util/libgnunetutil.la
510
511perf_gnunet_service_fs_p2p_dht_SOURCES = \
512 perf_gnunet_service_fs_p2p.c
513perf_gnunet_service_fs_p2p_dht_LDADD = \
514 libgnunetfstest.a \
515 $(top_builddir)/src/statistics/libgnunetstatistics.la \
516 $(top_builddir)/src/testbed/libgnunettestbed.la \
517 libgnunetfs.la \
518 $(top_builddir)/src/util/libgnunetutil.la
519
520perf_gnunet_service_fs_p2p_respect_SOURCES = \
521 perf_gnunet_service_fs_p2p_respect.c
522perf_gnunet_service_fs_p2p_respect_LDADD = \
523 libgnunetfstest.a \
524 $(top_builddir)/src/statistics/libgnunetstatistics.la \
525 $(top_builddir)/src/testbed/libgnunettestbed.la \
526 libgnunetfs.la \
527 $(top_builddir)/src/util/libgnunetutil.la
528
529
530test_gnunet_fs_psd.py: test_gnunet_fs_psd.py.in Makefile
531 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_fs_psd.py.in > test_gnunet_fs_psd.py
532 chmod +x test_gnunet_fs_psd.py
533
534test_gnunet_fs_rec.py: test_gnunet_fs_rec.py.in Makefile
535 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_fs_rec.py.in > test_gnunet_fs_rec.py
536 chmod +x test_gnunet_fs_rec.py
537
538test_gnunet_fs_ns.py: test_gnunet_fs_ns.py.in Makefile
539 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_fs_ns.py.in > test_gnunet_fs_ns.py
540 chmod +x test_gnunet_fs_ns.py
541
542test_gnunet_fs_idx.py: test_gnunet_fs_idx.py.in Makefile
543 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_fs_idx.py.in > test_gnunet_fs_idx.py
544 chmod +x test_gnunet_fs_idx.py
545
546
547EXTRA_DIST = \
548 fs_test_lib_data.conf \
549 perf_gnunet_service_fs_p2p.conf \
550 test_fs_data.conf \
551 test_fs_defaults.conf \
552 test_fs_download_data.conf \
553 test_fs_download_indexed.conf \
554 test_fs_file_information_data.conf \
555 test_fs_list_indexed_data.conf \
556 test_fs_namespace_data.conf \
557 test_fs_publish_data.conf \
558 test_fs_search_data.conf \
559 test_fs_unindex_data.conf \
560 test_gnunet_fs_idx_data.conf \
561 test_gnunet_fs_psd_data.conf \
562 test_gnunet_fs_rec_data.conf \
563 test_gnunet_fs_rec_data.tgz \
564 test_gnunet_fs_psd.py.in \
565 test_gnunet_fs_rec.py.in \
566 test_gnunet_fs_idx.py.in \
567 test_gnunet_service_fs_migration_data.conf \
568 test_gnunet_service_fs_p2p_cadet.conf \
569 test_pseudonym_data.conf
570
571CLEANFILES = $(check_SCRIPTS)