aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am565
1 files changed, 0 insertions, 565 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
deleted file mode 100644
index 3d8ec2bac..000000000
--- a/src/fs/Makefile.am
+++ /dev/null
@@ -1,565 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9pkgcfgdir= $(pkgdatadir)/config.d/
10
11libexecdir= $(pkglibdir)/libexec/
12
13pkgcfg_DATA = \
14 fs.conf
15
16plugindir = $(libdir)/gnunet
17
18
19lib_LTLIBRARIES = libgnunetfs.la
20
21plugin_LTLIBRARIES = \
22 libgnunet_plugin_block_fs.la
23
24noinst_LIBRARIES = libgnunetfstest.a
25
26libgnunetfs_la_SOURCES = \
27 fs_api.c fs_api.h fs.h \
28 fs_directory.c \
29 fs_dirmetascan.c \
30 fs_download.c \
31 fs_file_information.c \
32 fs_getopt.c \
33 fs_list_indexed.c \
34 fs_publish.c \
35 fs_publish_ksk.c \
36 fs_publish_ublock.c fs_publish_ublock.h \
37 fs_misc.c \
38 fs_namespace.c \
39 fs_search.c \
40 fs_sharetree.c \
41 fs_tree.c fs_tree.h \
42 fs_unindex.c \
43 fs_uri.c
44
45libgnunetfs_la_LIBADD = \
46 $(top_builddir)/src/datastore/libgnunetdatastore.la \
47 $(top_builddir)/src/statistics/libgnunetstatistics.la \
48 $(top_builddir)/src/util/libgnunetutil.la \
49 $(GN_LIBINTL) $(XLIB) $(LIBGCRYPT_LIBS) -lunistring
50
51if HAVE_LIBEXTRACTOR
52libgnunetfs_la_LIBADD += \
53 -lextractor
54endif
55
56libgnunetfs_la_LDFLAGS = \
57 $(GN_LIB_LDFLAGS) \
58 -version-info 3:1:1
59
60
61libgnunetfstest_a_SOURCES = \
62 fs_test_lib.c fs_test_lib.h
63
64libgnunetfstest_a_LIBADD = \
65 $(top_builddir)/src/testing/libgnunettesting.la \
66 $(top_builddir)/src/testbed/libgnunettestbed.la
67
68libexec_PROGRAMS = \
69 gnunet-helper-fs-publish \
70 gnunet-service-fs
71
72noinst_PROGRAMS = \
73 gnunet-fs-profiler \
74 gnunet-daemon-fsprofiler
75
76bin_PROGRAMS = \
77 gnunet-auto-share \
78 gnunet-directory \
79 gnunet-download \
80 gnunet-publish \
81 gnunet-search \
82 gnunet-fs \
83 gnunet-unindex
84
85gnunet_directory_SOURCES = \
86 gnunet-directory.c
87gnunet_directory_LDADD = \
88 libgnunetfs.la \
89 $(top_builddir)/src/util/libgnunetutil.la \
90 $(GN_LIBINTL)
91
92if HAVE_LIBEXTRACTOR
93gnunet_directory_LDADD += \
94 -lextractor
95endif
96
97gnunet_fs_profiler_SOURCES = \
98 gnunet-fs-profiler.c
99gnunet_fs_profiler_LDADD = \
100 $(top_builddir)/src/testing/libgnunettesting.la \
101 $(top_builddir)/src/testbed/libgnunettestbed.la \
102 $(top_builddir)/src/util/libgnunetutil.la \
103 $(GN_LIBINTL)
104
105gnunet_fs_SOURCES = \
106 gnunet-fs.c
107gnunet_fs_LDADD = \
108 libgnunetfs.la \
109 $(top_builddir)/src/util/libgnunetutil.la \
110 $(GN_LIBINTL)
111
112if HAVE_LIBEXTRACTOR
113gnunet_fs_LDADD += \
114 -lextractor
115endif
116
117gnunet_download_SOURCES = \
118 gnunet-download.c
119gnunet_download_LDADD = \
120 libgnunetfs.la \
121 $(top_builddir)/src/util/libgnunetutil.la \
122 $(GN_LIBINTL)
123
124gnunet_publish_SOURCES = \
125 gnunet-publish.c
126gnunet_publish_LDADD = \
127 $(top_builddir)/src/identity/libgnunetidentity.la \
128 libgnunetfs.la \
129 $(top_builddir)/src/util/libgnunetutil.la \
130 $(GN_LIBINTL)
131
132if HAVE_LIBEXTRACTOR
133gnunet_publish_LDADD += \
134 -lextractor
135endif
136
137gnunet_auto_share_SOURCES = \
138 gnunet-auto-share.c
139gnunet_auto_share_LDADD = \
140 $(top_builddir)/src/util/libgnunetutil.la \
141 $(GN_LIBINTL)
142
143if HAVE_LIBEXTRACTOR
144gnunet_auto_share_LDADD += \
145 -lextractor
146endif
147
148gnunet_helper_fs_publish_SOURCES = \
149 gnunet-helper-fs-publish.c
150gnunet_helper_fs_publish_LDADD = \
151 $(top_builddir)/src/util/libgnunetutil.la \
152 $(GN_LIBINTL)
153
154if HAVE_LIBEXTRACTOR
155gnunet_helper_fs_publish_LDADD += \
156 -lextractor
157endif
158
159gnunet_search_SOURCES = \
160 gnunet-search.c
161gnunet_search_LDADD = \
162 libgnunetfs.la \
163 $(top_builddir)/src/util/libgnunetutil.la \
164 $(GN_LIBINTL)
165
166if HAVE_LIBEXTRACTOR
167gnunet_search_LDADD += \
168 -lextractor
169endif
170
171
172gnunet_daemon_fsprofiler_SOURCES = \
173 gnunet-daemon-fsprofiler.c
174gnunet_daemon_fsprofiler_LDADD = \
175 libgnunetfs.la \
176 $(top_builddir)/src/statistics/libgnunetstatistics.la \
177 $(top_builddir)/src/util/libgnunetutil.la \
178 $(GN_LIBINTL)
179
180gnunet_service_fs_SOURCES = \
181 gnunet-service-fs.c gnunet-service-fs.h \
182 gnunet-service-fs_cp.c gnunet-service-fs_cp.h \
183 gnunet-service-fs_indexing.c gnunet-service-fs_indexing.h \
184 gnunet-service-fs_pe.c gnunet-service-fs_pe.h \
185 gnunet-service-fs_pr.c gnunet-service-fs_pr.h \
186 gnunet-service-fs_push.c gnunet-service-fs_push.h \
187 gnunet-service-fs_put.c gnunet-service-fs_put.h \
188 gnunet-service-fs_cadet_client.c gnunet-service-fs_cadet.h \
189 gnunet-service-fs_cadet_server.c
190gnunet_service_fs_LDADD = \
191 libgnunetfs.la \
192 $(top_builddir)/src/dht/libgnunetdht.la \
193 $(top_builddir)/src/block/libgnunetblock.la \
194 $(top_builddir)/src/datastore/libgnunetdatastore.la \
195 $(top_builddir)/src/statistics/libgnunetstatistics.la \
196 $(top_builddir)/src/cadet/libgnunetcadet.la \
197 $(top_builddir)/src/ats/libgnunetats.la \
198 $(top_builddir)/src/core/libgnunetcore.la \
199 $(top_builddir)/src/util/libgnunetutil.la \
200 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
201 $(GN_LIBINTL) -lm
202
203gnunet_unindex_SOURCES = \
204 gnunet-unindex.c
205gnunet_unindex_LDADD = \
206 libgnunetfs.la \
207 $(top_builddir)/src/util/libgnunetutil.la \
208 $(GN_LIBINTL)
209
210libgnunet_plugin_block_fs_la_SOURCES = \
211 plugin_block_fs.c
212libgnunet_plugin_block_fs_la_LIBADD = \
213 $(top_builddir)/src/block/libgnunetblockgroup.la \
214 $(top_builddir)/src/block/libgnunetblock.la \
215 libgnunetfs.la \
216 $(top_builddir)/src/util/libgnunetutil.la \
217 $(LTLIBINTL)
218libgnunet_plugin_block_fs_la_LDFLAGS = \
219 $(GN_PLUGIN_LDFLAGS)
220
221if HAVE_BENCHMARKS
222 FS_BENCHMARKS = \
223 perf_gnunet_service_fs_p2p \
224 perf_gnunet_service_fs_p2p_dht \
225 perf_gnunet_service_fs_p2p_index \
226 perf_gnunet_service_fs_p2p_respect
227endif
228
229check_PROGRAMS = \
230 test_plugin_block_fs \
231 test_fs_directory \
232 test_fs_download \
233 test_fs_download_cadet \
234 test_fs_download_indexed \
235 test_fs_download_persistence \
236 test_fs_file_information \
237 test_fs_getopt \
238 test_fs_list_indexed \
239 test_fs_namespace \
240 test_fs_namespace_list_updateable \
241 test_fs_publish \
242 test_fs_publish_persistence \
243 test_fs_search \
244 test_fs_search_with_and \
245 test_fs_search_probes \
246 test_fs_search_persistence \
247 test_fs_start_stop \
248 test_fs_test_lib \
249 test_fs_unindex \
250 test_fs_unindex_persistence \
251 test_fs_uri \
252 test_gnunet_service_fs_migration \
253 test_gnunet_service_fs_p2p \
254 test_gnunet_service_fs_p2p_cadet \
255 $(FS_BENCHMARKS)
256
257test_plugin_block_fs_SOURCES = \
258 test_plugin_block_fs.c
259test_plugin_block_fs_LDADD = \
260 $(top_builddir)/src/block/libgnunetblock.la \
261 $(top_builddir)/src/util/libgnunetutil.la
262
263if HAVE_PYTHON
264check_SCRIPTS = \
265 test_gnunet_fs_rec.py \
266 test_gnunet_fs_idx.py
267
268if HAVE_LIBEXTRACTOR
269check_SCRIPTS += \
270 test_gnunet_fs_psd.py
271endif
272endif
273
274
275if ENABLE_TEST_RUN
276AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; $(MONKEY)
277TESTS = \
278 test_fs_directory \
279 test_fs_download \
280 test_fs_download_indexed \
281 test_fs_download_persistence \
282 test_fs_file_information \
283 test_fs_list_indexed \
284 test_fs_namespace \
285 test_fs_namespace_list_updateable \
286 test_fs_publish \
287 test_fs_publish_persistence \
288 test_fs_search \
289 test_fs_search_with_and \
290 test_fs_search_probes \
291 test_fs_search_persistence \
292 test_fs_start_stop \
293 test_fs_unindex \
294 test_fs_unindex_persistence \
295 test_fs_uri \
296 test_fs_test_lib \
297 test_gnunet_service_fs_migration \
298 test_gnunet_service_fs_p2p \
299 test_gnunet_service_fs_p2p_cadet \
300 perf_gnunet_service_fs_p2p \
301 perf_gnunet_service_fs_p2p_index \
302 perf_gnunet_service_fs_p2p_respect \
303 $(check_SCRIPTS)
304endif
305
306
307test_fs_directory_SOURCES = \
308 test_fs_directory.c
309test_fs_directory_LDADD = \
310 libgnunetfs.la \
311 $(top_builddir)/src/util/libgnunetutil.la
312
313if HAVE_LIBEXTRACTOR
314test_fs_directory_LDADD += \
315 -lextractor
316endif
317
318
319test_fs_download_SOURCES = \
320 test_fs_download.c
321test_fs_download_LDADD = \
322 $(top_builddir)/src/testing/libgnunettesting.la \
323 libgnunetfs.la \
324 $(top_builddir)/src/util/libgnunetutil.la
325
326test_fs_download_indexed_SOURCES = \
327 test_fs_download.c
328test_fs_download_indexed_LDADD = \
329 $(top_builddir)/src/testing/libgnunettesting.la \
330 libgnunetfs.la \
331 $(top_builddir)/src/util/libgnunetutil.la
332
333test_fs_download_cadet_SOURCES = \
334 test_fs_download.c
335test_fs_download_cadet_LDADD = \
336 $(top_builddir)/src/testing/libgnunettesting.la \
337 libgnunetfs.la \
338 $(top_builddir)/src/util/libgnunetutil.la
339
340test_fs_download_persistence_SOURCES = \
341 test_fs_download_persistence.c
342test_fs_download_persistence_LDADD = \
343 $(top_builddir)/src/testing/libgnunettesting.la \
344 libgnunetfs.la \
345 $(top_builddir)/src/util/libgnunetutil.la
346
347test_fs_file_information_SOURCES = \
348 test_fs_file_information.c
349test_fs_file_information_LDADD = \
350 libgnunetfs.la \
351 $(top_builddir)/src/util/libgnunetutil.la
352
353if HAVE_LIBEXTRACTOR
354test_fs_file_information_LDADD += \
355 -lextractor
356endif
357
358
359test_fs_getopt_SOURCES = \
360 test_fs_getopt.c
361test_fs_getopt_LDADD = \
362 libgnunetfs.la \
363 $(top_builddir)/src/util/libgnunetutil.la
364
365test_fs_list_indexed_SOURCES = \
366 test_fs_list_indexed.c
367test_fs_list_indexed_LDADD = \
368 $(top_builddir)/src/testing/libgnunettesting.la \
369 libgnunetfs.la \
370 $(top_builddir)/src/util/libgnunetutil.la
371
372test_fs_namespace_SOURCES = \
373 test_fs_namespace.c
374test_fs_namespace_LDADD = \
375 $(top_builddir)/src/testing/libgnunettesting.la \
376 libgnunetfs.la \
377 $(top_builddir)/src/util/libgnunetutil.la
378
379test_fs_namespace_list_updateable_SOURCES = \
380 test_fs_namespace_list_updateable.c
381test_fs_namespace_list_updateable_LDADD = \
382 $(top_builddir)/src/testing/libgnunettesting.la \
383 libgnunetfs.la \
384 $(top_builddir)/src/util/libgnunetutil.la
385
386test_fs_publish_SOURCES = \
387 test_fs_publish.c
388test_fs_publish_LDADD = \
389 $(top_builddir)/src/testing/libgnunettesting.la \
390 libgnunetfs.la \
391 $(top_builddir)/src/util/libgnunetutil.la
392
393test_fs_publish_persistence_SOURCES = \
394 test_fs_publish_persistence.c
395test_fs_publish_persistence_LDADD = \
396 $(top_builddir)/src/testing/libgnunettesting.la \
397 libgnunetfs.la \
398 $(top_builddir)/src/util/libgnunetutil.la
399
400test_fs_search_SOURCES = \
401 test_fs_search.c
402test_fs_search_LDADD = \
403 $(top_builddir)/src/testing/libgnunettesting.la \
404 libgnunetfs.la \
405 $(top_builddir)/src/util/libgnunetutil.la
406
407test_fs_search_with_and_SOURCES = \
408 test_fs_search_with_and.c
409test_fs_search_with_and_LDADD = \
410 $(top_builddir)/src/testing/libgnunettesting.la \
411 libgnunetfs.la \
412 $(top_builddir)/src/util/libgnunetutil.la
413
414test_fs_search_probes_SOURCES = \
415 test_fs_search_probes.c
416test_fs_search_probes_LDADD = \
417 $(top_builddir)/src/testing/libgnunettesting.la \
418 libgnunetfs.la \
419 $(top_builddir)/src/util/libgnunetutil.la
420
421test_fs_search_persistence_SOURCES = \
422 test_fs_search_persistence.c
423test_fs_search_persistence_LDADD = \
424 $(top_builddir)/src/testing/libgnunettesting.la \
425 libgnunetfs.la \
426 $(top_builddir)/src/util/libgnunetutil.la
427
428test_fs_start_stop_SOURCES = \
429 test_fs_start_stop.c
430test_fs_start_stop_LDADD = \
431 $(top_builddir)/src/testing/libgnunettesting.la \
432 libgnunetfs.la \
433 $(top_builddir)/src/util/libgnunetutil.la
434
435test_fs_unindex_SOURCES = \
436 test_fs_unindex.c
437test_fs_unindex_LDADD = \
438 $(top_builddir)/src/testing/libgnunettesting.la \
439 libgnunetfs.la \
440 $(top_builddir)/src/util/libgnunetutil.la
441
442test_fs_unindex_persistence_SOURCES = \
443 test_fs_unindex_persistence.c
444test_fs_unindex_persistence_LDADD = \
445 $(top_builddir)/src/testing/libgnunettesting.la \
446 libgnunetfs.la \
447 $(top_builddir)/src/util/libgnunetutil.la
448
449test_fs_uri_SOURCES = \
450 test_fs_uri.c
451test_fs_uri_LDADD = \
452 libgnunetfs.la \
453 $(top_builddir)/src/util/libgnunetutil.la
454
455test_fs_test_lib_SOURCES = \
456 test_fs_test_lib.c
457test_fs_test_lib_LDADD = \
458 libgnunetfstest.a \
459 $(top_builddir)/src/testbed/libgnunettestbed.la \
460 libgnunetfs.la \
461 $(top_builddir)/src/util/libgnunetutil.la
462
463test_gnunet_service_fs_p2p_SOURCES = \
464 test_gnunet_service_fs_p2p.c
465test_gnunet_service_fs_p2p_LDADD = \
466 libgnunetfstest.a \
467 $(top_builddir)/src/testbed/libgnunettestbed.la \
468 libgnunetfs.la \
469 $(top_builddir)/src/util/libgnunetutil.la
470
471test_gnunet_service_fs_p2p_cadet_SOURCES = \
472 test_gnunet_service_fs_p2p.c
473test_gnunet_service_fs_p2p_cadet_LDADD = \
474 libgnunetfstest.a \
475 $(top_builddir)/src/testbed/libgnunettestbed.la \
476 libgnunetfs.la \
477 $(top_builddir)/src/util/libgnunetutil.la
478
479test_gnunet_service_fs_migration_SOURCES = \
480 test_gnunet_service_fs_migration.c
481test_gnunet_service_fs_migration_LDADD = \
482 libgnunetfstest.a \
483 $(top_builddir)/src/testbed/libgnunettestbed.la \
484 libgnunetfs.la \
485 $(top_builddir)/src/util/libgnunetutil.la
486
487perf_gnunet_service_fs_p2p_SOURCES = \
488 perf_gnunet_service_fs_p2p.c
489perf_gnunet_service_fs_p2p_LDADD = \
490 libgnunetfstest.a \
491 $(top_builddir)/src/statistics/libgnunetstatistics.la \
492 $(top_builddir)/src/testbed/libgnunettestbed.la \
493 libgnunetfs.la \
494 $(top_builddir)/src/util/libgnunetutil.la
495
496perf_gnunet_service_fs_p2p_index_SOURCES = \
497 perf_gnunet_service_fs_p2p.c
498perf_gnunet_service_fs_p2p_index_LDADD = \
499 libgnunetfstest.a \
500 $(top_builddir)/src/statistics/libgnunetstatistics.la \
501 $(top_builddir)/src/testbed/libgnunettestbed.la \
502 libgnunetfs.la \
503 $(top_builddir)/src/util/libgnunetutil.la
504
505perf_gnunet_service_fs_p2p_dht_SOURCES = \
506 perf_gnunet_service_fs_p2p.c
507perf_gnunet_service_fs_p2p_dht_LDADD = \
508 libgnunetfstest.a \
509 $(top_builddir)/src/statistics/libgnunetstatistics.la \
510 $(top_builddir)/src/testbed/libgnunettestbed.la \
511 libgnunetfs.la \
512 $(top_builddir)/src/util/libgnunetutil.la
513
514perf_gnunet_service_fs_p2p_respect_SOURCES = \
515 perf_gnunet_service_fs_p2p_respect.c
516perf_gnunet_service_fs_p2p_respect_LDADD = \
517 libgnunetfstest.a \
518 $(top_builddir)/src/statistics/libgnunetstatistics.la \
519 $(top_builddir)/src/testbed/libgnunettestbed.la \
520 libgnunetfs.la \
521 $(top_builddir)/src/util/libgnunetutil.la
522
523
524test_gnunet_fs_psd.py: test_gnunet_fs_psd.py.in Makefile
525 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_fs_psd.py.in > test_gnunet_fs_psd.py
526 chmod +x test_gnunet_fs_psd.py
527
528test_gnunet_fs_rec.py: test_gnunet_fs_rec.py.in Makefile
529 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_fs_rec.py.in > test_gnunet_fs_rec.py
530 chmod +x test_gnunet_fs_rec.py
531
532test_gnunet_fs_ns.py: test_gnunet_fs_ns.py.in Makefile
533 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_fs_ns.py.in > test_gnunet_fs_ns.py
534 chmod +x test_gnunet_fs_ns.py
535
536test_gnunet_fs_idx.py: test_gnunet_fs_idx.py.in Makefile
537 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_fs_idx.py.in > test_gnunet_fs_idx.py
538 chmod +x test_gnunet_fs_idx.py
539
540
541EXTRA_DIST = \
542 fs_test_lib_data.conf \
543 perf_gnunet_service_fs_p2p.conf \
544 test_fs_data.conf \
545 test_fs_defaults.conf \
546 test_fs_download_data.conf \
547 test_fs_download_indexed.conf \
548 test_fs_file_information_data.conf \
549 test_fs_list_indexed_data.conf \
550 test_fs_namespace_data.conf \
551 test_fs_publish_data.conf \
552 test_fs_search_data.conf \
553 test_fs_unindex_data.conf \
554 test_gnunet_fs_idx_data.conf \
555 test_gnunet_fs_psd_data.conf \
556 test_gnunet_fs_rec_data.conf \
557 test_gnunet_fs_rec_data.tgz \
558 test_gnunet_fs_psd.py.in \
559 test_gnunet_fs_rec.py.in \
560 test_gnunet_fs_idx.py.in \
561 test_gnunet_service_fs_migration_data.conf \
562 test_gnunet_service_fs_p2p_cadet.conf \
563 test_pseudonym_data.conf
564
565CLEANFILES = $(check_SCRIPTS)