aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am39
1 files changed, 13 insertions, 26 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 57b096b96..2659f7e6a 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -76,6 +76,9 @@ bin_PROGRAMS = \
76 $(DO_NONPOSIX_GNSIMPORT) \ 76 $(DO_NONPOSIX_GNSIMPORT) \
77 gnunet-gns 77 gnunet-gns
78 78
79noinst_PROGRAMS = \
80 gnunet-gns-benchmark
81
79if HAVE_MHD 82if HAVE_MHD
80if LINUX 83if LINUX
81bin_PROGRAMS += gnunet-bcd 84bin_PROGRAMS += gnunet-bcd
@@ -89,17 +92,10 @@ plugin_LTLIBRARIES = \
89 libgnunet_plugin_gnsrecord_gns.la 92 libgnunet_plugin_gnsrecord_gns.la
90 93
91 94
92if HAVE_MHD
93if HAVE_JSON
94plugin_LTLIBRARIES += libgnunet_plugin_rest_gns.la
95endif
96endif
97
98libgnunet_plugin_gnsrecord_gns_la_SOURCES = \ 95libgnunet_plugin_gnsrecord_gns_la_SOURCES = \
99 plugin_gnsrecord_gns.c 96 plugin_gnsrecord_gns.c
100libgnunet_plugin_gnsrecord_gns_la_LIBADD = \ 97libgnunet_plugin_gnsrecord_gns_la_LIBADD = \
101 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 98 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
102 $(top_builddir)/src/dns/libgnunetdnsparser.la \
103 $(top_builddir)/src/util/libgnunetutil.la \ 99 $(top_builddir)/src/util/libgnunetutil.la \
104 $(LTLIBINTL) 100 $(LTLIBINTL)
105libgnunet_plugin_gnsrecord_gns_la_LDFLAGS = \ 101libgnunet_plugin_gnsrecord_gns_la_LDFLAGS = \
@@ -114,6 +110,14 @@ gnunet_gns_LDADD = \
114 $(top_builddir)/src/util/libgnunetutil.la \ 110 $(top_builddir)/src/util/libgnunetutil.la \
115 $(GN_LIBINTL) 111 $(GN_LIBINTL)
116 112
113gnunet_gns_benchmark_SOURCES = \
114 gnunet-gns-benchmark.c
115gnunet_gns_benchmark_LDADD = \
116 libgnunetgns.la \
117 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
118 $(top_builddir)/src/util/libgnunetutil.la \
119 $(GN_LIBINTL)
120
117 121
118gnunet_bcd_SOURCES = \ 122gnunet_bcd_SOURCES = \
119 gnunet-bcd.c 123 gnunet-bcd.c
@@ -129,8 +133,6 @@ gnunet_dns2gns_LDADD = \
129 libgnunetgns.la \ 133 libgnunetgns.la \
130 $(top_builddir)/src/util/libgnunetutil.la \ 134 $(top_builddir)/src/util/libgnunetutil.la \
131 $(top_builddir)/src/identity/libgnunetidentity.la \ 135 $(top_builddir)/src/identity/libgnunetidentity.la \
132 $(top_builddir)/src/dns/libgnunetdnsparser.la \
133 $(top_builddir)/src/dns/libgnunetdnsstub.la \
134 $(GN_LIBINTL) 136 $(GN_LIBINTL)
135 137
136if LINUX 138if LINUX
@@ -195,10 +197,7 @@ gnunet_service_gns_LDADD = \
195 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 197 $(top_builddir)/src/statistics/libgnunetstatistics.la \
196 $(top_builddir)/src/util/libgnunetutil.la \ 198 $(top_builddir)/src/util/libgnunetutil.la \
197 $(top_builddir)/src/dns/libgnunetdns.la \ 199 $(top_builddir)/src/dns/libgnunetdns.la \
198 $(top_builddir)/src/dns/libgnunetdnsparser.la \
199 $(top_builddir)/src/dns/libgnunetdnsstub.la \
200 $(top_builddir)/src/dht/libgnunetdht.la \ 200 $(top_builddir)/src/dht/libgnunetdht.la \
201 $(top_builddir)/src/tun/libgnunettun.la \
202 $(top_builddir)/src/namecache/libgnunetnamecache.la \ 201 $(top_builddir)/src/namecache/libgnunetnamecache.la \
203 $(USE_VPN) \ 202 $(USE_VPN) \
204 $(GN_LIBINTL) 203 $(GN_LIBINTL)
@@ -233,19 +232,6 @@ libgnunet_plugin_block_gns_la_LIBADD = \
233libgnunet_plugin_block_gns_la_LDFLAGS = \ 232libgnunet_plugin_block_gns_la_LDFLAGS = \
234 $(GN_PLUGIN_LDFLAGS) 233 $(GN_PLUGIN_LDFLAGS)
235 234
236libgnunet_plugin_rest_gns_la_SOURCES = \
237 plugin_rest_gns.c
238libgnunet_plugin_rest_gns_la_LIBADD = \
239 libgnunetgns.la \
240 $(top_builddir)/src/rest/libgnunetrest.la \
241 $(top_builddir)/src/identity/libgnunetidentity.la \
242 $(top_builddir)/src/jsonapi/libgnunetjsonapi.la \
243 $(top_builddir)/src/jsonapi/libgnunetjsonapiutils.la \
244 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
245 $(LTLIBINTL) -ljansson -lmicrohttpd
246libgnunet_plugin_rest_gns_la_LDFLAGS = \
247 $(GN_PLUGIN_LDFLAGS)
248
249 235
250check_SCRIPTS = \ 236check_SCRIPTS = \
251 test_gns_lookup.sh \ 237 test_gns_lookup.sh \
@@ -253,9 +239,10 @@ check_SCRIPTS = \
253 test_gns_txt_lookup.sh\ 239 test_gns_txt_lookup.sh\
254 test_gns_mx_lookup.sh \ 240 test_gns_mx_lookup.sh \
255 test_gns_gns2dns_lookup.sh \ 241 test_gns_gns2dns_lookup.sh \
242 test_gns_gns2dns_cname_lookup.sh \
256 test_gns_dht_lookup.sh\ 243 test_gns_dht_lookup.sh\
257 test_gns_delegated_lookup.sh \ 244 test_gns_delegated_lookup.sh \
258 test_gns_plus_lookup.sh\ 245 test_gns_at_lookup.sh\
259 test_gns_zkey_lookup.sh\ 246 test_gns_zkey_lookup.sh\
260 test_gns_rel_expiration.sh\ 247 test_gns_rel_expiration.sh\
261 test_gns_soa_lookup.sh\ 248 test_gns_soa_lookup.sh\