aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am322
1 files changed, 0 insertions, 322 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
deleted file mode 100644
index d49e0c5c8..000000000
--- a/src/gns/Makefile.am
+++ /dev/null
@@ -1,322 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if HAVE_GLIBCNSS
5NSS_SUBDIR = nss
6endif
7
8SUBDIRS = . $(NSS_SUBDIR)
9
10pkgdata_DATA = \
11 gnunet-gns-proxy-ca.template
12
13if HAVE_LIBIDN
14 LIBIDN= -lidn
15else
16 LIBIDN=
17endif
18
19if HAVE_LIBIDN2
20 LIBIDN2= -lidn2
21else
22 LIBIDN2=
23endif
24
25USE_VPN = $(top_builddir)/src/vpn/libgnunetvpn.la
26
27if USE_COVERAGE
28 AM_CFLAGS = --coverage -O0
29endif
30
31pkgcfgdir = $(pkgdatadir)/config.d/
32
33libexecdir= $(pkglibdir)/libexec/
34
35plugindir = $(libdir)/gnunet
36
37pkgcfg_DATA = \
38 gns.conf
39dist_pkgcfg_DATA = \
40 tlds.conf
41
42lib_LTLIBRARIES = \
43 libgnunetgns.la
44
45
46if HAVE_GNUTLS
47if HAVE_LIBGNURL
48 DO_PROXY=gnunet-gns-proxy
49LIB_GNURL=@LIBGNURL@
50CPP_GNURL=@LIBGNURL_CPPFLAGS@
51else
52if HAVE_LIBCURL
53 DO_PROXY=gnunet-gns-proxy
54LIB_GNURL=@LIBCURL@
55CPP_GNURL=@LIBCURL_CPPFLAGS@
56endif
57endif
58endif
59
60libexec_PROGRAMS = \
61 gnunet-service-gns \
62 gnunet-dns2gns \
63 $(DO_PROXY)
64
65bin_PROGRAMS = \
66 gnunet-gns
67
68noinst_PROGRAMS = \
69 gnunet-gns-benchmark
70
71if HAVE_PDFLATEX
72bin_PROGRAMS += gnunet-bcd
73endif
74
75REST_PLUGIN = libgnunet_plugin_rest_gns.la
76
77plugin_LTLIBRARIES = \
78 libgnunet_plugin_block_gns.la \
79 libgnunet_plugin_gnsrecord_gns.la \
80 $(REST_PLUGIN)
81
82
83bin_SCRIPTS = \
84 gnunet-gns-proxy-setup-ca
85
86gnunet-gns-proxy-setup-ca: gnunet-gns-proxy-setup-ca.in Makefile
87 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/gnunet-gns-proxy-setup-ca.in > gnunet-gns-proxy-setup-ca
88 @chmod +x gnunet-gns-proxy-setup-ca
89
90test_gnunet_gns.sh: test_gnunet_gns.sh.in Makefile
91 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_gns.sh.in > test_gnunet_gns.sh
92 @chmod +x test_gnunet_gns.sh
93
94CLEANFILES = test_gnunet_gns.sh
95
96libgnunet_plugin_rest_gns_la_SOURCES = \
97 plugin_rest_gns.c
98libgnunet_plugin_rest_gns_la_LIBADD = \
99 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
100 $(top_builddir)/src/gnsrecord/libgnunetgnsrecordjson.la \
101 libgnunetgns.la \
102 $(top_builddir)/src/rest/libgnunetrest.la \
103 $(top_builddir)/src/identity/libgnunetidentity.la \
104 $(top_builddir)/src/json/libgnunetjson.la \
105 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
106 $(LTLIBINTL) -ljansson $(MHD_LIBS)
107libgnunet_plugin_rest_gns_la_LDFLAGS = \
108 $(GN_PLUGIN_LDFLAGS)
109libgnunet_plugin_rest_gns_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
110
111
112libgnunet_plugin_gnsrecord_gns_la_SOURCES = \
113 plugin_gnsrecord_gns.c
114libgnunet_plugin_gnsrecord_gns_la_LIBADD = \
115 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
116 $(top_builddir)/src/identity/libgnunetidentity.la \
117 $(top_builddir)/src/util/libgnunetutil.la \
118 $(LTLIBINTL)
119libgnunet_plugin_gnsrecord_gns_la_LDFLAGS = \
120 $(GN_PLUGIN_LDFLAGS)
121
122
123gnunet_gns_SOURCES = \
124 gnunet-gns.c
125gnunet_gns_LDADD = \
126 libgnunetgns.la \
127 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
128 $(top_builddir)/src/identity/libgnunetidentity.la \
129 $(top_builddir)/src/util/libgnunetutil.la \
130 $(LIBIDN) $(LIBIDN2) \
131 $(GN_LIBINTL)
132
133gnunet_gns_benchmark_SOURCES = \
134 gnunet-gns-benchmark.c
135gnunet_gns_benchmark_LDADD = \
136 libgnunetgns.la \
137 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
138 $(top_builddir)/src/identity/libgnunetidentity.la \
139 $(top_builddir)/src/util/libgnunetutil.la \
140 $(GN_LIBINTL)
141
142
143gnunet_bcd_SOURCES = \
144 gnunet-bcd.c
145gnunet_bcd_LDADD = \
146 $(top_builddir)/src/util/libgnunetutil.la \
147 $(top_builddir)/src/identity/libgnunetidentity.la \
148 $(GN_LIBINTL) $(MHD_LIBS)
149gnunet_bcd_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
150
151
152gnunet_dns2gns_SOURCES = \
153 gnunet-dns2gns.c
154gnunet_dns2gns_LDADD = \
155 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
156 libgnunetgns.la \
157 $(top_builddir)/src/util/libgnunetutil.la \
158 $(USE_VPN) \
159 $(top_builddir)/src/identity/libgnunetidentity.la \
160 $(GN_LIBINTL)
161
162if HAVE_SUDO
163SUDO_OR_DOAS_BINARY= $(SUDO_BINARY) -n
164else
165if HAVE_DOAS_BINARY
166SUDO_OR_DOAS_BINARY= $(DOAS_BINARY)
167endif
168endif
169
170if LINUX
171HIJACKBIN = gnunet-dns2gns
172install-exec-hook:
173 $(SUDO_OR_DOAS_BINARY) setcap 'cap_net_bind_service=+ep' $(DESTDIR)$(libexecdir)/gnunet-dns2gns || true
174else
175install-exec-hook:
176endif
177
178gnunet_gns_proxy_SOURCES = \
179 gnunet-gns-proxy.c
180gnunet_gns_proxy_LDADD = $(MHD_LIBS) $(LIB_GNURL) -lgnutls \
181 libgnunetgns.la \
182 $(top_builddir)/src/identity/libgnunetidentity.la \
183 $(top_builddir)/src/util/libgnunetutil.la \
184 $(GN_LIBINTL)
185if HAVE_GNUTLS_DANE
186gnunet_gns_proxy_LDADD += -lgnutls-dane
187endif
188gnunet_gns_proxy_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
189
190test_gns_proxy_SOURCES = \
191 test_gns_proxy.c
192test_gns_proxy_LDADD = $(MHD_LIBS) $(LIB_GNURL) -lgnutls \
193 $(top_builddir)/src/util/libgnunetutil.la \
194 $(GN_LIBINTL)
195test_gns_proxy_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
196
197#gnunet_gns_import_SOURCES = \
198# gnunet-gns-import.c
199#gnunet_gns_import_LDADD = \
200# $(top_builddir)/src/identity/libgnunetidentity.la \
201# $(top_builddir)/src/namestore/libgnunetnamestore.la \
202# $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
203# $(top_builddir)/src/util/libgnunetutil.la \
204# $(GN_LIBINTL)
205
206
207gnunet_service_gns_SOURCES = \
208 gnunet-service-gns.c gnunet-service-gns.h \
209 gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \
210 gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h
211gnunet_service_gns_LDADD = \
212 -lm \
213 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
214 $(top_builddir)/src/identity/libgnunetidentity.la \
215 $(top_builddir)/src/revocation/libgnunetrevocation.la \
216 $(top_builddir)/src/statistics/libgnunetstatistics.la \
217 $(top_builddir)/src/util/libgnunetutil.la \
218 $(top_builddir)/src/dns/libgnunetdns.la \
219 $(top_builddir)/src/dht/libgnunetdht.la \
220 $(top_builddir)/src/namecache/libgnunetnamecache.la \
221 $(LIBIDN) $(LIBIDN2) \
222 $(GN_LIBINTL)
223
224
225libgnunetgns_la_SOURCES = \
226 gns_api.c gns_api.h \
227 gns_tld_api.c gns.h
228libgnunetgns_la_LIBADD = \
229 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
230 $(top_builddir)/src/identity/libgnunetidentity.la \
231 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la
232libgnunetgns_la_LDFLAGS = \
233 $(GN_LIBINTL) \
234 $(GN_LIB_LDFLAGS)
235
236
237libgnunet_plugin_block_gns_la_SOURCES = \
238 plugin_block_gns.c
239libgnunet_plugin_block_gns_la_LIBADD = \
240 $(top_builddir)/src/util/libgnunetutil.la \
241 $(top_builddir)/src/block/libgnunetblock.la \
242 $(top_builddir)/src/block/libgnunetblockgroup.la \
243 $(top_builddir)/src/identity/libgnunetidentity.la \
244 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la
245libgnunet_plugin_block_gns_la_LDFLAGS = \
246 $(GN_LIBINTL) \
247 $(GN_PLUGIN_LDFLAGS)
248
249if HAVE_GNUTLS
250if HAVE_LIBGNURL
251check_PROGRAMS = \
252 test_gns_proxy
253endif
254endif
255
256check_SCRIPTS = \
257 test_gns_lookup.sh \
258 test_gns_config_lookup.sh \
259 test_gns_ipv6_lookup.sh\
260 test_gns_txt_lookup.sh\
261 test_gns_caa_lookup.sh\
262 test_gns_mx_lookup.sh \
263 test_gns_gns2dns_lookup.sh \
264 test_gns_gns2dns_zkey_lookup.sh \
265 test_gns_gns2dns_cname_lookup.sh \
266 test_gns_dht_lookup.sh\
267 test_gns_delegated_lookup.sh \
268 test_gns_at_lookup.sh\
269 test_gns_zkey_lookup.sh\
270 test_gns_rel_expiration.sh\
271 test_gns_soa_lookup.sh\
272 test_gns_revocation.sh\
273 test_gns_redirect_lookup.sh
274
275if HAVE_GNUTLS
276if HAVE_LIBGNURL
277check_SCRIPTS += \
278 test_proxy.sh
279endif
280endif
281check_SCRIPTS += \
282 test_plugin_rest_gns.sh
283
284EXTRA_DIST = \
285 test_gns_defaults.conf \
286 test_gns_lookup.conf \
287 test_gns_proxy.conf \
288 test_gns_simple_lookup.conf \
289 openssl.cnf \
290 gnunet-gns-proxy-setup-ca.in \
291 zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \
292 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
293 zonefiles/test_zonekey \
294 test_gns_lookup.sh \
295 test_gns_config_lookup.sh \
296 test_gns_ipv6_lookup.sh\
297 test_gns_txt_lookup.sh\
298 test_gns_caa_lookup.sh\
299 test_gns_mx_lookup.sh \
300 test_gns_gns2dns_lookup.sh \
301 test_gns_gns2dns_zkey_lookup.sh \
302 test_gns_gns2dns_cname_lookup.sh \
303 test_gns_dht_lookup.sh\
304 test_gns_delegated_lookup.sh \
305 test_gns_at_lookup.sh\
306 test_gns_zkey_lookup.sh\
307 test_gns_rel_expiration.sh\
308 test_gns_soa_lookup.sh\
309 test_gns_revocation.sh\
310 test_gns_redirect_lookup.sh\
311 test_proxy.sh\
312 test_plugin_rest_gns.sh\
313 test_proxy.sh \
314 $(pkgdata_DATA) \
315 test_gnunet_gns.sh.in
316
317if ENABLE_TEST_RUN
318if HAVE_SQLITE
319 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
320 TESTS = $(check_SCRIPTS)
321endif
322endif