aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am301
1 files changed, 0 insertions, 301 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
deleted file mode 100644
index 3aaa734f2..000000000
--- a/src/gns/Makefile.am
+++ /dev/null
@@ -1,301 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if HAVE_GLIBCNSS
5NSS_SUBDIR = nss
6endif
7
8SUBDIRS = . $(NSS_SUBDIR)
9
10pkgdata_DATA = \
11 gnunet-gns-proxy-ca.template
12
13if HAVE_LIBIDN
14 LIBIDN= -lidn
15else
16 LIBIDN=
17endif
18
19if HAVE_LIBIDN2
20 LIBIDN2= -lidn2
21else
22 LIBIDN2=
23endif
24
25EXTRA_DIST = \
26 test_gns_defaults.conf \
27 test_gns_lookup.conf \
28 test_gns_proxy.conf \
29 test_gns_simple_lookup.conf \
30 openssl.cnf \
31 gnunet-gns-proxy-setup-ca.in \
32 zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \
33 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
34 zonefiles/test_zonekey \
35 $(check_SCRIPTS) \
36 $(pkgdata_DATA) \
37 test_gnunet_gns.sh.in
38
39USE_VPN = $(top_builddir)/src/vpn/libgnunetvpn.la
40
41if USE_COVERAGE
42 AM_CFLAGS = --coverage -O0
43endif
44
45pkgcfgdir = $(pkgdatadir)/config.d/
46
47libexecdir= $(pkglibdir)/libexec/
48
49plugindir = $(libdir)/gnunet
50
51pkgcfg_DATA = \
52 gns.conf
53
54lib_LTLIBRARIES = \
55 libgnunetgns.la
56
57
58if HAVE_GNUTLS
59if HAVE_LIBGNURL
60 DO_PROXY=gnunet-gns-proxy
61LIB_GNURL=@LIBGNURL@
62CPP_GNURL=@LIBGNURL_CPPFLAGS@
63else
64if HAVE_LIBCURL
65 DO_PROXY=gnunet-gns-proxy
66LIB_GNURL=@LIBCURL@
67CPP_GNURL=@LIBCURL_CPPFLAGS@
68endif
69endif
70endif
71
72libexec_PROGRAMS = \
73 gnunet-service-gns \
74 gnunet-dns2gns \
75 $(DO_PROXY)
76
77bin_PROGRAMS = \
78 gnunet-gns
79
80noinst_PROGRAMS = \
81 gnunet-gns-benchmark
82
83bin_PROGRAMS += gnunet-bcd
84
85REST_PLUGIN = libgnunet_plugin_rest_gns.la
86
87plugin_LTLIBRARIES = \
88 libgnunet_plugin_block_gns.la \
89 libgnunet_plugin_gnsrecord_gns.la \
90 $(REST_PLUGIN)
91
92
93bin_SCRIPTS = \
94 gnunet-gns-proxy-setup-ca
95
96gnunet-gns-proxy-setup-ca: gnunet-gns-proxy-setup-ca.in Makefile
97 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/gnunet-gns-proxy-setup-ca.in > gnunet-gns-proxy-setup-ca
98 @chmod +x gnunet-gns-proxy-setup-ca
99
100test_gnunet_gns.sh: test_gnunet_gns.sh.in Makefile
101 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/test_gnunet_gns.sh.in > test_gnunet_gns.sh
102 @chmod +x test_gnunet_gns.sh
103
104CLEANFILES = test_gnunet_gns.sh
105
106libgnunet_plugin_rest_gns_la_SOURCES = \
107 plugin_rest_gns.c
108libgnunet_plugin_rest_gns_la_LIBADD = \
109 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
110 $(top_builddir)/src/gnsrecord/libgnunetgnsrecordjson.la \
111 libgnunetgns.la \
112 $(top_builddir)/src/rest/libgnunetrest.la \
113 $(top_builddir)/src/identity/libgnunetidentity.la \
114 $(top_builddir)/src/json/libgnunetjson.la \
115 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
116 $(LTLIBINTL) -ljansson $(MHD_LIBS)
117libgnunet_plugin_rest_gns_la_LDFLAGS = \
118 $(GN_PLUGIN_LDFLAGS)
119libgnunet_plugin_rest_gns_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
120
121
122libgnunet_plugin_gnsrecord_gns_la_SOURCES = \
123 plugin_gnsrecord_gns.c
124libgnunet_plugin_gnsrecord_gns_la_LIBADD = \
125 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
126 $(top_builddir)/src/identity/libgnunetidentity.la \
127 $(top_builddir)/src/util/libgnunetutil.la \
128 $(LTLIBINTL)
129libgnunet_plugin_gnsrecord_gns_la_LDFLAGS = \
130 $(GN_PLUGIN_LDFLAGS)
131
132
133gnunet_gns_SOURCES = \
134 gnunet-gns.c
135gnunet_gns_LDADD = \
136 libgnunetgns.la \
137 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
138 $(top_builddir)/src/identity/libgnunetidentity.la \
139 $(top_builddir)/src/util/libgnunetutil.la \
140 $(LIBIDN) $(LIBIDN2) \
141 $(GN_LIBINTL)
142
143gnunet_gns_benchmark_SOURCES = \
144 gnunet-gns-benchmark.c
145gnunet_gns_benchmark_LDADD = \
146 libgnunetgns.la \
147 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
148 $(top_builddir)/src/identity/libgnunetidentity.la \
149 $(top_builddir)/src/util/libgnunetutil.la \
150 $(GN_LIBINTL)
151
152
153gnunet_bcd_SOURCES = \
154 gnunet-bcd.c
155gnunet_bcd_LDADD = \
156 $(top_builddir)/src/util/libgnunetutil.la \
157 $(top_builddir)/src/identity/libgnunetidentity.la \
158 $(GN_LIBINTL) $(MHD_LIBS)
159gnunet_bcd_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
160
161
162gnunet_dns2gns_SOURCES = \
163 gnunet-dns2gns.c
164gnunet_dns2gns_LDADD = \
165 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
166 libgnunetgns.la \
167 $(top_builddir)/src/util/libgnunetutil.la \
168 $(top_builddir)/src/identity/libgnunetidentity.la \
169 $(GN_LIBINTL)
170
171if HAVE_SUDO
172SUDO_OR_DOAS_BINARY= $(SUDO_BINARY)
173else
174if HAVE_DOAS_BINARY
175SUDO_OR_DOAS_BINARY= $(DOAS_BINARY)
176endif
177endif
178
179if LINUX
180HIJACKBIN = gnunet-dns2gns
181install-exec-hook:
182 $(SUDO_OR_DOAS_BINARY) setcap 'cap_net_bind_service=+ep' $(DESTDIR)$(libexecdir)/gnunet-dns2gns || true
183else
184install-exec-hook:
185endif
186
187gnunet_gns_proxy_SOURCES = \
188 gnunet-gns-proxy.c
189gnunet_gns_proxy_LDADD = $(MHD_LIBS) $(LIB_GNURL) -lgnutls \
190 libgnunetgns.la \
191 $(top_builddir)/src/identity/libgnunetidentity.la \
192 $(top_builddir)/src/util/libgnunetutil.la \
193 $(GN_LIBINTL)
194if HAVE_GNUTLS_DANE
195gnunet_gns_proxy_LDADD += -lgnutls-dane
196endif
197gnunet_gns_proxy_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
198
199test_gns_proxy_SOURCES = \
200 test_gns_proxy.c
201test_gns_proxy_LDADD = $(MHD_LIBS) $(LIB_GNURL) -lgnutls \
202 $(top_builddir)/src/util/libgnunetutil.la \
203 $(GN_LIBINTL)
204test_gns_proxy_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
205
206#gnunet_gns_import_SOURCES = \
207# gnunet-gns-import.c
208#gnunet_gns_import_LDADD = \
209# $(top_builddir)/src/identity/libgnunetidentity.la \
210# $(top_builddir)/src/namestore/libgnunetnamestore.la \
211# $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
212# $(top_builddir)/src/util/libgnunetutil.la \
213# $(GN_LIBINTL)
214
215
216gnunet_service_gns_SOURCES = \
217 gnunet-service-gns.c gnunet-service-gns.h \
218 gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \
219 gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h
220gnunet_service_gns_LDADD = \
221 -lm \
222 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
223 $(top_builddir)/src/identity/libgnunetidentity.la \
224 $(top_builddir)/src/revocation/libgnunetrevocation.la \
225 $(top_builddir)/src/statistics/libgnunetstatistics.la \
226 $(top_builddir)/src/util/libgnunetutil.la \
227 $(top_builddir)/src/dns/libgnunetdns.la \
228 $(top_builddir)/src/dht/libgnunetdht.la \
229 $(top_builddir)/src/namecache/libgnunetnamecache.la \
230 $(LIBIDN) $(LIBIDN2) \
231 $(USE_VPN) \
232 $(GN_LIBINTL)
233
234
235libgnunetgns_la_SOURCES = \
236 gns_api.c gns_api.h \
237 gns_tld_api.c gns.h
238libgnunetgns_la_LIBADD = \
239 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
240 $(top_builddir)/src/identity/libgnunetidentity.la \
241 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la
242libgnunetgns_la_LDFLAGS = \
243 $(GN_LIBINTL) \
244 $(GN_LIB_LDFLAGS)
245
246
247libgnunet_plugin_block_gns_la_SOURCES = \
248 plugin_block_gns.c
249libgnunet_plugin_block_gns_la_LIBADD = \
250 $(top_builddir)/src/util/libgnunetutil.la \
251 $(top_builddir)/src/block/libgnunetblock.la \
252 $(top_builddir)/src/block/libgnunetblockgroup.la \
253 $(top_builddir)/src/identity/libgnunetidentity.la \
254 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la
255libgnunet_plugin_block_gns_la_LDFLAGS = \
256 $(GN_LIBINTL) \
257 $(GN_PLUGIN_LDFLAGS)
258
259if HAVE_GNUTLS
260if HAVE_LIBGNURL
261check_PROGRAMS = \
262 test_gns_proxy
263endif
264endif
265
266check_SCRIPTS = \
267 test_gns_lookup.sh \
268 test_gns_config_lookup.sh \
269 test_gns_ipv6_lookup.sh\
270 test_gns_txt_lookup.sh\
271 test_gns_caa_lookup.sh\
272 test_gns_mx_lookup.sh \
273 test_gns_gns2dns_lookup.sh \
274 test_gns_gns2dns_zkey_lookup.sh \
275 test_gns_gns2dns_cname_lookup.sh \
276 test_gns_dht_lookup.sh\
277 test_gns_delegated_lookup.sh \
278 test_gns_at_lookup.sh\
279 test_gns_zkey_lookup.sh\
280 test_gns_rel_expiration.sh\
281 test_gns_soa_lookup.sh\
282 test_gns_revocation.sh\
283 test_gns_cname_lookup.sh\
284 test_proxy.sh
285
286if HAVE_GNUTLS
287if HAVE_LIBGNURL
288check_SCRIPTS += \
289 test_proxy.sh
290endif
291endif
292check_SCRIPTS += \
293 test_plugin_rest_gns.sh
294
295
296if ENABLE_TEST_RUN
297if HAVE_SQLITE
298 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
299 TESTS = $(check_SCRIPTS)
300endif
301endif