aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am26
1 files changed, 9 insertions, 17 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 991c40ae3..434d50f34 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -14,7 +14,8 @@ EXTRA_DIST = \
14 test_gns_simple_lookup.conf \ 14 test_gns_simple_lookup.conf \
15 gns-helper-service-w32.conf \ 15 gns-helper-service-w32.conf \
16 w32nsp.def \ 16 w32nsp.def \
17 gnunet-gns-proxy-setup-ca \ 17 openssl.cnf \
18 gnunet-gns-proxy-setup-ca.in \
18 zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \ 19 zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \
19 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \ 20 zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
20 zonefiles/test_zonekey \ 21 zonefiles/test_zonekey \
@@ -80,7 +81,7 @@ noinst_PROGRAMS = \
80 gnunet-gns-benchmark 81 gnunet-gns-benchmark
81 82
82pkgdata_DATA = \ 83pkgdata_DATA = \
83 openssl.cnf 84 openssl.cnf
84 85
85if HAVE_MHD 86if HAVE_MHD
86if LINUX 87if LINUX
@@ -93,25 +94,16 @@ plugin_LTLIBRARIES = \
93 libgnunet_plugin_gnsrecord_gns.la 94 libgnunet_plugin_gnsrecord_gns.la
94 95
95 96
96if HAVE_OPENSSL 97bin_SCRIPTS = \
97xOPENSSL=$(shell which openssl) 98 gnunet-gns-proxy-setup-ca
98do_subst_openssl = $(SED) -e 's,[@]OPENSSLBIN[@],${xOPENSSL},g'
99endif
100
101if HAVE_CERTUTIL
102xCERTUTIL=$(shell which certutil)
103do_subst_certutil = $(SED) -e 's,[@]CERTUTILBIN[@],${xCERTUTIL},g'
104endif
105 99
106xPFX=$(pkgdatadir)/openssl.cnf 100# See: https://www.gnu.org/software/automake/manual/html_node/Scripts.html#Scripts
107do_subst = $(SED) -e 's,[@]PREFIX[@],${xPFX},g' 101do_subst = sed -e 's,[@]pkgdatadir[@],$(pkgdatadir),g'
108 102
109gnunet-gns-proxy-setup-ca: gnunet-gns-proxy-setup-ca.in 103gnunet-gns-proxy-setup-ca: gnunet-gns-proxy-setup-ca.in Makefile
110 $(do_subst) < $(top_srcdir)/src/gns/gnunet-gns-proxy-setup-ca.in > gnunet-gns-proxy-setup-ca 104 $(do_subst) < $(srcdir)/gnunet-gns-proxy-setup-ca.in > gnunet-gns-proxy-setup-ca
111 chmod +x gnunet-gns-proxy-setup-ca 105 chmod +x gnunet-gns-proxy-setup-ca
112 106
113bin_SCRIPTS = gnunet-gns-proxy-setup-ca
114
115libgnunet_plugin_gnsrecord_gns_la_SOURCES = \ 107libgnunet_plugin_gnsrecord_gns_la_SOURCES = \
116 plugin_gnsrecord_gns.c 108 plugin_gnsrecord_gns.c
117libgnunet_plugin_gnsrecord_gns_la_LIBADD = \ 109libgnunet_plugin_gnsrecord_gns_la_LIBADD = \