aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index f8d266748..61e52ee98 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -55,6 +55,14 @@ if HAVE_MHD
55if HAVE_GNUTLS 55if HAVE_GNUTLS
56if HAVE_LIBGNURL 56if HAVE_LIBGNURL
57 DO_PROXY=gnunet-gns-proxy 57 DO_PROXY=gnunet-gns-proxy
58LIB_GNURL=@LIBGNURL@
59CPP_GNURL=@LIBGNURL_CPPFLAGS@
60else
61if HAVE_LIBCURL
62 DO_PROXY=gnunet-gns-proxy
63LIB_GNURL=@LIBCURL@
64CPP_GNURL=@LIBCURL_CPPFLAGS@
65endif
58endif 66endif
59endif 67endif
60endif 68endif
@@ -141,8 +149,8 @@ gnunet_dns2gns_DEPENDENCIES = \
141 149
142gnunet_gns_proxy_SOURCES = \ 150gnunet_gns_proxy_SOURCES = \
143 gnunet-gns-proxy.c 151 gnunet-gns-proxy.c
144gnunet_gns_proxy_CPPFLAGS = $(AM_CPPFLAGS) $(LIBGNURL_CPPFLAGS) 152gnunet_gns_proxy_CPPFLAGS = $(AM_CPPFLAGS) $(CPP_GNURL)
145gnunet_gns_proxy_LDADD = -lmicrohttpd $(LIBGNURL) -lgnutls \ 153gnunet_gns_proxy_LDADD = -lmicrohttpd $(LIB_GNURL) -lgnutls \
146 $(top_builddir)/src/gns/libgnunetgns.la \ 154 $(top_builddir)/src/gns/libgnunetgns.la \
147 $(top_builddir)/src/identity/libgnunetidentity.la \ 155 $(top_builddir)/src/identity/libgnunetidentity.la \
148 $(top_builddir)/src/util/libgnunetutil.la \ 156 $(top_builddir)/src/util/libgnunetutil.la \