aboutsummaryrefslogtreecommitdiff
path: root/src/gnsrecord/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gnsrecord/Makefile.am')
-rw-r--r--src/gnsrecord/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/gnsrecord/Makefile.am b/src/gnsrecord/Makefile.am
index 2fb427c69..f840a31a4 100644
--- a/src/gnsrecord/Makefile.am
+++ b/src/gnsrecord/Makefile.am
@@ -19,7 +19,8 @@ endif
19check_PROGRAMS = \ 19check_PROGRAMS = \
20 test_gnsrecord_crypto \ 20 test_gnsrecord_crypto \
21 test_gnsrecord_serialization \ 21 test_gnsrecord_serialization \
22 test_gnsrecord_block_expiration 22 test_gnsrecord_block_expiration \
23 perf_gnsrecord_crypto
23 24
24if ENABLE_TEST_RUN 25if ENABLE_TEST_RUN
25AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 26AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
@@ -37,7 +38,6 @@ libgnunetgnsrecord_la_SOURCES = \
37 gnsrecord_crypto.c \ 38 gnsrecord_crypto.c \
38 gnsrecord_misc.c 39 gnsrecord_misc.c
39libgnunetgnsrecord_la_LIBADD = \ 40libgnunetgnsrecord_la_LIBADD = \
40 $(top_builddir)/src/dns/libgnunetdnsparser.la \
41 $(top_builddir)/src/util/libgnunetutil.la \ 41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(GN_LIBINTL) 42 $(GN_LIBINTL)
43libgnunetgnsrecord_la_LDFLAGS = \ 43libgnunetgnsrecord_la_LDFLAGS = \
@@ -52,7 +52,6 @@ plugin_LTLIBRARIES = \
52libgnunet_plugin_gnsrecord_dns_la_SOURCES = \ 52libgnunet_plugin_gnsrecord_dns_la_SOURCES = \
53 plugin_gnsrecord_dns.c 53 plugin_gnsrecord_dns.c
54libgnunet_plugin_gnsrecord_dns_la_LIBADD = \ 54libgnunet_plugin_gnsrecord_dns_la_LIBADD = \
55 $(top_builddir)/src/dns/libgnunetdnsparser.la \
56 $(top_builddir)/src/util/libgnunetutil.la \ 55 $(top_builddir)/src/util/libgnunetutil.la \
57 $(LTLIBINTL) 56 $(LTLIBINTL)
58libgnunet_plugin_gnsrecord_dns_la_LDFLAGS = \ 57libgnunet_plugin_gnsrecord_dns_la_LDFLAGS = \
@@ -85,3 +84,10 @@ test_gnsrecord_crypto_LDADD = \
85 libgnunetgnsrecord.la \ 84 libgnunetgnsrecord.la \
86 $(top_builddir)/src/util/libgnunetutil.la 85 $(top_builddir)/src/util/libgnunetutil.la
87 86
87
88perf_gnsrecord_crypto_SOURCES = \
89 perf_gnsrecord_crypto.c
90perf_gnsrecord_crypto_LDADD = \
91 $(top_builddir)/src/testing/libgnunettesting.la \
92 libgnunetgnsrecord.la \
93 $(top_builddir)/src/util/libgnunetutil.la