aboutsummaryrefslogtreecommitdiff
path: root/src/gnsrecord/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gnsrecord/Makefile.am')
-rw-r--r--src/gnsrecord/Makefile.am119
1 files changed, 0 insertions, 119 deletions
diff --git a/src/gnsrecord/Makefile.am b/src/gnsrecord/Makefile.am
deleted file mode 100644
index 42ac4ede4..000000000
--- a/src/gnsrecord/Makefile.am
+++ /dev/null
@@ -1,119 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include ${MHD_CFLAGS}
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10if USE_COVERAGE
11 AM_CFLAGS = --coverage -O0
12 XLIBS = -lgcov
13endif
14
15bin_PROGRAMS = \
16 gnunet-gnsrecord-tvg
17
18
19check_PROGRAMS = \
20 test_gnsrecord_crypto \
21 test_gnsrecord_serialization \
22 test_gnsrecord_block_expiration \
23 perf_gnsrecord_crypto
24
25if ENABLE_TEST_RUN
26AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
27TESTS = \
28 $(check_PROGRAMS) \
29 $(check_SCRIPTS)
30endif
31
32lib_LTLIBRARIES = \
33 libgnunetgnsrecord.la \
34 libgnunetgnsrecordjson.la
35
36gnunet_gnsrecord_tvg_SOURCES = \
37 gnunet-gnsrecord-tvg.c
38gnunet_gnsrecord_tvg_LDADD = \
39 $(top_builddir)/src/util/libgnunetutil.la \
40 $(top_builddir)/src/identity/libgnunetidentity.la \
41 libgnunetgnsrecord.la \
42 $(GN_LIBINTL)
43
44
45libgnunetgnsrecord_la_SOURCES = \
46 gnsrecord.c \
47 gnsrecord_serialization.c \
48 gnsrecord_crypto.c \
49 gnsrecord_misc.c
50libgnunetgnsrecord_la_LIBADD = \
51 $(top_builddir)/src/util/libgnunetutil.la \
52 $(top_builddir)/src/identity/libgnunetidentity.la \
53 $(LIBGCRYPT_LIBS) \
54 -lsodium \
55 $(GN_LIBINTL)
56libgnunetgnsrecord_la_LDFLAGS = \
57 $(GN_LIB_LDFLAGS) \
58 -version-info 0:0:0
59
60libgnunetgnsrecordjson_la_SOURCES = \
61 json_gnsrecord.c
62libgnunetgnsrecordjson_la_LIBADD = \
63 $(top_builddir)/src/util/libgnunetutil.la \
64 $(top_builddir)/src/identity/libgnunetidentity.la \
65 libgnunetgnsrecord.la \
66 -ljansson \
67 $(GN_LIBINTL)
68libgnunetgnsrecordjson_la_LDFLAGS = \
69 $(GN_LIB_LDFLAGS) \
70 -version-info 0:0:0
71
72plugin_LTLIBRARIES = \
73 libgnunet_plugin_gnsrecord_dns.la
74
75
76libgnunet_plugin_gnsrecord_dns_la_SOURCES = \
77 plugin_gnsrecord_dns.c
78libgnunet_plugin_gnsrecord_dns_la_LIBADD = \
79 $(top_builddir)/src/util/libgnunetutil.la \
80 $(LTLIBINTL)
81libgnunet_plugin_gnsrecord_dns_la_LDFLAGS = \
82 $(GN_PLUGIN_LDFLAGS)
83
84
85EXTRA_DIST = \
86 $(check_SCRIPTS)
87
88
89test_gnsrecord_serialization_SOURCES = \
90 test_gnsrecord_serialization.c
91test_gnsrecord_serialization_LDADD = \
92 $(top_builddir)/src/testing/libgnunettesting.la \
93 libgnunetgnsrecord.la \
94 $(top_builddir)/src/util/libgnunetutil.la
95
96test_gnsrecord_block_expiration_SOURCES = \
97 test_gnsrecord_block_expiration.c
98test_gnsrecord_block_expiration_LDADD = \
99 $(top_builddir)/src/testing/libgnunettesting.la \
100 libgnunetgnsrecord.la \
101 $(top_builddir)/src/util/libgnunetutil.la
102
103
104test_gnsrecord_crypto_SOURCES = \
105 test_gnsrecord_crypto.c
106test_gnsrecord_crypto_LDADD = \
107 $(top_builddir)/src/testing/libgnunettesting.la \
108 $(top_builddir)/src/identity/libgnunetidentity.la \
109 libgnunetgnsrecord.la \
110 $(top_builddir)/src/util/libgnunetutil.la
111
112
113perf_gnsrecord_crypto_SOURCES = \
114 perf_gnsrecord_crypto.c
115perf_gnsrecord_crypto_LDADD = \
116 $(top_builddir)/src/testing/libgnunettesting.la \
117 $(top_builddir)/src/identity/libgnunetidentity.la \
118 libgnunetgnsrecord.la \
119 $(top_builddir)/src/util/libgnunetutil.la