aboutsummaryrefslogtreecommitdiff
path: root/src/hello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hello/Makefile.am')
-rw-r--r--src/hello/Makefile.am60
1 files changed, 0 insertions, 60 deletions
diff --git a/src/hello/Makefile.am b/src/hello/Makefile.am
deleted file mode 100644
index 6a250e42f..000000000
--- a/src/hello/Makefile.am
+++ /dev/null
@@ -1,60 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9lib_LTLIBRARIES = libgnunethello.la
10
11libgnunethello_la_SOURCES = \
12 hello.c \
13 address.c \
14 hello-ng.c
15libgnunethello_la_LIBADD = \
16 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
17 $(LTLIBINTL)
18libgnunethello_la_LDFLAGS = \
19 $(GN_LIB_LDFLAGS) \
20 -version-info 1:0:1
21
22noinst_PROGRAMS = \
23 gnunet-hello
24
25check_PROGRAMS = \
26 test_hello \
27 test_friend_hello \
28 test_hello-ng
29
30if ENABLE_TEST_RUN
31AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
32TESTS = $(check_PROGRAMS)
33endif
34
35test_hello_SOURCES = \
36 test_hello.c
37test_hello_LDADD = \
38 libgnunethello.la \
39 $(top_builddir)/src/util/libgnunetutil.la
40
41test_hello_ng_SOURCES = \
42 test_hello-ng.c
43test_hello_ng_LDADD = \
44 libgnunethello.la \
45 $(top_builddir)/src/util/libgnunetutil.la
46
47
48test_friend_hello_SOURCES = \
49 test_friend_hello.c
50test_friend_hello_LDADD = \
51 libgnunethello.la \
52 $(top_builddir)/src/util/libgnunetutil.la
53
54gnunet_hello_SOURCES = \
55 gnunet-hello.c
56gnunet_hello_LDADD = \
57 libgnunethello.la \
58 $(top_builddir)/src/util/libgnunetutil.la
59gnunet_hello_LDFLAGS = \
60 $(GN_LIBINTL)