aboutsummaryrefslogtreecommitdiff
path: root/src/hello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hello/Makefile.am')
-rw-r--r--src/hello/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/hello/Makefile.am b/src/hello/Makefile.am
new file mode 100644
index 000000000..cffb7201c
--- /dev/null
+++ b/src/hello/Makefile.am
@@ -0,0 +1,28 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage
9endif
10
11lib_LTLIBRARIES = libgnunethello.la
12
13libgnunethello_la_SOURCES = \
14 hello.c
15libgnunethello_la_LIBADD = \
16 $(top_builddir)/src/util/libgnunetutil.la
17
18check_PROGRAMS = \
19 test_hello
20
21TESTS = $(check_PROGRAMS)
22
23test_hello_SOURCES = \
24 test_hello.c
25test_hello_LDADD = \
26 $(top_builddir)/src/hello/libgnunethello.la \
27 $(top_builddir)/src/util/libgnunetutil.la
28