aboutsummaryrefslogtreecommitdiff
path: root/src/hostlist/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hostlist/Makefile.am')
-rw-r--r--src/hostlist/Makefile.am105
1 files changed, 0 insertions, 105 deletions
diff --git a/src/hostlist/Makefile.am b/src/hostlist/Makefile.am
deleted file mode 100644
index 3b534de70..000000000
--- a/src/hostlist/Makefile.am
+++ /dev/null
@@ -1,105 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8
9if USE_COVERAGE
10 AM_CFLAGS = --coverage -O0
11endif
12
13 HOSTLIST_SERVER_SOURCES = \
14 gnunet-daemon-hostlist_server.c gnunet-daemon-hostlist_server.h
15 GN_LIBMHD = $(MHD_LIBS)
16 GN_CPPMHD = $(MHD_CFLAGS)
17
18if HAVE_LIBGNURL
19libexec_PROGRAMS = \
20 gnunet-daemon-hostlist
21LIB_GNURL=@LIBGNURL@
22CPP_GNURL=@LIBGNURL_CPPFLAGS@
23dist_pkgcfg_DATA = \
24 hostlist.conf
25else
26if HAVE_LIBCURL
27libexec_PROGRAMS = \
28 gnunet-daemon-hostlist
29LIB_GNURL=@LIBCURL@
30CPP_GNURL=@LIBCURL_CPPFLAGS@
31dist_pkgcfg_DATA = \
32 hostlist.conf
33endif
34endif
35
36gnunet_daemon_hostlist_SOURCES = \
37 gnunet-daemon-hostlist.c gnunet-daemon-hostlist.h \
38 gnunet-daemon-hostlist_client.c gnunet-daemon-hostlist_client.h \
39 $(HOSTLIST_SERVER_SOURCES)
40
41gnunet_daemon_hostlist_LDADD = \
42 $(top_builddir)/src/core/libgnunetcore.la \
43 $(top_builddir)/src/hello/libgnunethello.la \
44 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
45 $(top_builddir)/src/statistics/libgnunetstatistics.la \
46 $(top_builddir)/src/transport/libgnunettransport.la \
47 $(top_builddir)/src/util/libgnunetutil.la \
48 $(GN_LIBMHD) \
49 $(LIB_GNURL) \
50 $(GN_LIBINTL)
51
52gnunet_daemon_hostlist_CFLAGS = \
53 $(GN_CPPMHD) \
54 $(CPP_GNURL) \
55 $(AM_CFLAGS)
56
57if HAVE_LIBGNURL
58check_PROGRAMS = \
59 test_gnunet_daemon_hostlist \
60 test_gnunet_daemon_hostlist_reconnect \
61 test_gnunet_daemon_hostlist_learning
62else
63if HAVE_LIBCURL
64check_PROGRAMS = \
65 test_gnunet_daemon_hostlist \
66 test_gnunet_daemon_hostlist_reconnect \
67 test_gnunet_daemon_hostlist_learning
68endif
69endif
70
71if ENABLE_TEST_RUN
72AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
73TESTS = \
74 $(check_PROGRAMS)
75endif
76
77test_gnunet_daemon_hostlist_SOURCES = \
78 test_gnunet_daemon_hostlist.c
79test_gnunet_daemon_hostlist_LDADD = \
80 $(top_builddir)/src/transport/libgnunettransport.la \
81 $(top_builddir)/src/util/libgnunetutil.la
82
83test_gnunet_daemon_hostlist_reconnect_SOURCES = \
84 test_gnunet_daemon_hostlist_reconnect.c
85test_gnunet_daemon_hostlist_reconnect_LDADD = \
86 $(top_builddir)/src/transport/libgnunettransport.la \
87 $(top_builddir)/src/util/libgnunetutil.la
88
89test_gnunet_daemon_hostlist_learning_SOURCES = \
90 test_gnunet_daemon_hostlist_learning.c
91test_gnunet_daemon_hostlist_learning_LDADD = \
92 $(top_builddir)/src/transport/libgnunettransport.la \
93 $(top_builddir)/src/core/libgnunetcore.la \
94 $(top_builddir)/src/statistics/libgnunetstatistics.la \
95 $(top_builddir)/src/util/libgnunetutil.la
96
97EXTRA_DIST = \
98 test_hostlist_defaults.conf \
99 test_gnunet_daemon_hostlist_data.conf \
100 test_gnunet_daemon_hostlist_peer1.conf \
101 test_gnunet_daemon_hostlist_peer2.conf \
102 test_learning_adv_peer.conf \
103 test_learning_learn_peer.conf \
104 test_learning_learn_peer2.conf \
105 learning_data.conf