aboutsummaryrefslogtreecommitdiff
path: root/src/hostlist/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hostlist/Makefile.am')
-rw-r--r--src/hostlist/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/hostlist/Makefile.am b/src/hostlist/Makefile.am
index d777cd658..5d5a94b5d 100644
--- a/src/hostlist/Makefile.am
+++ b/src/hostlist/Makefile.am
@@ -20,6 +20,15 @@ endif
20if HAVE_LIBGNURL 20if HAVE_LIBGNURL
21libexec_PROGRAMS = \ 21libexec_PROGRAMS = \
22 gnunet-daemon-hostlist 22 gnunet-daemon-hostlist
23LIB_GNURL=@LIBGNURL@
24CPP_GNURL=@LIBGNURL_CPPFLAGS@
25else
26if HAVE_LIBCURL
27libexec_PROGRAMS = \
28 gnunet-daemon-hostlist
29LIB_GNURL=@LIBCURL@
30CPP_GNURL=@LIBCURL_CPPFLAGS@
31endif
23endif 32endif
24 33
25gnunet_daemon_hostlist_SOURCES = \ 34gnunet_daemon_hostlist_SOURCES = \
@@ -35,11 +44,12 @@ gnunet_daemon_hostlist_LDADD = \
35 $(top_builddir)/src/transport/libgnunettransport.la \ 44 $(top_builddir)/src/transport/libgnunettransport.la \
36 $(top_builddir)/src/util/libgnunetutil.la \ 45 $(top_builddir)/src/util/libgnunetutil.la \
37 $(GN_LIBMHD) \ 46 $(GN_LIBMHD) \
38 @LIBGNURL@ \ 47 $(LIB_GNURL) \
39 $(GN_LIBINTL) 48 $(GN_LIBINTL)
40 49
41gnunet_daemon_hostlist_CPPFLAGS = \ 50gnunet_daemon_hostlist_CPPFLAGS = \
42 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS) 51 $(CPP_GNURL) \
52 $(AM_CPPFLAGS)
43 53
44if HAVE_LIBGNURL 54if HAVE_LIBGNURL
45check_PROGRAMS = \ 55check_PROGRAMS = \