aboutsummaryrefslogtreecommitdiff
path: root/src/identity-provider/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/identity-provider/Makefile.am')
-rw-r--r--src/identity-provider/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/identity-provider/Makefile.am b/src/identity-provider/Makefile.am
index f556052cb..1e0b82528 100644
--- a/src/identity-provider/Makefile.am
+++ b/src/identity-provider/Makefile.am
@@ -4,7 +4,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
4 plugindir = $(libdir)/gnunet 4 plugindir = $(libdir)/gnunet
5 5
6if MINGW 6if MINGW
7 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 7 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
8endif 8endif
9 9
10if USE_COVERAGE 10if USE_COVERAGE
@@ -21,7 +21,7 @@ pkgcfg_DATA = \
21 21
22plugin_LTLIBRARIES = \ 22plugin_LTLIBRARIES = \
23 libgnunetidentityprovider.la \ 23 libgnunetidentityprovider.la \
24 libgnunet_plugin_rest_identity_provider.la 24 libgnunet_plugin_rest_identity_provider.la
25 25
26bin_PROGRAMS = \ 26bin_PROGRAMS = \
27 gnunet-identity-token 27 gnunet-identity-token
@@ -37,6 +37,7 @@ gnunet_service_identity_provider_LDADD = \
37 $(top_builddir)/src/util/libgnunetutil.la \ 37 $(top_builddir)/src/util/libgnunetutil.la \
38 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 38 $(top_builddir)/src/namestore/libgnunetnamestore.la \
39 $(top_builddir)/src/identity/libgnunetidentity.la \ 39 $(top_builddir)/src/identity/libgnunetidentity.la \
40 $(top_builddir)/src/statistics/libgnunetstatistics.la \
40 $(top_builddir)/src/gns/libgnunetgns.la \ 41 $(top_builddir)/src/gns/libgnunetgns.la \
41 $(GN_LIBINTL) \ 42 $(GN_LIBINTL) \
42 -ljansson 43 -ljansson
@@ -65,10 +66,8 @@ libgnunet_plugin_rest_identity_provider_la_LDFLAGS = \
65 66
66 67
67gnunet_identity_token_SOURCES = \ 68gnunet_identity_token_SOURCES = \
68 gnunet-identity-token.c 69 gnunet-identity-token.c
69gnunet_identity_token_LDADD = \ 70gnunet_identity_token_LDADD = \
70 $(top_builddir)/src/util/libgnunetutil.la \ 71 $(top_builddir)/src/util/libgnunetutil.la \
71 -ljansson -lmicrohttpd \ 72 -ljansson -lmicrohttpd \
72 $(GN_LIBINTL) 73 $(GN_LIBINTL)
73
74