aboutsummaryrefslogtreecommitdiff
path: root/src/identity/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/identity/Makefile.am')
-rw-r--r--src/identity/Makefile.am101
1 files changed, 0 insertions, 101 deletions
diff --git a/src/identity/Makefile.am b/src/identity/Makefile.am
deleted file mode 100644
index 5a2110974..000000000
--- a/src/identity/Makefile.am
+++ /dev/null
@@ -1,101 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6if USE_COVERAGE
7 AM_CFLAGS = --coverage -O0
8 XLIB = -lgcov
9endif
10
11plugin_LTLIBRARIES = libgnunet_plugin_rest_identity.la
12
13pkgcfgdir= $(pkgdatadir)/config.d/
14
15libexecdir= $(pkglibdir)/libexec/
16
17pkgcfg_DATA = \
18 identity.conf
19
20lib_LTLIBRARIES = \
21 libgnunetidentity.la
22
23
24libgnunet_plugin_rest_identity_la_SOURCES = \
25 plugin_rest_identity.c
26libgnunet_plugin_rest_identity_la_LIBADD = \
27 libgnunetidentity.la \
28 $(top_builddir)/src/rest/libgnunetrest.la \
29 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
30 $(LTLIBINTL) -ljansson $(MHD_LIBS)
31libgnunet_plugin_rest_identity_la_LDFLAGS = \
32 $(GN_PLUGIN_LDFLAGS)
33libgnunet_plugin_rest_identity_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
34
35
36libgnunetidentity_la_SOURCES = \
37 identity_api.c \
38 identity_api_lookup.c \
39 identity_api_suffix_lookup.c \
40 identity.h
41libgnunetidentity_la_LIBADD = \
42 $(top_builddir)/src/util/libgnunetutil.la \
43 $(GN_LIBINTL) $(XLIB)
44libgnunetidentity_la_LDFLAGS = \
45 $(GN_LIB_LDFLAGS) \
46 -version-info 1:0:0
47
48bin_PROGRAMS = \
49 gnunet-identity
50
51libexec_PROGRAMS = \
52 gnunet-service-identity
53
54gnunet_service_identity_SOURCES = \
55 gnunet-service-identity.c
56gnunet_service_identity_LDADD = \
57 $(top_builddir)/src/statistics/libgnunetstatistics.la \
58 $(top_builddir)/src/util/libgnunetutil.la \
59 $(GN_LIBINTL)
60
61
62gnunet_identity_SOURCES = \
63 gnunet-identity.c
64gnunet_identity_LDADD = \
65 libgnunetidentity.la \
66 $(top_builddir)/src/statistics/libgnunetstatistics.la \
67 $(top_builddir)/src/util/libgnunetutil.la \
68 $(GN_LIBINTL)
69
70check_PROGRAMS = \
71 test_identity \
72 test_identity_defaults
73
74check_SCRIPTS = \
75 test_identity_messages.sh
76
77if ENABLE_TEST_RUN
78AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
79TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
80endif
81
82
83test_identity_SOURCES = \
84 test_identity.c
85test_identity_LDADD = \
86 libgnunetidentity.la \
87 $(top_builddir)/src/testing/libgnunettesting.la \
88 $(top_builddir)/src/util/libgnunetutil.la
89
90test_identity_defaults_SOURCES = \
91 test_identity_defaults.c
92test_identity_defaults_LDADD = \
93 libgnunetidentity.la \
94 $(top_builddir)/src/testing/libgnunettesting.la \
95 $(top_builddir)/src/util/libgnunetutil.la
96
97EXTRA_DIST = \
98 test_identity.conf \
99 test_identity_messages.sh
100
101