aboutsummaryrefslogtreecommitdiff
path: root/src/jsonapi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/jsonapi/Makefile.am')
-rw-r--r--src/jsonapi/Makefile.am70
1 files changed, 0 insertions, 70 deletions
diff --git a/src/jsonapi/Makefile.am b/src/jsonapi/Makefile.am
deleted file mode 100644
index e572ffa9d..000000000
--- a/src/jsonapi/Makefile.am
+++ /dev/null
@@ -1,70 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6if USE_COVERAGE
7 AM_CFLAGS = --coverage -O0
8 XLIB = -lgcov
9endif
10
11lib_LTLIBRARIES = \
12 libgnunetjsonapi.la \
13 libgnunetjsonapiutils.la
14
15if HAVE_ABE
16lib_LTLIBRARIES += libgnunet_plugin_rest_reclaim.la
17endif
18
19libgnunet_plugin_rest_reclaim_la_SOURCES = \
20 plugin_rest_reclaim.c
21libgnunet_plugin_rest_reclaim_la_LIBADD = \
22 $(top_builddir)/src/identity/libgnunetidentity.la \
23 $(top_builddir)/src/reclaim/libgnunetreclaim.la \
24 $(top_builddir)/src/rest/libgnunetrest.la \
25 libgnunetjsonapi.la \
26 $(top_builddir)/src/reclaim-attribute/libgnunetreclaimattribute.la \
27 $(top_builddir)/src/namestore/libgnunetnamestore.la \
28 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
29 $(LTLIBINTL) -ljansson -lmicrohttpd
30libgnunet_plugin_rest_reclaim_la_LDFLAGS = \
31 i$(GN_PLUGIN_LDFLAGS)
32
33
34libgnunetjsonapiutils_la_LDFLAGS = \
35 -version-info 0:0:0 \
36 -no-undefined
37libgnunetjsonapiutils_la_SOURCES = \
38 jsonapi.c
39libgnunetjsonapiutils_la_LIBADD = \
40 $(top_builddir)/src/util/libgnunetutil.la \
41 $(top_builddir)/src/rest/libgnunetrest.la \
42 $(XLIB)
43
44libgnunetjsonapi_la_LDFLAGS = \
45 -version-info 0:0:0 \
46 -no-undefined
47libgnunetjsonapi_la_SOURCES = \
48 jsonapi_document.c jsonapi_objects.h \
49 jsonapi_resource.c \
50 jsonapi_error.c \
51 jsonapi_relationship.c
52libgnunetjsonapi_la_LIBADD = \
53 $(top_builddir)/src/util/libgnunetutil.la \
54 $(top_builddir)/src/json/libgnunetjson.la \
55 -ljansson \
56 $(XLIB)
57
58check_PROGRAMS = \
59 test_jsonapi
60
61TESTS = \
62 $(check_PROGRAMS)
63
64test_jsonapi_SOURCES = \
65 test_jsonapi.c
66test_jsonapi_LDADD = \
67 libgnunetjsonapi.la \
68 $(top_builddir)/src/json/libgnunetjson.la \
69 $(top_builddir)/src/util/libgnunetutil.la \
70 -ljansson