aboutsummaryrefslogtreecommitdiff
path: root/src/namecache/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namecache/Makefile.am')
-rw-r--r--src/namecache/Makefile.am171
1 files changed, 0 insertions, 171 deletions
diff --git a/src/namecache/Makefile.am b/src/namecache/Makefile.am
deleted file mode 100644
index 272f16b77..000000000
--- a/src/namecache/Makefile.am
+++ /dev/null
@@ -1,171 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS)
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 namecache.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIBS = -lgcov
16endif
17
18if HAVE_EXPERIMENTAL
19FLAT_PLUGIN = libgnunet_plugin_namecache_flat.la
20FLAT_TESTS = test_plugin_namecache_flat
21endif
22
23if HAVE_SQLITE
24SQLITE_PLUGIN = libgnunet_plugin_namecache_sqlite.la
25SQLITE_TESTS = test_plugin_namecache_sqlite
26endif
27
28if HAVE_POSTGRESQL
29POSTGRES_PLUGIN = libgnunet_plugin_namecache_postgres.la
30POSTGRES_TESTS = test_plugin_namecache_postgres
31endif
32
33# testcases do not even build yet; thus: experimental!
34TESTING_TESTS = \
35 test_namecache_api_cache_block
36
37if HAVE_SQLITE
38check_PROGRAMS = \
39 $(SQLITE_TESTS) \
40 $(POSTGRES_TESTS) \
41 $(FLAT_TESTS) \
42 $(TESTING_TESTS)
43endif
44
45if ENABLE_TEST_RUN
46AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
47TESTS = \
48 $(check_PROGRAMS)
49endif
50
51lib_LTLIBRARIES = \
52 libgnunetnamecache.la
53
54
55libgnunetnamecache_la_SOURCES = \
56 namecache_api.c \
57 namecache.h
58libgnunetnamecache_la_LIBADD = \
59 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
60 $(top_builddir)/src/identity/libgnunetidentity.la \
61 $(top_builddir)/src/util/libgnunetutil.la \
62 $(GN_LIBINTL)
63libgnunetnamecache_la_LDFLAGS = \
64 $(GN_LIB_LDFLAGS) \
65 -version-info 0:0:0
66
67
68libexec_PROGRAMS = \
69 gnunet-service-namecache
70
71bin_PROGRAMS = \
72 gnunet-namecache
73
74gnunet_namecache_SOURCES = \
75 gnunet-namecache.c
76gnunet_namecache_LDADD = \
77 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
78 $(top_builddir)/src/identity/libgnunetidentity.la \
79 $(top_builddir)/src/util/libgnunetutil.la \
80 libgnunetnamecache.la \
81 $(GN_LIBINTL)
82
83gnunet_service_namecache_SOURCES = \
84 gnunet-service-namecache.c
85
86gnunet_service_namecache_LDADD = \
87 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
88 $(top_builddir)/src/identity/libgnunetidentity.la \
89 $(top_builddir)/src/statistics/libgnunetstatistics.la \
90 $(top_builddir)/src/util/libgnunetutil.la \
91 libgnunetnamecache.la \
92 $(GN_LIBINTL)
93
94
95plugin_LTLIBRARIES = \
96 $(SQLITE_PLUGIN) \
97 $(FLAT_PLUGIN) \
98 $(POSTGRES_PLUGIN)
99
100libgnunet_plugin_namecache_flat_la_SOURCES = \
101 plugin_namecache_flat.c
102libgnunet_plugin_namecache_flat_la_LIBADD = \
103 libgnunetnamecache.la \
104 $(top_builddir)/src/statistics/libgnunetstatistics.la \
105 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
106 $(top_builddir)/src/identity/libgnunetidentity.la \
107 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
108 $(LTLIBINTL)
109libgnunet_plugin_namecache_flat_la_LDFLAGS = \
110 $(GN_PLUGIN_LDFLAGS)
111
112libgnunet_plugin_namecache_sqlite_la_SOURCES = \
113 plugin_namecache_sqlite.c
114libgnunet_plugin_namecache_sqlite_la_LIBADD = \
115 libgnunetnamecache.la \
116 $(top_builddir)/src/sq/libgnunetsq.la \
117 $(top_builddir)/src/statistics/libgnunetstatistics.la \
118 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
119 $(top_builddir)/src/identity/libgnunetidentity.la \
120 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
121 $(LTLIBINTL)
122libgnunet_plugin_namecache_sqlite_la_LDFLAGS = \
123 $(GN_PLUGIN_LDFLAGS)
124
125
126libgnunet_plugin_namecache_postgres_la_SOURCES = \
127 plugin_namecache_postgres.c
128libgnunet_plugin_namecache_postgres_la_LIBADD = \
129 libgnunetnamecache.la \
130 $(top_builddir)/src/pq/libgnunetpq.la \
131 $(top_builddir)/src/statistics/libgnunetstatistics.la \
132 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
133 $(top_builddir)/src/identity/libgnunetidentity.la \
134 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq \
135 $(LTLIBINTL)
136libgnunet_plugin_namecache_postgres_la_LDFLAGS = \
137 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
138
139test_namecache_api_cache_block_SOURCES = \
140 test_namecache_api_cache_block.c
141test_namecache_api_cache_block_LDADD = \
142 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
143 $(top_builddir)/src/identity/libgnunetidentity.la \
144 libgnunetnamecache.la \
145 $(top_builddir)/src/testing/libgnunettesting.la \
146 $(top_builddir)/src/util/libgnunetutil.la
147
148
149test_plugin_namecache_flat_SOURCES = \
150 test_plugin_namecache.c
151test_plugin_namecache_flat_LDADD = \
152 $(top_builddir)/src/testing/libgnunettesting.la \
153 $(top_builddir)/src/util/libgnunetutil.la
154
155test_plugin_namecache_sqlite_SOURCES = \
156 test_plugin_namecache.c
157test_plugin_namecache_sqlite_LDADD = \
158 $(top_builddir)/src/testing/libgnunettesting.la \
159 $(top_builddir)/src/util/libgnunetutil.la
160
161test_plugin_namecache_postgres_SOURCES = \
162 test_plugin_namecache.c
163test_plugin_namecache_postgres_LDADD = \
164 $(top_builddir)/src/testing/libgnunettesting.la \
165 $(top_builddir)/src/util/libgnunetutil.la
166
167EXTRA_DIST = \
168 test_namecache_api.conf \
169 test_plugin_namecache_sqlite.conf \
170 test_plugin_namecache_postgres.conf \
171 test_plugin_namecache_flat.conf