aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am25
1 files changed, 1 insertions, 24 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index fa85cc060..a349921d7 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -97,12 +97,6 @@ check_PROGRAMS = \
97 $(FLAT_TESTS) 97 $(FLAT_TESTS)
98endif 98endif
99 99
100if HAVE_MHD
101if HAVE_JSON
102REST_PLUGIN=libgnunet_plugin_rest_namestore.la
103endif
104endif
105
106if ENABLE_TEST_RUN 100if ENABLE_TEST_RUN
107AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 101AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
108TESTS = \ 102TESTS = \
@@ -147,8 +141,6 @@ gnunet_zoneimport_LDADD = \
147 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 141 $(top_builddir)/src/statistics/libgnunetstatistics.la \
148 $(top_builddir)/src/identity/libgnunetidentity.la \ 142 $(top_builddir)/src/identity/libgnunetidentity.la \
149 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 143 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
150 $(top_builddir)/src/dns/libgnunetdnsparser.la \
151 $(top_builddir)/src/dns/libgnunetdnsstub.la \
152 $(top_builddir)/src/util/libgnunetutil.la \ 144 $(top_builddir)/src/util/libgnunetutil.la \
153 $(GN_LIBINTL) 145 $(GN_LIBINTL)
154 146
@@ -188,8 +180,7 @@ gnunet_service_namestore_LDADD = \
188plugin_LTLIBRARIES = \ 180plugin_LTLIBRARIES = \
189 $(SQLITE_PLUGIN) \ 181 $(SQLITE_PLUGIN) \
190 $(POSTGRES_PLUGIN) \ 182 $(POSTGRES_PLUGIN) \
191 $(FLAT_PLUGIN) \ 183 $(FLAT_PLUGIN)
192 $(REST_PLUGIN)
193 184
194 185
195 186
@@ -226,20 +217,6 @@ libgnunet_plugin_namestore_postgres_la_LIBADD = \
226libgnunet_plugin_namestore_postgres_la_LDFLAGS = \ 217libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
227 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS) 218 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
228 219
229libgnunet_plugin_rest_namestore_la_SOURCES = \
230 plugin_rest_namestore.c
231libgnunet_plugin_rest_namestore_la_LIBADD = \
232 libgnunetnamestore.la \
233 $(top_builddir)/src/rest/libgnunetrest.la \
234 $(top_builddir)/src/identity/libgnunetidentity.la \
235 $(top_builddir)/src/jsonapi/libgnunetjsonapi.la \
236 $(top_builddir)/src/jsonapi/libgnunetjsonapiutils.la \
237 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
238 $(LTLIBINTL) -ljansson -lmicrohttpd
239libgnunet_plugin_rest_namestore_la_LDFLAGS = \
240 $(GN_PLUGIN_LDFLAGS)
241
242
243test_namestore_api_store_flat_SOURCES = \ 220test_namestore_api_store_flat_SOURCES = \
244 test_namestore_api_store.c 221 test_namestore_api_store.c
245test_namestore_api_store_flat_LDADD = \ 222test_namestore_api_store_flat_LDADD = \