aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am749
1 files changed, 0 insertions, 749 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
deleted file mode 100644
index 51708dd67..000000000
--- a/src/namestore/Makefile.am
+++ /dev/null
@@ -1,749 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS)
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 namestore.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIBS = -lgcov
16endif
17
18HEAP_PLUGIN = libgnunet_plugin_namestore_flat.la
19HEAP_TESTS = test_plugin_namestore_flat \
20 test_namestore_api_store_flat \
21 test_namestore_api_store_update_flat \
22 test_namestore_api_remove_flat \
23 test_namestore_api_zone_iteration_flat \
24 test_namestore_api_lookup_nick_flat \
25 test_namestore_api_monitoring_flat \
26 test_namestore_api_lookup_public_flat \
27 test_namestore_api_lookup_private_flat \
28 test_namestore_api_lookup_shadow_flat \
29 test_namestore_api_lookup_shadow_filter_flat \
30 test_namestore_api_remove_not_existing_record_flat \
31 test_namestore_api_zone_iteration_nick_flat \
32 test_namestore_api_zone_iteration_specific_zone_flat \
33 test_namestore_api_zone_iteration_stop_flat \
34 test_namestore_api_monitoring_existing_flat \
35 test_namestore_api_zone_to_name_flat \
36 perf_namestore_api_zone_iteration_flat
37
38if HAVE_SQLITE
39SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
40SQLITE_TESTS = test_plugin_namestore_sqlite \
41 test_namestore_api_store_sqlite \
42 test_namestore_api_store_update_sqlite \
43 test_namestore_api_zone_iteration_sqlite \
44 test_namestore_api_remove_sqlite \
45 test_namestore_api_lookup_nick_sqlite \
46 test_namestore_api_monitoring_sqlite \
47 test_namestore_api_lookup_public_sqlite \
48 test_namestore_api_lookup_private_sqlite \
49 test_namestore_api_lookup_shadow_sqlite \
50 test_namestore_api_lookup_shadow_filter_sqlite \
51 test_namestore_api_remove_not_existing_record_sqlite \
52 test_namestore_api_zone_iteration_nick_sqlite \
53 test_namestore_api_zone_iteration_specific_zone_sqlite \
54 test_namestore_api_zone_iteration_stop_sqlite \
55 test_namestore_api_monitoring_existing_sqlite \
56 test_namestore_api_zone_to_name_sqlite \
57 perf_namestore_api_zone_iteration_sqlite
58endif
59
60if HAVE_POSTGRESQL
61POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
62POSTGRES_TESTS = test_plugin_namestore_postgres \
63 test_namestore_api_store_postgres \
64 test_namestore_api_store_update_postgres \
65 test_namestore_api_remove_postgres \
66 test_namestore_api_zone_iteration_postgres \
67 test_namestore_api_lookup_nick_postgres \
68 test_namestore_api_monitoring_postgres \
69 test_namestore_api_lookup_public_postgres \
70 test_namestore_api_lookup_private_postgres \
71 test_namestore_api_lookup_shadow_postgres \
72 test_namestore_api_lookup_shadow_filter_postgres \
73 test_namestore_api_remove_not_existing_record_postgres \
74 test_namestore_api_zone_iteration_nick_postgres \
75 test_namestore_api_zone_iteration_specific_zone_postgres \
76 test_namestore_api_zone_iteration_stop_postgres \
77 test_namestore_api_monitoring_existing_postgres \
78 test_namestore_api_zone_to_name_postgres \
79 perf_namestore_api_zone_iteration_postgres
80endif
81
82if HAVE_SQLITE
83check_PROGRAMS = \
84 $(SQLITE_TESTS) \
85 $(POSTGRES_TESTS) \
86 $(HEAP_TESTS)
87endif
88
89if ENABLE_TEST_RUN
90AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
91TESTS = \
92 $(check_PROGRAMS) \
93 $(check_SCRIPTS)
94endif
95
96REST_PLUGIN = libgnunet_plugin_rest_namestore.la
97
98lib_LTLIBRARIES = \
99 libgnunetnamestore.la
100
101
102libexec_PROGRAMS = \
103 gnunet-service-namestore
104
105bin_PROGRAMS = \
106 gnunet-namestore \
107 gnunet-zoneimport
108
109libexec_PROGRAMS += \
110 gnunet-namestore-fcfsd
111
112
113plugin_LTLIBRARIES = \
114 $(SQLITE_PLUGIN) \
115 $(POSTGRES_PLUGIN) \
116 $(HEAP_PLUGIN) \
117 $(REST_PLUGIN)
118
119
120libgnunet_plugin_rest_namestore_la_SOURCES = \
121 plugin_rest_namestore.c
122libgnunet_plugin_rest_namestore_la_LIBADD = \
123 libgnunetnamestore.la \
124 $(top_builddir)/src/rest/libgnunetrest.la \
125 $(top_builddir)/src/identity/libgnunetidentity.la \
126 $(top_builddir)/src/json/libgnunetjson.la \
127 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
128 $(top_builddir)/src/gnsrecord/libgnunetgnsrecordjson.la \
129 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
130 $(LTLIBINTL) -ljansson $(MHD_LIBS)
131libgnunet_plugin_rest_namestore_la_LDFLAGS = \
132 $(GN_PLUGIN_LDFLAGS)
133libgnunet_plugin_rest_namestore_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
134
135
136libgnunetnamestore_la_SOURCES = \
137 namestore_api.c \
138 namestore_api_monitor.c \
139 namestore.h
140libgnunetnamestore_la_LIBADD = \
141 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
142 $(top_builddir)/src/identity/libgnunetidentity.la \
143 $(top_builddir)/src/statistics/libgnunetstatistics.la \
144 $(top_builddir)/src/util/libgnunetutil.la \
145 $(GN_LIBINTL)
146libgnunetnamestore_la_LDFLAGS = \
147 $(GN_LIB_LDFLAGS) \
148 -version-info 0:1:0
149
150
151
152gnunet_zoneimport_SOURCES = \
153 gnunet-zoneimport.c
154gnunet_zoneimport_LDADD = \
155 libgnunetnamestore.la \
156 $(top_builddir)/src/statistics/libgnunetstatistics.la \
157 $(top_builddir)/src/identity/libgnunetidentity.la \
158 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
159 $(top_builddir)/src/util/libgnunetutil.la \
160 $(GN_LIBINTL)
161
162gnunet_namestore_SOURCES = \
163 gnunet-namestore.c
164gnunet_namestore_LDADD = \
165 $(top_builddir)/src/identity/libgnunetidentity.la \
166 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
167 $(top_builddir)/src/util/libgnunetutil.la \
168 libgnunetnamestore.la \
169 $(GN_LIBINTL)
170
171
172gnunet_namestore_fcfsd_SOURCES = \
173 gnunet-namestore-fcfsd.c
174gnunet_namestore_fcfsd_LDADD = $(MHD_LIBS) \
175 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
176 $(top_builddir)/src/identity/libgnunetidentity.la \
177 libgnunetnamestore.la \
178 $(top_builddir)/src/util/libgnunetutil.la \
179 $(top_builddir)/src/json/libgnunetjson.la \
180 $(GN_LIBINTL) -ljansson
181gnunet_namestore_fcfsd_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
182
183
184gnunet_service_namestore_SOURCES = \
185 gnunet-service-namestore.c
186
187gnunet_service_namestore_LDADD = \
188 $(top_builddir)/src/namecache/libgnunetnamecache.la \
189 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
190 $(top_builddir)/src/identity/libgnunetidentity.la \
191 $(top_builddir)/src/statistics/libgnunetstatistics.la \
192 $(top_builddir)/src/util/libgnunetutil.la \
193 libgnunetnamestore.la \
194 $(GN_LIBINTL)
195
196
197
198libgnunet_plugin_namestore_flat_la_SOURCES = \
199 plugin_namestore_flat.c
200libgnunet_plugin_namestore_flat_la_LIBADD = \
201 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
202 $(top_builddir)/src/identity/libgnunetidentity.la \
203 $(top_builddir)/src/statistics/libgnunetstatistics.la \
204 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
205 $(LTLIBINTL)
206libgnunet_plugin_namestore_flat_la_LDFLAGS = \
207 $(GN_PLUGIN_LDFLAGS)
208
209
210libgnunet_plugin_namestore_sqlite_la_SOURCES = \
211 plugin_namestore_sqlite.c
212libgnunet_plugin_namestore_sqlite_la_LIBADD = \
213 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
214 $(top_builddir)/src/identity/libgnunetidentity.la \
215 $(top_builddir)/src/sq/libgnunetsq.la \
216 $(top_builddir)/src/statistics/libgnunetstatistics.la \
217 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
218 $(LTLIBINTL)
219libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \
220 $(GN_PLUGIN_LDFLAGS)
221
222libgnunet_plugin_namestore_postgres_la_SOURCES = \
223 plugin_namestore_postgres.c
224libgnunet_plugin_namestore_postgres_la_LIBADD = \
225 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
226 $(top_builddir)/src/identity/libgnunetidentity.la \
227 $(top_builddir)/src/pq/libgnunetpq.la \
228 $(top_builddir)/src/statistics/libgnunetstatistics.la \
229 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq \
230 $(LTLIBINTL)
231libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
232 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
233
234test_namestore_api_store_flat_SOURCES = \
235 test_namestore_api_store.c
236test_namestore_api_store_flat_LDADD = \
237 $(top_builddir)/src/testing/libgnunettesting.la \
238 $(top_builddir)/src/util/libgnunetutil.la \
239 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
240 $(top_builddir)/src/identity/libgnunetidentity.la \
241 libgnunetnamestore.la
242
243test_namestore_api_store_sqlite_SOURCES = \
244 test_namestore_api_store.c
245test_namestore_api_store_sqlite_LDADD = \
246 $(top_builddir)/src/testing/libgnunettesting.la \
247 $(top_builddir)/src/util/libgnunetutil.la \
248 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
249 $(top_builddir)/src/identity/libgnunetidentity.la \
250 libgnunetnamestore.la
251
252test_namestore_api_store_postgres_SOURCES = \
253 test_namestore_api_store.c
254test_namestore_api_store_postgres_LDADD = \
255 $(top_builddir)/src/testing/libgnunettesting.la \
256 $(top_builddir)/src/util/libgnunetutil.la \
257 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
258 $(top_builddir)/src/identity/libgnunetidentity.la \
259 libgnunetnamestore.la
260
261test_namestore_api_store_update_flat_SOURCES = \
262 test_namestore_api_store_update.c
263test_namestore_api_store_update_flat_LDADD = \
264 $(top_builddir)/src/testing/libgnunettesting.la \
265 $(top_builddir)/src/util/libgnunetutil.la \
266 $(top_builddir)/src/identity/libgnunetidentity.la \
267 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
268 $(top_builddir)/src/namecache/libgnunetnamecache.la \
269 libgnunetnamestore.la
270
271test_namestore_api_store_update_sqlite_SOURCES = \
272 test_namestore_api_store_update.c
273test_namestore_api_store_update_sqlite_LDADD = \
274 $(top_builddir)/src/testing/libgnunettesting.la \
275 $(top_builddir)/src/util/libgnunetutil.la \
276 $(top_builddir)/src/identity/libgnunetidentity.la \
277 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
278 $(top_builddir)/src/namecache/libgnunetnamecache.la \
279 libgnunetnamestore.la
280
281test_namestore_api_store_update_postgres_SOURCES = \
282 test_namestore_api_store_update.c
283test_namestore_api_store_update_postgres_LDADD = \
284 $(top_builddir)/src/testing/libgnunettesting.la \
285 $(top_builddir)/src/util/libgnunetutil.la \
286 $(top_builddir)/src/identity/libgnunetidentity.la \
287 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
288 $(top_builddir)/src/namecache/libgnunetnamecache.la \
289 libgnunetnamestore.la
290
291test_namestore_api_lookup_public_flat_SOURCES = \
292 test_namestore_api_lookup_public.c
293test_namestore_api_lookup_public_flat_LDADD = \
294 $(top_builddir)/src/testing/libgnunettesting.la \
295 $(top_builddir)/src/identity/libgnunetidentity.la \
296 $(top_builddir)/src/util/libgnunetutil.la \
297 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
298 $(top_builddir)/src/namecache/libgnunetnamecache.la \
299 libgnunetnamestore.la
300
301test_namestore_api_lookup_public_sqlite_SOURCES = \
302 test_namestore_api_lookup_public.c
303test_namestore_api_lookup_public_sqlite_LDADD = \
304 $(top_builddir)/src/testing/libgnunettesting.la \
305 $(top_builddir)/src/util/libgnunetutil.la \
306 $(top_builddir)/src/identity/libgnunetidentity.la \
307 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
308 $(top_builddir)/src/namecache/libgnunetnamecache.la \
309 libgnunetnamestore.la
310
311test_namestore_api_lookup_public_postgres_SOURCES = \
312 test_namestore_api_lookup_public.c
313test_namestore_api_lookup_public_postgres_LDADD = \
314 $(top_builddir)/src/testing/libgnunettesting.la \
315 $(top_builddir)/src/util/libgnunetutil.la \
316 $(top_builddir)/src/identity/libgnunetidentity.la \
317 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
318 $(top_builddir)/src/namecache/libgnunetnamecache.la \
319 libgnunetnamestore.la
320
321test_namestore_api_lookup_nick_sqlite_SOURCES = \
322 test_namestore_api_lookup_nick.c
323test_namestore_api_lookup_nick_sqlite_LDADD = \
324 $(top_builddir)/src/testing/libgnunettesting.la \
325 $(top_builddir)/src/util/libgnunetutil.la \
326 $(top_builddir)/src/identity/libgnunetidentity.la \
327 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
328 $(top_builddir)/src/namecache/libgnunetnamecache.la \
329 libgnunetnamestore.la
330
331test_namestore_api_lookup_nick_postgres_SOURCES = \
332 test_namestore_api_lookup_nick.c
333test_namestore_api_lookup_nick_postgres_LDADD = \
334 $(top_builddir)/src/testing/libgnunettesting.la \
335 $(top_builddir)/src/util/libgnunetutil.la \
336 $(top_builddir)/src/identity/libgnunetidentity.la \
337 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
338 $(top_builddir)/src/namecache/libgnunetnamecache.la \
339 libgnunetnamestore.la
340
341test_namestore_api_lookup_nick_flat_SOURCES = \
342 test_namestore_api_lookup_nick.c
343test_namestore_api_lookup_nick_flat_LDADD = \
344 $(top_builddir)/src/testing/libgnunettesting.la \
345 $(top_builddir)/src/identity/libgnunetidentity.la \
346 $(top_builddir)/src/util/libgnunetutil.la \
347 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
348 $(top_builddir)/src/namecache/libgnunetnamecache.la \
349 libgnunetnamestore.la
350
351test_namestore_api_lookup_private_flat_SOURCES = \
352 test_namestore_api_lookup_private.c
353test_namestore_api_lookup_private_flat_LDADD = \
354 $(top_builddir)/src/testing/libgnunettesting.la \
355 $(top_builddir)/src/identity/libgnunetidentity.la \
356 $(top_builddir)/src/util/libgnunetutil.la \
357 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
358 $(top_builddir)/src/namecache/libgnunetnamecache.la \
359 libgnunetnamestore.la
360
361test_namestore_api_lookup_private_sqlite_SOURCES = \
362 test_namestore_api_lookup_private.c
363test_namestore_api_lookup_private_sqlite_LDADD = \
364 $(top_builddir)/src/testing/libgnunettesting.la \
365 $(top_builddir)/src/identity/libgnunetidentity.la \
366 $(top_builddir)/src/util/libgnunetutil.la \
367 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
368 $(top_builddir)/src/namecache/libgnunetnamecache.la \
369 libgnunetnamestore.la
370
371test_namestore_api_lookup_private_postgres_SOURCES = \
372 test_namestore_api_lookup_private.c
373test_namestore_api_lookup_private_postgres_LDADD = \
374 $(top_builddir)/src/identity/libgnunetidentity.la \
375 $(top_builddir)/src/testing/libgnunettesting.la \
376 $(top_builddir)/src/util/libgnunetutil.la \
377 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
378 $(top_builddir)/src/namecache/libgnunetnamecache.la \
379 libgnunetnamestore.la
380
381test_namestore_api_lookup_shadow_flat_SOURCES = \
382 test_namestore_api_lookup_shadow.c
383test_namestore_api_lookup_shadow_flat_LDADD = \
384 $(top_builddir)/src/testing/libgnunettesting.la \
385 $(top_builddir)/src/identity/libgnunetidentity.la \
386 $(top_builddir)/src/util/libgnunetutil.la \
387 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
388 $(top_builddir)/src/namecache/libgnunetnamecache.la \
389 libgnunetnamestore.la
390
391test_namestore_api_lookup_shadow_sqlite_SOURCES = \
392 test_namestore_api_lookup_shadow.c
393test_namestore_api_lookup_shadow_sqlite_LDADD = \
394 $(top_builddir)/src/testing/libgnunettesting.la \
395 $(top_builddir)/src/util/libgnunetutil.la \
396 $(top_builddir)/src/identity/libgnunetidentity.la \
397 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
398 $(top_builddir)/src/namecache/libgnunetnamecache.la \
399 libgnunetnamestore.la
400
401test_namestore_api_lookup_shadow_postgres_SOURCES = \
402 test_namestore_api_lookup_shadow.c
403test_namestore_api_lookup_shadow_postgres_LDADD = \
404 $(top_builddir)/src/testing/libgnunettesting.la \
405 $(top_builddir)/src/util/libgnunetutil.la \
406 $(top_builddir)/src/identity/libgnunetidentity.la \
407 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
408 $(top_builddir)/src/namecache/libgnunetnamecache.la \
409 libgnunetnamestore.la
410
411test_namestore_api_lookup_shadow_filter_flat_SOURCES = \
412 test_namestore_api_lookup_shadow_filter.c
413test_namestore_api_lookup_shadow_filter_flat_LDADD = \
414 $(top_builddir)/src/testing/libgnunettesting.la \
415 $(top_builddir)/src/util/libgnunetutil.la \
416 $(top_builddir)/src/identity/libgnunetidentity.la \
417 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
418 $(top_builddir)/src/namecache/libgnunetnamecache.la \
419 libgnunetnamestore.la
420
421test_namestore_api_lookup_shadow_filter_sqlite_SOURCES = \
422 test_namestore_api_lookup_shadow_filter.c
423test_namestore_api_lookup_shadow_filter_sqlite_LDADD = \
424 $(top_builddir)/src/testing/libgnunettesting.la \
425 $(top_builddir)/src/identity/libgnunetidentity.la \
426 $(top_builddir)/src/util/libgnunetutil.la \
427 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
428 $(top_builddir)/src/namecache/libgnunetnamecache.la \
429 libgnunetnamestore.la
430test_namestore_api_lookup_shadow_filter_postgres_SOURCES = \
431 test_namestore_api_lookup_shadow_filter.c
432test_namestore_api_lookup_shadow_filter_postgres_LDADD = \
433 $(top_builddir)/src/testing/libgnunettesting.la \
434 $(top_builddir)/src/identity/libgnunetidentity.la \
435 $(top_builddir)/src/util/libgnunetutil.la \
436 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
437 $(top_builddir)/src/namecache/libgnunetnamecache.la \
438 libgnunetnamestore.la
439
440test_namestore_api_remove_sqlite_SOURCES = \
441 test_namestore_api_remove.c
442test_namestore_api_remove_sqlite_LDADD = \
443 $(top_builddir)/src/identity/libgnunetidentity.la \
444 $(top_builddir)/src/testing/libgnunettesting.la \
445 $(top_builddir)/src/util/libgnunetutil.la \
446 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
447 libgnunetnamestore.la
448
449test_namestore_api_remove_postgres_SOURCES = \
450 test_namestore_api_remove.c
451test_namestore_api_remove_postgres_LDADD = \
452 $(top_builddir)/src/identity/libgnunetidentity.la \
453 $(top_builddir)/src/testing/libgnunettesting.la \
454 $(top_builddir)/src/util/libgnunetutil.la \
455 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
456 libgnunetnamestore.la
457
458test_namestore_api_remove_flat_SOURCES = \
459 test_namestore_api_remove.c
460test_namestore_api_remove_flat_LDADD = \
461 $(top_builddir)/src/testing/libgnunettesting.la \
462 $(top_builddir)/src/identity/libgnunetidentity.la \
463 $(top_builddir)/src/util/libgnunetutil.la \
464 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
465 libgnunetnamestore.la
466
467test_namestore_api_remove_not_existing_record_flat_SOURCES = \
468 test_namestore_api_remove_not_existing_record.c
469test_namestore_api_remove_not_existing_record_flat_LDADD = \
470 $(top_builddir)/src/testing/libgnunettesting.la \
471 $(top_builddir)/src/identity/libgnunetidentity.la \
472 $(top_builddir)/src/util/libgnunetutil.la \
473 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
474 libgnunetnamestore.la
475
476test_namestore_api_remove_not_existing_record_sqlite_SOURCES = \
477 test_namestore_api_remove_not_existing_record.c
478test_namestore_api_remove_not_existing_record_sqlite_LDADD = \
479 $(top_builddir)/src/testing/libgnunettesting.la \
480 $(top_builddir)/src/util/libgnunetutil.la \
481 $(top_builddir)/src/identity/libgnunetidentity.la \
482 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
483 libgnunetnamestore.la
484
485test_namestore_api_remove_not_existing_record_postgres_SOURCES = \
486 test_namestore_api_remove_not_existing_record.c
487test_namestore_api_remove_not_existing_record_postgres_LDADD = \
488 $(top_builddir)/src/testing/libgnunettesting.la \
489 $(top_builddir)/src/identity/libgnunetidentity.la \
490 $(top_builddir)/src/util/libgnunetutil.la \
491 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
492 libgnunetnamestore.la
493
494test_namestore_api_zone_to_name_flat_SOURCES = \
495 test_namestore_api_zone_to_name.c
496test_namestore_api_zone_to_name_flat_LDADD = \
497 $(top_builddir)/src/identity/libgnunetidentity.la \
498 $(top_builddir)/src/testing/libgnunettesting.la \
499 $(top_builddir)/src/util/libgnunetutil.la \
500 libgnunetnamestore.la
501
502test_namestore_api_zone_to_name_sqlite_SOURCES = \
503 test_namestore_api_zone_to_name.c
504test_namestore_api_zone_to_name_sqlite_LDADD = \
505 $(top_builddir)/src/identity/libgnunetidentity.la \
506 $(top_builddir)/src/testing/libgnunettesting.la \
507 $(top_builddir)/src/util/libgnunetutil.la \
508 libgnunetnamestore.la
509
510test_namestore_api_zone_to_name_postgres_SOURCES = \
511 test_namestore_api_zone_to_name.c
512test_namestore_api_zone_to_name_postgres_LDADD = \
513 $(top_builddir)/src/identity/libgnunetidentity.la \
514 $(top_builddir)/src/testing/libgnunettesting.la \
515 $(top_builddir)/src/util/libgnunetutil.la \
516 libgnunetnamestore.la
517
518test_namestore_api_monitoring_flat_SOURCES = \
519 test_namestore_api_monitoring.c
520test_namestore_api_monitoring_flat_LDADD = \
521 $(top_builddir)/src/testing/libgnunettesting.la \
522 libgnunetnamestore.la \
523 $(top_builddir)/src/identity/libgnunetidentity.la \
524 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
525 $(top_builddir)/src/util/libgnunetutil.la
526
527test_namestore_api_monitoring_sqlite_SOURCES = \
528 test_namestore_api_monitoring.c
529test_namestore_api_monitoring_sqlite_LDADD = \
530 $(top_builddir)/src/identity/libgnunetidentity.la \
531 $(top_builddir)/src/testing/libgnunettesting.la \
532 libgnunetnamestore.la \
533 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
534 $(top_builddir)/src/util/libgnunetutil.la
535
536test_namestore_api_monitoring_postgres_SOURCES = \
537 test_namestore_api_monitoring.c
538test_namestore_api_monitoring_postgres_LDADD = \
539 $(top_builddir)/src/testing/libgnunettesting.la \
540 $(top_builddir)/src/identity/libgnunetidentity.la \
541 libgnunetnamestore.la \
542 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
543 $(top_builddir)/src/util/libgnunetutil.la
544
545test_namestore_api_monitoring_existing_flat_SOURCES = \
546 test_namestore_api_monitoring_existing.c
547test_namestore_api_monitoring_existing_flat_LDADD = \
548 $(top_builddir)/src/testing/libgnunettesting.la \
549 $(top_builddir)/src/identity/libgnunetidentity.la \
550 libgnunetnamestore.la \
551 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
552 $(top_builddir)/src/util/libgnunetutil.la
553
554test_namestore_api_monitoring_existing_sqlite_SOURCES = \
555 test_namestore_api_monitoring_existing.c
556test_namestore_api_monitoring_existing_sqlite_LDADD = \
557 $(top_builddir)/src/testing/libgnunettesting.la \
558 $(top_builddir)/src/identity/libgnunetidentity.la \
559 libgnunetnamestore.la \
560 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
561 $(top_builddir)/src/util/libgnunetutil.la
562
563test_namestore_api_monitoring_existing_postgres_SOURCES = \
564 test_namestore_api_monitoring_existing.c
565test_namestore_api_monitoring_existing_postgres_LDADD = \
566 $(top_builddir)/src/testing/libgnunettesting.la \
567 libgnunetnamestore.la \
568 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
569 $(top_builddir)/src/identity/libgnunetidentity.la \
570 $(top_builddir)/src/util/libgnunetutil.la
571
572test_namestore_api_zone_iteration_flat_SOURCES = \
573 test_namestore_api_zone_iteration.c
574test_namestore_api_zone_iteration_flat_LDADD = \
575 $(top_builddir)/src/testing/libgnunettesting.la \
576 $(top_builddir)/src/identity/libgnunetidentity.la \
577 $(top_builddir)/src/util/libgnunetutil.la \
578 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
579 libgnunetnamestore.la
580
581test_namestore_api_zone_iteration_sqlite_SOURCES = \
582 test_namestore_api_zone_iteration.c
583test_namestore_api_zone_iteration_sqlite_LDADD = \
584 $(top_builddir)/src/testing/libgnunettesting.la \
585 $(top_builddir)/src/identity/libgnunetidentity.la \
586 $(top_builddir)/src/util/libgnunetutil.la \
587 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
588 libgnunetnamestore.la
589
590test_namestore_api_zone_iteration_postgres_SOURCES = \
591 test_namestore_api_zone_iteration.c
592test_namestore_api_zone_iteration_postgres_LDADD = \
593 $(top_builddir)/src/testing/libgnunettesting.la \
594 $(top_builddir)/src/identity/libgnunetidentity.la \
595 $(top_builddir)/src/util/libgnunetutil.la \
596 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
597 libgnunetnamestore.la
598
599perf_namestore_api_zone_iteration_postgres_SOURCES = \
600 perf_namestore_api_zone_iteration.c
601perf_namestore_api_zone_iteration_postgres_LDADD = \
602 $(top_builddir)/src/testing/libgnunettesting.la \
603 $(top_builddir)/src/util/libgnunetutil.la \
604 $(top_builddir)/src/identity/libgnunetidentity.la \
605 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
606 libgnunetnamestore.la
607
608perf_namestore_api_zone_iteration_sqlite_SOURCES = \
609 perf_namestore_api_zone_iteration.c
610perf_namestore_api_zone_iteration_sqlite_LDADD = \
611 $(top_builddir)/src/testing/libgnunettesting.la \
612 $(top_builddir)/src/identity/libgnunetidentity.la \
613 $(top_builddir)/src/util/libgnunetutil.la \
614 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
615 libgnunetnamestore.la
616
617perf_namestore_api_zone_iteration_flat_SOURCES = \
618 perf_namestore_api_zone_iteration.c
619perf_namestore_api_zone_iteration_flat_LDADD = \
620 $(top_builddir)/src/testing/libgnunettesting.la \
621 $(top_builddir)/src/identity/libgnunetidentity.la \
622 $(top_builddir)/src/util/libgnunetutil.la \
623 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
624 libgnunetnamestore.la
625
626test_namestore_api_zone_iteration_nick_flat_SOURCES = \
627 test_namestore_api_zone_iteration_nick.c
628test_namestore_api_zone_iteration_nick_flat_LDADD = \
629 $(top_builddir)/src/testing/libgnunettesting.la \
630 $(top_builddir)/src/util/libgnunetutil.la \
631 $(top_builddir)/src/identity/libgnunetidentity.la \
632 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
633 libgnunetnamestore.la
634
635test_namestore_api_zone_iteration_nick_sqlite_SOURCES = \
636 test_namestore_api_zone_iteration_nick.c
637test_namestore_api_zone_iteration_nick_sqlite_LDADD = \
638 $(top_builddir)/src/testing/libgnunettesting.la \
639 $(top_builddir)/src/identity/libgnunetidentity.la \
640 $(top_builddir)/src/util/libgnunetutil.la \
641 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
642 libgnunetnamestore.la
643
644test_namestore_api_zone_iteration_nick_postgres_SOURCES = \
645 test_namestore_api_zone_iteration_nick.c
646test_namestore_api_zone_iteration_nick_postgres_LDADD = \
647 $(top_builddir)/src/testing/libgnunettesting.la \
648 $(top_builddir)/src/identity/libgnunetidentity.la \
649 $(top_builddir)/src/util/libgnunetutil.la \
650 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
651 libgnunetnamestore.la
652
653test_namestore_api_zone_iteration_specific_zone_flat_SOURCES = \
654 test_namestore_api_zone_iteration_specific_zone.c
655test_namestore_api_zone_iteration_specific_zone_flat_LDADD = \
656 $(top_builddir)/src/testing/libgnunettesting.la \
657 $(top_builddir)/src/identity/libgnunetidentity.la \
658 $(top_builddir)/src/util/libgnunetutil.la \
659 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
660 libgnunetnamestore.la
661
662test_namestore_api_zone_iteration_specific_zone_sqlite_SOURCES = \
663 test_namestore_api_zone_iteration_specific_zone.c
664test_namestore_api_zone_iteration_specific_zone_sqlite_LDADD = \
665 $(top_builddir)/src/testing/libgnunettesting.la \
666 $(top_builddir)/src/identity/libgnunetidentity.la \
667 $(top_builddir)/src/util/libgnunetutil.la \
668 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
669 libgnunetnamestore.la
670
671test_namestore_api_zone_iteration_specific_zone_postgres_SOURCES = \
672 test_namestore_api_zone_iteration_specific_zone.c
673test_namestore_api_zone_iteration_specific_zone_postgres_LDADD = \
674 $(top_builddir)/src/testing/libgnunettesting.la \
675 $(top_builddir)/src/identity/libgnunetidentity.la \
676 $(top_builddir)/src/util/libgnunetutil.la \
677 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
678 libgnunetnamestore.la
679
680test_namestore_api_zone_iteration_stop_flat_SOURCES = \
681 test_namestore_api_zone_iteration_stop.c
682test_namestore_api_zone_iteration_stop_flat_LDADD = \
683 $(top_builddir)/src/testing/libgnunettesting.la \
684 $(top_builddir)/src/identity/libgnunetidentity.la \
685 $(top_builddir)/src/util/libgnunetutil.la \
686 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
687 libgnunetnamestore.la
688
689test_namestore_api_zone_iteration_stop_sqlite_SOURCES = \
690 test_namestore_api_zone_iteration_stop.c
691test_namestore_api_zone_iteration_stop_sqlite_LDADD = \
692 $(top_builddir)/src/testing/libgnunettesting.la \
693 $(top_builddir)/src/identity/libgnunetidentity.la \
694 $(top_builddir)/src/util/libgnunetutil.la \
695 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
696 libgnunetnamestore.la
697
698test_namestore_api_zone_iteration_stop_postgres_SOURCES = \
699 test_namestore_api_zone_iteration_stop.c
700test_namestore_api_zone_iteration_stop_postgres_LDADD = \
701 $(top_builddir)/src/testing/libgnunettesting.la \
702 $(top_builddir)/src/identity/libgnunetidentity.la \
703 $(top_builddir)/src/util/libgnunetutil.la \
704 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
705 libgnunetnamestore.la
706
707test_plugin_namestore_flat_SOURCES = \
708 test_plugin_namestore.c
709test_plugin_namestore_flat_LDADD = \
710 $(top_builddir)/src/testing/libgnunettesting.la \
711 $(top_builddir)/src/identity/libgnunetidentity.la \
712 $(top_builddir)/src/util/libgnunetutil.la
713
714test_plugin_namestore_sqlite_SOURCES = \
715 test_plugin_namestore.c
716test_plugin_namestore_sqlite_LDADD = \
717 $(top_builddir)/src/testing/libgnunettesting.la \
718 $(top_builddir)/src/identity/libgnunetidentity.la \
719 $(top_builddir)/src/util/libgnunetutil.la
720
721test_plugin_namestore_postgres_SOURCES = \
722 test_plugin_namestore.c
723test_plugin_namestore_postgres_LDADD = \
724 $(top_builddir)/src/identity/libgnunetidentity.la \
725 $(top_builddir)/src/testing/libgnunettesting.la \
726 $(top_builddir)/src/util/libgnunetutil.la
727
728check_SCRIPTS = \
729 test_namestore_put.sh \
730 test_namestore_lookup.sh \
731 test_namestore_delete.sh
732
733check_SCRIPTS += \
734 test_plugin_rest_namestore.sh
735
736EXTRA_DIST = \
737 test_common.c \
738 test_namestore_api.conf \
739 test_namestore_api_postgres.conf \
740 test_namestore_api_sqlite.conf \
741 test_namestore_api_flat.conf \
742 perf_namestore_api_postgres.conf \
743 perf_namestore_api_sqlite.conf \
744 perf_namestore_api_flat.conf \
745 test_plugin_namestore_sqlite.conf \
746 test_plugin_namestore_postgres.conf \
747 test_plugin_namestore_flat.conf \
748 test_hostkey \
749 $(check_SCRIPTS)