aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am755
1 files changed, 0 insertions, 755 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
deleted file mode 100644
index 18e6a196b..000000000
--- a/src/namestore/Makefile.am
+++ /dev/null
@@ -1,755 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS)
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10pkgcfg_DATA = \
11 namestore.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIBS = -lgcov
16endif
17
18HEAP_PLUGIN = libgnunet_plugin_namestore_flat.la
19if HAVE_TESTING
20HEAP_TESTS = test_plugin_namestore_flat \
21 test_namestore_api_store_flat \
22 test_namestore_api_store_update_flat \
23 test_namestore_api_remove_flat \
24 test_namestore_api_zone_iteration_flat \
25 test_namestore_api_lookup_nick_flat \
26 test_namestore_api_monitoring_flat \
27 test_namestore_api_lookup_public_flat \
28 test_namestore_api_lookup_private_flat \
29 test_namestore_api_lookup_shadow_flat \
30 test_namestore_api_lookup_shadow_filter_flat \
31 test_namestore_api_remove_not_existing_record_flat \
32 test_namestore_api_zone_iteration_nick_flat \
33 test_namestore_api_zone_iteration_specific_zone_flat \
34 test_namestore_api_zone_iteration_stop_flat \
35 test_namestore_api_monitoring_existing_flat \
36 test_namestore_api_zone_to_name_flat \
37 perf_namestore_api_zone_iteration_flat
38endif
39
40if HAVE_SQLITE
41SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
42if HAVE_TESTING
43SQLITE_TESTS = test_plugin_namestore_sqlite \
44 test_namestore_api_store_sqlite \
45 test_namestore_api_store_update_sqlite \
46 test_namestore_api_zone_iteration_sqlite \
47 test_namestore_api_remove_sqlite \
48 test_namestore_api_lookup_nick_sqlite \
49 test_namestore_api_monitoring_sqlite \
50 test_namestore_api_lookup_public_sqlite \
51 test_namestore_api_lookup_private_sqlite \
52 test_namestore_api_lookup_shadow_sqlite \
53 test_namestore_api_lookup_shadow_filter_sqlite \
54 test_namestore_api_remove_not_existing_record_sqlite \
55 test_namestore_api_zone_iteration_nick_sqlite \
56 test_namestore_api_zone_iteration_specific_zone_sqlite \
57 test_namestore_api_zone_iteration_stop_sqlite \
58 test_namestore_api_monitoring_existing_sqlite \
59 test_namestore_api_zone_to_name_sqlite \
60 perf_namestore_api_zone_iteration_sqlite
61endif
62endif
63
64if HAVE_POSTGRESQL
65POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
66if HAVE_TESTING
67POSTGRES_TESTS = test_plugin_namestore_postgres \
68 test_namestore_api_store_postgres \
69 test_namestore_api_store_update_postgres \
70 test_namestore_api_remove_postgres \
71 test_namestore_api_zone_iteration_postgres \
72 test_namestore_api_lookup_nick_postgres \
73 test_namestore_api_monitoring_postgres \
74 test_namestore_api_lookup_public_postgres \
75 test_namestore_api_lookup_private_postgres \
76 test_namestore_api_lookup_shadow_postgres \
77 test_namestore_api_lookup_shadow_filter_postgres \
78 test_namestore_api_remove_not_existing_record_postgres \
79 test_namestore_api_zone_iteration_nick_postgres \
80 test_namestore_api_zone_iteration_specific_zone_postgres \
81 test_namestore_api_zone_iteration_stop_postgres \
82 test_namestore_api_monitoring_existing_postgres \
83 test_namestore_api_zone_to_name_postgres \
84 perf_namestore_api_zone_iteration_postgres
85endif
86endif
87
88if HAVE_SQLITE
89check_PROGRAMS = \
90 $(SQLITE_TESTS) \
91 $(POSTGRES_TESTS) \
92 $(HEAP_TESTS)
93endif
94
95if ENABLE_TEST_RUN
96AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
97TESTS = \
98 $(check_PROGRAMS) \
99 $(check_SCRIPTS)
100endif
101
102REST_PLUGIN = libgnunet_plugin_rest_namestore.la
103
104lib_LTLIBRARIES = \
105 libgnunetnamestore.la
106
107
108libexec_PROGRAMS = \
109 gnunet-service-namestore
110
111bin_PROGRAMS = \
112 gnunet-namestore \
113 gnunet-zoneimport
114
115libexec_PROGRAMS += \
116 gnunet-namestore-fcfsd
117
118
119plugin_LTLIBRARIES = \
120 $(SQLITE_PLUGIN) \
121 $(POSTGRES_PLUGIN) \
122 $(HEAP_PLUGIN) \
123 $(REST_PLUGIN)
124
125
126libgnunet_plugin_rest_namestore_la_SOURCES = \
127 plugin_rest_namestore.c
128libgnunet_plugin_rest_namestore_la_LIBADD = \
129 libgnunetnamestore.la \
130 $(top_builddir)/src/rest/libgnunetrest.la \
131 $(top_builddir)/src/identity/libgnunetidentity.la \
132 $(top_builddir)/src/json/libgnunetjson.la \
133 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
134 $(top_builddir)/src/gnsrecord/libgnunetgnsrecordjson.la \
135 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
136 $(LTLIBINTL) -ljansson $(MHD_LIBS)
137libgnunet_plugin_rest_namestore_la_LDFLAGS = \
138 $(GN_PLUGIN_LDFLAGS)
139libgnunet_plugin_rest_namestore_la_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
140
141
142libgnunetnamestore_la_SOURCES = \
143 namestore_api.c \
144 namestore_api_monitor.c \
145 namestore.h
146libgnunetnamestore_la_LIBADD = \
147 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
148 $(top_builddir)/src/identity/libgnunetidentity.la \
149 $(top_builddir)/src/statistics/libgnunetstatistics.la \
150 $(top_builddir)/src/util/libgnunetutil.la \
151 $(GN_LIBINTL)
152libgnunetnamestore_la_LDFLAGS = \
153 $(GN_LIB_LDFLAGS) \
154 -version-info 0:1:0
155
156
157
158gnunet_zoneimport_SOURCES = \
159 gnunet-zoneimport.c
160gnunet_zoneimport_LDADD = \
161 libgnunetnamestore.la \
162 $(top_builddir)/src/statistics/libgnunetstatistics.la \
163 $(top_builddir)/src/identity/libgnunetidentity.la \
164 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
165 $(top_builddir)/src/util/libgnunetutil.la \
166 $(GN_LIBINTL)
167
168gnunet_namestore_SOURCES = \
169 gnunet-namestore.c
170gnunet_namestore_LDADD = \
171 $(top_builddir)/src/identity/libgnunetidentity.la \
172 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
173 $(top_builddir)/src/util/libgnunetutil.la \
174 libgnunetnamestore.la \
175 $(GN_LIBINTL)
176
177
178gnunet_namestore_fcfsd_SOURCES = \
179 gnunet-namestore-fcfsd.c
180gnunet_namestore_fcfsd_LDADD = $(MHD_LIBS) \
181 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
182 $(top_builddir)/src/identity/libgnunetidentity.la \
183 libgnunetnamestore.la \
184 $(top_builddir)/src/util/libgnunetutil.la \
185 $(top_builddir)/src/json/libgnunetjson.la \
186 $(GN_LIBINTL) -ljansson
187gnunet_namestore_fcfsd_CFLAGS = $(MHD_CFLAGS) $(AM_CFLAGS)
188
189
190gnunet_service_namestore_SOURCES = \
191 gnunet-service-namestore.c
192
193gnunet_service_namestore_LDADD = \
194 $(top_builddir)/src/namecache/libgnunetnamecache.la \
195 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
196 $(top_builddir)/src/identity/libgnunetidentity.la \
197 $(top_builddir)/src/statistics/libgnunetstatistics.la \
198 $(top_builddir)/src/util/libgnunetutil.la \
199 libgnunetnamestore.la \
200 $(GN_LIBINTL)
201
202
203
204libgnunet_plugin_namestore_flat_la_SOURCES = \
205 plugin_namestore_flat.c
206libgnunet_plugin_namestore_flat_la_LIBADD = \
207 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
208 $(top_builddir)/src/identity/libgnunetidentity.la \
209 $(top_builddir)/src/statistics/libgnunetstatistics.la \
210 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
211 $(LTLIBINTL)
212libgnunet_plugin_namestore_flat_la_LDFLAGS = \
213 $(GN_PLUGIN_LDFLAGS)
214
215
216libgnunet_plugin_namestore_sqlite_la_SOURCES = \
217 plugin_namestore_sqlite.c
218libgnunet_plugin_namestore_sqlite_la_LIBADD = \
219 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
220 $(top_builddir)/src/identity/libgnunetidentity.la \
221 $(top_builddir)/src/sq/libgnunetsq.la \
222 $(top_builddir)/src/statistics/libgnunetstatistics.la \
223 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
224 $(LTLIBINTL)
225libgnunet_plugin_namestore_sqlite_la_LDFLAGS = \
226 $(GN_PLUGIN_LDFLAGS)
227
228libgnunet_plugin_namestore_postgres_la_SOURCES = \
229 plugin_namestore_postgres.c
230libgnunet_plugin_namestore_postgres_la_LIBADD = \
231 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
232 $(top_builddir)/src/identity/libgnunetidentity.la \
233 $(top_builddir)/src/pq/libgnunetpq.la \
234 $(top_builddir)/src/statistics/libgnunetstatistics.la \
235 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq \
236 $(LTLIBINTL)
237libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
238 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
239
240test_namestore_api_store_flat_SOURCES = \
241 test_namestore_api_store.c
242test_namestore_api_store_flat_LDADD = \
243 $(top_builddir)/src/testing/libgnunettesting.la \
244 $(top_builddir)/src/util/libgnunetutil.la \
245 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
246 $(top_builddir)/src/identity/libgnunetidentity.la \
247 libgnunetnamestore.la
248
249test_namestore_api_store_sqlite_SOURCES = \
250 test_namestore_api_store.c
251test_namestore_api_store_sqlite_LDADD = \
252 $(top_builddir)/src/testing/libgnunettesting.la \
253 $(top_builddir)/src/util/libgnunetutil.la \
254 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
255 $(top_builddir)/src/identity/libgnunetidentity.la \
256 libgnunetnamestore.la
257
258test_namestore_api_store_postgres_SOURCES = \
259 test_namestore_api_store.c
260test_namestore_api_store_postgres_LDADD = \
261 $(top_builddir)/src/testing/libgnunettesting.la \
262 $(top_builddir)/src/util/libgnunetutil.la \
263 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
264 $(top_builddir)/src/identity/libgnunetidentity.la \
265 libgnunetnamestore.la
266
267test_namestore_api_store_update_flat_SOURCES = \
268 test_namestore_api_store_update.c
269test_namestore_api_store_update_flat_LDADD = \
270 $(top_builddir)/src/testing/libgnunettesting.la \
271 $(top_builddir)/src/util/libgnunetutil.la \
272 $(top_builddir)/src/identity/libgnunetidentity.la \
273 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
274 $(top_builddir)/src/namecache/libgnunetnamecache.la \
275 libgnunetnamestore.la
276
277test_namestore_api_store_update_sqlite_SOURCES = \
278 test_namestore_api_store_update.c
279test_namestore_api_store_update_sqlite_LDADD = \
280 $(top_builddir)/src/testing/libgnunettesting.la \
281 $(top_builddir)/src/util/libgnunetutil.la \
282 $(top_builddir)/src/identity/libgnunetidentity.la \
283 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
284 $(top_builddir)/src/namecache/libgnunetnamecache.la \
285 libgnunetnamestore.la
286
287test_namestore_api_store_update_postgres_SOURCES = \
288 test_namestore_api_store_update.c
289test_namestore_api_store_update_postgres_LDADD = \
290 $(top_builddir)/src/testing/libgnunettesting.la \
291 $(top_builddir)/src/util/libgnunetutil.la \
292 $(top_builddir)/src/identity/libgnunetidentity.la \
293 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
294 $(top_builddir)/src/namecache/libgnunetnamecache.la \
295 libgnunetnamestore.la
296
297test_namestore_api_lookup_public_flat_SOURCES = \
298 test_namestore_api_lookup_public.c
299test_namestore_api_lookup_public_flat_LDADD = \
300 $(top_builddir)/src/testing/libgnunettesting.la \
301 $(top_builddir)/src/identity/libgnunetidentity.la \
302 $(top_builddir)/src/util/libgnunetutil.la \
303 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
304 $(top_builddir)/src/namecache/libgnunetnamecache.la \
305 libgnunetnamestore.la
306
307test_namestore_api_lookup_public_sqlite_SOURCES = \
308 test_namestore_api_lookup_public.c
309test_namestore_api_lookup_public_sqlite_LDADD = \
310 $(top_builddir)/src/testing/libgnunettesting.la \
311 $(top_builddir)/src/util/libgnunetutil.la \
312 $(top_builddir)/src/identity/libgnunetidentity.la \
313 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
314 $(top_builddir)/src/namecache/libgnunetnamecache.la \
315 libgnunetnamestore.la
316
317test_namestore_api_lookup_public_postgres_SOURCES = \
318 test_namestore_api_lookup_public.c
319test_namestore_api_lookup_public_postgres_LDADD = \
320 $(top_builddir)/src/testing/libgnunettesting.la \
321 $(top_builddir)/src/util/libgnunetutil.la \
322 $(top_builddir)/src/identity/libgnunetidentity.la \
323 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
324 $(top_builddir)/src/namecache/libgnunetnamecache.la \
325 libgnunetnamestore.la
326
327test_namestore_api_lookup_nick_sqlite_SOURCES = \
328 test_namestore_api_lookup_nick.c
329test_namestore_api_lookup_nick_sqlite_LDADD = \
330 $(top_builddir)/src/testing/libgnunettesting.la \
331 $(top_builddir)/src/util/libgnunetutil.la \
332 $(top_builddir)/src/identity/libgnunetidentity.la \
333 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
334 $(top_builddir)/src/namecache/libgnunetnamecache.la \
335 libgnunetnamestore.la
336
337test_namestore_api_lookup_nick_postgres_SOURCES = \
338 test_namestore_api_lookup_nick.c
339test_namestore_api_lookup_nick_postgres_LDADD = \
340 $(top_builddir)/src/testing/libgnunettesting.la \
341 $(top_builddir)/src/util/libgnunetutil.la \
342 $(top_builddir)/src/identity/libgnunetidentity.la \
343 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
344 $(top_builddir)/src/namecache/libgnunetnamecache.la \
345 libgnunetnamestore.la
346
347test_namestore_api_lookup_nick_flat_SOURCES = \
348 test_namestore_api_lookup_nick.c
349test_namestore_api_lookup_nick_flat_LDADD = \
350 $(top_builddir)/src/testing/libgnunettesting.la \
351 $(top_builddir)/src/identity/libgnunetidentity.la \
352 $(top_builddir)/src/util/libgnunetutil.la \
353 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
354 $(top_builddir)/src/namecache/libgnunetnamecache.la \
355 libgnunetnamestore.la
356
357test_namestore_api_lookup_private_flat_SOURCES = \
358 test_namestore_api_lookup_private.c
359test_namestore_api_lookup_private_flat_LDADD = \
360 $(top_builddir)/src/testing/libgnunettesting.la \
361 $(top_builddir)/src/identity/libgnunetidentity.la \
362 $(top_builddir)/src/util/libgnunetutil.la \
363 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
364 $(top_builddir)/src/namecache/libgnunetnamecache.la \
365 libgnunetnamestore.la
366
367test_namestore_api_lookup_private_sqlite_SOURCES = \
368 test_namestore_api_lookup_private.c
369test_namestore_api_lookup_private_sqlite_LDADD = \
370 $(top_builddir)/src/testing/libgnunettesting.la \
371 $(top_builddir)/src/identity/libgnunetidentity.la \
372 $(top_builddir)/src/util/libgnunetutil.la \
373 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
374 $(top_builddir)/src/namecache/libgnunetnamecache.la \
375 libgnunetnamestore.la
376
377test_namestore_api_lookup_private_postgres_SOURCES = \
378 test_namestore_api_lookup_private.c
379test_namestore_api_lookup_private_postgres_LDADD = \
380 $(top_builddir)/src/identity/libgnunetidentity.la \
381 $(top_builddir)/src/testing/libgnunettesting.la \
382 $(top_builddir)/src/util/libgnunetutil.la \
383 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
384 $(top_builddir)/src/namecache/libgnunetnamecache.la \
385 libgnunetnamestore.la
386
387test_namestore_api_lookup_shadow_flat_SOURCES = \
388 test_namestore_api_lookup_shadow.c
389test_namestore_api_lookup_shadow_flat_LDADD = \
390 $(top_builddir)/src/testing/libgnunettesting.la \
391 $(top_builddir)/src/identity/libgnunetidentity.la \
392 $(top_builddir)/src/util/libgnunetutil.la \
393 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
394 $(top_builddir)/src/namecache/libgnunetnamecache.la \
395 libgnunetnamestore.la
396
397test_namestore_api_lookup_shadow_sqlite_SOURCES = \
398 test_namestore_api_lookup_shadow.c
399test_namestore_api_lookup_shadow_sqlite_LDADD = \
400 $(top_builddir)/src/testing/libgnunettesting.la \
401 $(top_builddir)/src/util/libgnunetutil.la \
402 $(top_builddir)/src/identity/libgnunetidentity.la \
403 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
404 $(top_builddir)/src/namecache/libgnunetnamecache.la \
405 libgnunetnamestore.la
406
407test_namestore_api_lookup_shadow_postgres_SOURCES = \
408 test_namestore_api_lookup_shadow.c
409test_namestore_api_lookup_shadow_postgres_LDADD = \
410 $(top_builddir)/src/testing/libgnunettesting.la \
411 $(top_builddir)/src/util/libgnunetutil.la \
412 $(top_builddir)/src/identity/libgnunetidentity.la \
413 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
414 $(top_builddir)/src/namecache/libgnunetnamecache.la \
415 libgnunetnamestore.la
416
417test_namestore_api_lookup_shadow_filter_flat_SOURCES = \
418 test_namestore_api_lookup_shadow_filter.c
419test_namestore_api_lookup_shadow_filter_flat_LDADD = \
420 $(top_builddir)/src/testing/libgnunettesting.la \
421 $(top_builddir)/src/util/libgnunetutil.la \
422 $(top_builddir)/src/identity/libgnunetidentity.la \
423 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
424 $(top_builddir)/src/namecache/libgnunetnamecache.la \
425 libgnunetnamestore.la
426
427test_namestore_api_lookup_shadow_filter_sqlite_SOURCES = \
428 test_namestore_api_lookup_shadow_filter.c
429test_namestore_api_lookup_shadow_filter_sqlite_LDADD = \
430 $(top_builddir)/src/testing/libgnunettesting.la \
431 $(top_builddir)/src/identity/libgnunetidentity.la \
432 $(top_builddir)/src/util/libgnunetutil.la \
433 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
434 $(top_builddir)/src/namecache/libgnunetnamecache.la \
435 libgnunetnamestore.la
436test_namestore_api_lookup_shadow_filter_postgres_SOURCES = \
437 test_namestore_api_lookup_shadow_filter.c
438test_namestore_api_lookup_shadow_filter_postgres_LDADD = \
439 $(top_builddir)/src/testing/libgnunettesting.la \
440 $(top_builddir)/src/identity/libgnunetidentity.la \
441 $(top_builddir)/src/util/libgnunetutil.la \
442 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
443 $(top_builddir)/src/namecache/libgnunetnamecache.la \
444 libgnunetnamestore.la
445
446test_namestore_api_remove_sqlite_SOURCES = \
447 test_namestore_api_remove.c
448test_namestore_api_remove_sqlite_LDADD = \
449 $(top_builddir)/src/identity/libgnunetidentity.la \
450 $(top_builddir)/src/testing/libgnunettesting.la \
451 $(top_builddir)/src/util/libgnunetutil.la \
452 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
453 libgnunetnamestore.la
454
455test_namestore_api_remove_postgres_SOURCES = \
456 test_namestore_api_remove.c
457test_namestore_api_remove_postgres_LDADD = \
458 $(top_builddir)/src/identity/libgnunetidentity.la \
459 $(top_builddir)/src/testing/libgnunettesting.la \
460 $(top_builddir)/src/util/libgnunetutil.la \
461 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
462 libgnunetnamestore.la
463
464test_namestore_api_remove_flat_SOURCES = \
465 test_namestore_api_remove.c
466test_namestore_api_remove_flat_LDADD = \
467 $(top_builddir)/src/testing/libgnunettesting.la \
468 $(top_builddir)/src/identity/libgnunetidentity.la \
469 $(top_builddir)/src/util/libgnunetutil.la \
470 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
471 libgnunetnamestore.la
472
473test_namestore_api_remove_not_existing_record_flat_SOURCES = \
474 test_namestore_api_remove_not_existing_record.c
475test_namestore_api_remove_not_existing_record_flat_LDADD = \
476 $(top_builddir)/src/testing/libgnunettesting.la \
477 $(top_builddir)/src/identity/libgnunetidentity.la \
478 $(top_builddir)/src/util/libgnunetutil.la \
479 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
480 libgnunetnamestore.la
481
482test_namestore_api_remove_not_existing_record_sqlite_SOURCES = \
483 test_namestore_api_remove_not_existing_record.c
484test_namestore_api_remove_not_existing_record_sqlite_LDADD = \
485 $(top_builddir)/src/testing/libgnunettesting.la \
486 $(top_builddir)/src/util/libgnunetutil.la \
487 $(top_builddir)/src/identity/libgnunetidentity.la \
488 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
489 libgnunetnamestore.la
490
491test_namestore_api_remove_not_existing_record_postgres_SOURCES = \
492 test_namestore_api_remove_not_existing_record.c
493test_namestore_api_remove_not_existing_record_postgres_LDADD = \
494 $(top_builddir)/src/testing/libgnunettesting.la \
495 $(top_builddir)/src/identity/libgnunetidentity.la \
496 $(top_builddir)/src/util/libgnunetutil.la \
497 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
498 libgnunetnamestore.la
499
500test_namestore_api_zone_to_name_flat_SOURCES = \
501 test_namestore_api_zone_to_name.c
502test_namestore_api_zone_to_name_flat_LDADD = \
503 $(top_builddir)/src/identity/libgnunetidentity.la \
504 $(top_builddir)/src/testing/libgnunettesting.la \
505 $(top_builddir)/src/util/libgnunetutil.la \
506 libgnunetnamestore.la
507
508test_namestore_api_zone_to_name_sqlite_SOURCES = \
509 test_namestore_api_zone_to_name.c
510test_namestore_api_zone_to_name_sqlite_LDADD = \
511 $(top_builddir)/src/identity/libgnunetidentity.la \
512 $(top_builddir)/src/testing/libgnunettesting.la \
513 $(top_builddir)/src/util/libgnunetutil.la \
514 libgnunetnamestore.la
515
516test_namestore_api_zone_to_name_postgres_SOURCES = \
517 test_namestore_api_zone_to_name.c
518test_namestore_api_zone_to_name_postgres_LDADD = \
519 $(top_builddir)/src/identity/libgnunetidentity.la \
520 $(top_builddir)/src/testing/libgnunettesting.la \
521 $(top_builddir)/src/util/libgnunetutil.la \
522 libgnunetnamestore.la
523
524test_namestore_api_monitoring_flat_SOURCES = \
525 test_namestore_api_monitoring.c
526test_namestore_api_monitoring_flat_LDADD = \
527 $(top_builddir)/src/testing/libgnunettesting.la \
528 libgnunetnamestore.la \
529 $(top_builddir)/src/identity/libgnunetidentity.la \
530 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
531 $(top_builddir)/src/util/libgnunetutil.la
532
533test_namestore_api_monitoring_sqlite_SOURCES = \
534 test_namestore_api_monitoring.c
535test_namestore_api_monitoring_sqlite_LDADD = \
536 $(top_builddir)/src/identity/libgnunetidentity.la \
537 $(top_builddir)/src/testing/libgnunettesting.la \
538 libgnunetnamestore.la \
539 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
540 $(top_builddir)/src/util/libgnunetutil.la
541
542test_namestore_api_monitoring_postgres_SOURCES = \
543 test_namestore_api_monitoring.c
544test_namestore_api_monitoring_postgres_LDADD = \
545 $(top_builddir)/src/testing/libgnunettesting.la \
546 $(top_builddir)/src/identity/libgnunetidentity.la \
547 libgnunetnamestore.la \
548 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
549 $(top_builddir)/src/util/libgnunetutil.la
550
551test_namestore_api_monitoring_existing_flat_SOURCES = \
552 test_namestore_api_monitoring_existing.c
553test_namestore_api_monitoring_existing_flat_LDADD = \
554 $(top_builddir)/src/testing/libgnunettesting.la \
555 $(top_builddir)/src/identity/libgnunetidentity.la \
556 libgnunetnamestore.la \
557 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
558 $(top_builddir)/src/util/libgnunetutil.la
559
560test_namestore_api_monitoring_existing_sqlite_SOURCES = \
561 test_namestore_api_monitoring_existing.c
562test_namestore_api_monitoring_existing_sqlite_LDADD = \
563 $(top_builddir)/src/testing/libgnunettesting.la \
564 $(top_builddir)/src/identity/libgnunetidentity.la \
565 libgnunetnamestore.la \
566 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
567 $(top_builddir)/src/util/libgnunetutil.la
568
569test_namestore_api_monitoring_existing_postgres_SOURCES = \
570 test_namestore_api_monitoring_existing.c
571test_namestore_api_monitoring_existing_postgres_LDADD = \
572 $(top_builddir)/src/testing/libgnunettesting.la \
573 libgnunetnamestore.la \
574 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
575 $(top_builddir)/src/identity/libgnunetidentity.la \
576 $(top_builddir)/src/util/libgnunetutil.la
577
578test_namestore_api_zone_iteration_flat_SOURCES = \
579 test_namestore_api_zone_iteration.c
580test_namestore_api_zone_iteration_flat_LDADD = \
581 $(top_builddir)/src/testing/libgnunettesting.la \
582 $(top_builddir)/src/identity/libgnunetidentity.la \
583 $(top_builddir)/src/util/libgnunetutil.la \
584 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
585 libgnunetnamestore.la
586
587test_namestore_api_zone_iteration_sqlite_SOURCES = \
588 test_namestore_api_zone_iteration.c
589test_namestore_api_zone_iteration_sqlite_LDADD = \
590 $(top_builddir)/src/testing/libgnunettesting.la \
591 $(top_builddir)/src/identity/libgnunetidentity.la \
592 $(top_builddir)/src/util/libgnunetutil.la \
593 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
594 libgnunetnamestore.la
595
596test_namestore_api_zone_iteration_postgres_SOURCES = \
597 test_namestore_api_zone_iteration.c
598test_namestore_api_zone_iteration_postgres_LDADD = \
599 $(top_builddir)/src/testing/libgnunettesting.la \
600 $(top_builddir)/src/identity/libgnunetidentity.la \
601 $(top_builddir)/src/util/libgnunetutil.la \
602 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
603 libgnunetnamestore.la
604
605perf_namestore_api_zone_iteration_postgres_SOURCES = \
606 perf_namestore_api_zone_iteration.c
607perf_namestore_api_zone_iteration_postgres_LDADD = \
608 $(top_builddir)/src/testing/libgnunettesting.la \
609 $(top_builddir)/src/util/libgnunetutil.la \
610 $(top_builddir)/src/identity/libgnunetidentity.la \
611 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
612 libgnunetnamestore.la
613
614perf_namestore_api_zone_iteration_sqlite_SOURCES = \
615 perf_namestore_api_zone_iteration.c
616perf_namestore_api_zone_iteration_sqlite_LDADD = \
617 $(top_builddir)/src/testing/libgnunettesting.la \
618 $(top_builddir)/src/identity/libgnunetidentity.la \
619 $(top_builddir)/src/util/libgnunetutil.la \
620 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
621 libgnunetnamestore.la
622
623perf_namestore_api_zone_iteration_flat_SOURCES = \
624 perf_namestore_api_zone_iteration.c
625perf_namestore_api_zone_iteration_flat_LDADD = \
626 $(top_builddir)/src/testing/libgnunettesting.la \
627 $(top_builddir)/src/identity/libgnunetidentity.la \
628 $(top_builddir)/src/util/libgnunetutil.la \
629 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
630 libgnunetnamestore.la
631
632test_namestore_api_zone_iteration_nick_flat_SOURCES = \
633 test_namestore_api_zone_iteration_nick.c
634test_namestore_api_zone_iteration_nick_flat_LDADD = \
635 $(top_builddir)/src/testing/libgnunettesting.la \
636 $(top_builddir)/src/util/libgnunetutil.la \
637 $(top_builddir)/src/identity/libgnunetidentity.la \
638 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
639 libgnunetnamestore.la
640
641test_namestore_api_zone_iteration_nick_sqlite_SOURCES = \
642 test_namestore_api_zone_iteration_nick.c
643test_namestore_api_zone_iteration_nick_sqlite_LDADD = \
644 $(top_builddir)/src/testing/libgnunettesting.la \
645 $(top_builddir)/src/identity/libgnunetidentity.la \
646 $(top_builddir)/src/util/libgnunetutil.la \
647 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
648 libgnunetnamestore.la
649
650test_namestore_api_zone_iteration_nick_postgres_SOURCES = \
651 test_namestore_api_zone_iteration_nick.c
652test_namestore_api_zone_iteration_nick_postgres_LDADD = \
653 $(top_builddir)/src/testing/libgnunettesting.la \
654 $(top_builddir)/src/identity/libgnunetidentity.la \
655 $(top_builddir)/src/util/libgnunetutil.la \
656 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
657 libgnunetnamestore.la
658
659test_namestore_api_zone_iteration_specific_zone_flat_SOURCES = \
660 test_namestore_api_zone_iteration_specific_zone.c
661test_namestore_api_zone_iteration_specific_zone_flat_LDADD = \
662 $(top_builddir)/src/testing/libgnunettesting.la \
663 $(top_builddir)/src/identity/libgnunetidentity.la \
664 $(top_builddir)/src/util/libgnunetutil.la \
665 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
666 libgnunetnamestore.la
667
668test_namestore_api_zone_iteration_specific_zone_sqlite_SOURCES = \
669 test_namestore_api_zone_iteration_specific_zone.c
670test_namestore_api_zone_iteration_specific_zone_sqlite_LDADD = \
671 $(top_builddir)/src/testing/libgnunettesting.la \
672 $(top_builddir)/src/identity/libgnunetidentity.la \
673 $(top_builddir)/src/util/libgnunetutil.la \
674 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
675 libgnunetnamestore.la
676
677test_namestore_api_zone_iteration_specific_zone_postgres_SOURCES = \
678 test_namestore_api_zone_iteration_specific_zone.c
679test_namestore_api_zone_iteration_specific_zone_postgres_LDADD = \
680 $(top_builddir)/src/testing/libgnunettesting.la \
681 $(top_builddir)/src/identity/libgnunetidentity.la \
682 $(top_builddir)/src/util/libgnunetutil.la \
683 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
684 libgnunetnamestore.la
685
686test_namestore_api_zone_iteration_stop_flat_SOURCES = \
687 test_namestore_api_zone_iteration_stop.c
688test_namestore_api_zone_iteration_stop_flat_LDADD = \
689 $(top_builddir)/src/testing/libgnunettesting.la \
690 $(top_builddir)/src/identity/libgnunetidentity.la \
691 $(top_builddir)/src/util/libgnunetutil.la \
692 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
693 libgnunetnamestore.la
694
695test_namestore_api_zone_iteration_stop_sqlite_SOURCES = \
696 test_namestore_api_zone_iteration_stop.c
697test_namestore_api_zone_iteration_stop_sqlite_LDADD = \
698 $(top_builddir)/src/testing/libgnunettesting.la \
699 $(top_builddir)/src/identity/libgnunetidentity.la \
700 $(top_builddir)/src/util/libgnunetutil.la \
701 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
702 libgnunetnamestore.la
703
704test_namestore_api_zone_iteration_stop_postgres_SOURCES = \
705 test_namestore_api_zone_iteration_stop.c
706test_namestore_api_zone_iteration_stop_postgres_LDADD = \
707 $(top_builddir)/src/testing/libgnunettesting.la \
708 $(top_builddir)/src/identity/libgnunetidentity.la \
709 $(top_builddir)/src/util/libgnunetutil.la \
710 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
711 libgnunetnamestore.la
712
713test_plugin_namestore_flat_SOURCES = \
714 test_plugin_namestore.c
715test_plugin_namestore_flat_LDADD = \
716 $(top_builddir)/src/testing/libgnunettesting.la \
717 $(top_builddir)/src/identity/libgnunetidentity.la \
718 $(top_builddir)/src/util/libgnunetutil.la
719
720test_plugin_namestore_sqlite_SOURCES = \
721 test_plugin_namestore.c
722test_plugin_namestore_sqlite_LDADD = \
723 $(top_builddir)/src/testing/libgnunettesting.la \
724 $(top_builddir)/src/identity/libgnunetidentity.la \
725 $(top_builddir)/src/util/libgnunetutil.la
726
727test_plugin_namestore_postgres_SOURCES = \
728 test_plugin_namestore.c
729test_plugin_namestore_postgres_LDADD = \
730 $(top_builddir)/src/identity/libgnunetidentity.la \
731 $(top_builddir)/src/testing/libgnunettesting.la \
732 $(top_builddir)/src/util/libgnunetutil.la
733
734check_SCRIPTS = \
735 test_namestore_put.sh \
736 test_namestore_lookup.sh \
737 test_namestore_delete.sh
738
739check_SCRIPTS += \
740 test_plugin_rest_namestore.sh
741
742EXTRA_DIST = \
743 test_common.c \
744 test_namestore_api.conf \
745 test_namestore_api_postgres.conf \
746 test_namestore_api_sqlite.conf \
747 test_namestore_api_flat.conf \
748 perf_namestore_api_postgres.conf \
749 perf_namestore_api_sqlite.conf \
750 perf_namestore_api_flat.conf \
751 test_plugin_namestore_sqlite.conf \
752 test_plugin_namestore_postgres.conf \
753 test_plugin_namestore_flat.conf \
754 test_hostkey \
755 $(check_SCRIPTS)