aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am57
1 files changed, 40 insertions, 17 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index ac4eebd06..25941b4fb 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -104,10 +104,50 @@ TESTS = \
104 $(check_SCRIPTS) 104 $(check_SCRIPTS)
105endif 105endif
106 106
107if HAVE_MHD
108if HAVE_JSON
109REST_PLUGIN = libgnunet_plugin_rest_namestore.la
110endif
111endif
112
107lib_LTLIBRARIES = \ 113lib_LTLIBRARIES = \
108 libgnunetnamestore.la 114 libgnunetnamestore.la
109 115
110 116
117libexec_PROGRAMS = \
118 gnunet-service-namestore
119
120bin_PROGRAMS = \
121 gnunet-namestore \
122 gnunet-zoneimport
123
124if HAVE_MHD
125libexec_PROGRAMS += \
126 gnunet-namestore-fcfsd
127endif
128
129
130plugin_LTLIBRARIES = \
131 $(SQLITE_PLUGIN) \
132 $(POSTGRES_PLUGIN) \
133 $(HEAP_PLUGIN) \
134 $(REST_PLUGIN)
135
136
137libgnunet_plugin_rest_namestore_la_SOURCES = \
138 plugin_rest_namestore.c
139libgnunet_plugin_rest_namestore_la_LIBADD = \
140 libgnunetnamestore.la \
141 $(top_builddir)/src/rest/libgnunetrest.la \
142 $(top_builddir)/src/identity/libgnunetidentity.la \
143 $(top_builddir)/src/json/libgnunetjson.la \
144 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
145 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
146 $(LTLIBINTL) -ljansson -lmicrohttpd
147libgnunet_plugin_rest_namestore_la_LDFLAGS = \
148 $(GN_PLUGIN_LDFLAGS)
149
150
111libgnunetnamestore_la_SOURCES = \ 151libgnunetnamestore_la_SOURCES = \
112 namestore_api.c \ 152 namestore_api.c \
113 namestore_api_monitor.c \ 153 namestore_api_monitor.c \
@@ -121,17 +161,6 @@ libgnunetnamestore_la_LDFLAGS = \
121 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 161 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
122 -version-info 0:1:0 162 -version-info 0:1:0
123 163
124libexec_PROGRAMS = \
125 gnunet-service-namestore
126
127bin_PROGRAMS = \
128 gnunet-namestore \
129 gnunet-zoneimport
130
131if HAVE_MHD
132libexec_PROGRAMS += \
133 gnunet-namestore-fcfsd
134endif
135 164
136 165
137gnunet_zoneimport_SOURCES = \ 166gnunet_zoneimport_SOURCES = \
@@ -176,12 +205,6 @@ gnunet_service_namestore_LDADD = \
176 $(GN_LIBINTL) 205 $(GN_LIBINTL)
177 206
178 207
179plugin_LTLIBRARIES = \
180 $(SQLITE_PLUGIN) \
181 $(POSTGRES_PLUGIN) \
182 $(HEAP_PLUGIN)
183
184
185 208
186libgnunet_plugin_namestore_heap_la_SOURCES = \ 209libgnunet_plugin_namestore_heap_la_SOURCES = \
187 plugin_namestore_heap.c 210 plugin_namestore_heap.c