aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 18e6a196b..51708dd67 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -16,7 +16,6 @@ if USE_COVERAGE
16endif 16endif
17 17
18HEAP_PLUGIN = libgnunet_plugin_namestore_flat.la 18HEAP_PLUGIN = libgnunet_plugin_namestore_flat.la
19if HAVE_TESTING
20HEAP_TESTS = test_plugin_namestore_flat \ 19HEAP_TESTS = test_plugin_namestore_flat \
21 test_namestore_api_store_flat \ 20 test_namestore_api_store_flat \
22 test_namestore_api_store_update_flat \ 21 test_namestore_api_store_update_flat \
@@ -35,11 +34,9 @@ HEAP_TESTS = test_plugin_namestore_flat \
35 test_namestore_api_monitoring_existing_flat \ 34 test_namestore_api_monitoring_existing_flat \
36 test_namestore_api_zone_to_name_flat \ 35 test_namestore_api_zone_to_name_flat \
37 perf_namestore_api_zone_iteration_flat 36 perf_namestore_api_zone_iteration_flat
38endif
39 37
40if HAVE_SQLITE 38if HAVE_SQLITE
41SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la 39SQLITE_PLUGIN = libgnunet_plugin_namestore_sqlite.la
42if HAVE_TESTING
43SQLITE_TESTS = test_plugin_namestore_sqlite \ 40SQLITE_TESTS = test_plugin_namestore_sqlite \
44 test_namestore_api_store_sqlite \ 41 test_namestore_api_store_sqlite \
45 test_namestore_api_store_update_sqlite \ 42 test_namestore_api_store_update_sqlite \
@@ -59,11 +56,9 @@ SQLITE_TESTS = test_plugin_namestore_sqlite \
59 test_namestore_api_zone_to_name_sqlite \ 56 test_namestore_api_zone_to_name_sqlite \
60 perf_namestore_api_zone_iteration_sqlite 57 perf_namestore_api_zone_iteration_sqlite
61endif 58endif
62endif
63 59
64if HAVE_POSTGRESQL 60if HAVE_POSTGRESQL
65POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la 61POSTGRES_PLUGIN = libgnunet_plugin_namestore_postgres.la
66if HAVE_TESTING
67POSTGRES_TESTS = test_plugin_namestore_postgres \ 62POSTGRES_TESTS = test_plugin_namestore_postgres \
68 test_namestore_api_store_postgres \ 63 test_namestore_api_store_postgres \
69 test_namestore_api_store_update_postgres \ 64 test_namestore_api_store_update_postgres \
@@ -83,7 +78,6 @@ POSTGRES_TESTS = test_plugin_namestore_postgres \
83 test_namestore_api_zone_to_name_postgres \ 78 test_namestore_api_zone_to_name_postgres \
84 perf_namestore_api_zone_iteration_postgres 79 perf_namestore_api_zone_iteration_postgres
85endif 80endif
86endif
87 81
88if HAVE_SQLITE 82if HAVE_SQLITE
89check_PROGRAMS = \ 83check_PROGRAMS = \