aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am23
1 files changed, 1 insertions, 22 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 7f44c2a71..a349921d7 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -97,12 +97,6 @@ check_PROGRAMS = \
97 $(FLAT_TESTS) 97 $(FLAT_TESTS)
98endif 98endif
99 99
100if HAVE_MHD
101if HAVE_JSON
102REST_PLUGIN=libgnunet_plugin_rest_namestore.la
103endif
104endif
105
106if ENABLE_TEST_RUN 100if ENABLE_TEST_RUN
107AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 101AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
108TESTS = \ 102TESTS = \
@@ -186,8 +180,7 @@ gnunet_service_namestore_LDADD = \
186plugin_LTLIBRARIES = \ 180plugin_LTLIBRARIES = \
187 $(SQLITE_PLUGIN) \ 181 $(SQLITE_PLUGIN) \
188 $(POSTGRES_PLUGIN) \ 182 $(POSTGRES_PLUGIN) \
189 $(FLAT_PLUGIN) \ 183 $(FLAT_PLUGIN)
190 $(REST_PLUGIN)
191 184
192 185
193 186
@@ -224,20 +217,6 @@ libgnunet_plugin_namestore_postgres_la_LIBADD = \
224libgnunet_plugin_namestore_postgres_la_LDFLAGS = \ 217libgnunet_plugin_namestore_postgres_la_LDFLAGS = \
225 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS) 218 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
226 219
227libgnunet_plugin_rest_namestore_la_SOURCES = \
228 plugin_rest_namestore.c
229libgnunet_plugin_rest_namestore_la_LIBADD = \
230 libgnunetnamestore.la \
231 $(top_builddir)/src/rest/libgnunetrest.la \
232 $(top_builddir)/src/identity/libgnunetidentity.la \
233 $(top_builddir)/src/json/libgnunetjson.la \
234 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
235 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
236 $(LTLIBINTL) -ljansson -lmicrohttpd
237libgnunet_plugin_rest_namestore_la_LDFLAGS = \
238 $(GN_PLUGIN_LDFLAGS)
239
240
241test_namestore_api_store_flat_SOURCES = \ 220test_namestore_api_store_flat_SOURCES = \
242 test_namestore_api_store.c 221 test_namestore_api_store.c
243test_namestore_api_store_flat_LDADD = \ 222test_namestore_api_store_flat_LDADD = \