aboutsummaryrefslogtreecommitdiff
path: root/src/namestore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/namestore/Makefile.am')
-rw-r--r--src/namestore/Makefile.am8
1 files changed, 0 insertions, 8 deletions
diff --git a/src/namestore/Makefile.am b/src/namestore/Makefile.am
index 94861b478..f4b846065 100644
--- a/src/namestore/Makefile.am
+++ b/src/namestore/Makefile.am
@@ -99,9 +99,7 @@ TESTS = \
99 $(check_SCRIPTS) 99 $(check_SCRIPTS)
100endif 100endif
101 101
102if HAVE_REST
103REST_PLUGIN = libgnunet_plugin_rest_namestore.la 102REST_PLUGIN = libgnunet_plugin_rest_namestore.la
104endif
105 103
106lib_LTLIBRARIES = \ 104lib_LTLIBRARIES = \
107 libgnunetnamestore.la 105 libgnunetnamestore.la
@@ -114,10 +112,8 @@ bin_PROGRAMS = \
114 gnunet-namestore \ 112 gnunet-namestore \
115 gnunet-zoneimport 113 gnunet-zoneimport
116 114
117if HAVE_MHD
118libexec_PROGRAMS += \ 115libexec_PROGRAMS += \
119 gnunet-namestore-fcfsd 116 gnunet-namestore-fcfsd
120endif
121 117
122 118
123plugin_LTLIBRARIES = \ 119plugin_LTLIBRARIES = \
@@ -679,12 +675,8 @@ check_SCRIPTS = \
679 test_namestore_lookup.sh \ 675 test_namestore_lookup.sh \
680 test_namestore_delete.sh 676 test_namestore_delete.sh
681 677
682if HAVE_MHD
683if HAVE_JSON
684check_SCRIPTS += \ 678check_SCRIPTS += \
685 test_plugin_rest_namestore.sh 679 test_plugin_rest_namestore.sh
686endif
687endif
688 680
689EXTRA_DIST = \ 681EXTRA_DIST = \
690 test_common.c \ 682 test_common.c \