summaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am22
1 files changed, 15 insertions, 7 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index db104d194..d88dd6db4 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -8,19 +8,27 @@ pkgcfgdir= $(pkgdatadir)/config.d/
8pkgcfg_DATA = \ 8pkgcfg_DATA = \
9 nat.conf 9 nat.conf
10 10
11if HAVE_SUDO
12SUDO_OR_DOAS_BINARY= $(SUDO_BINARY)
13else
14if HAVE_DOAS_BINARY
15SUDO_OR_DOAS_BINARY= $(DOAS_BINARY)
16endif
17endif
18
11if LINUX 19if LINUX
12 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client 20 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client
13 NATSERVER = gnunet-helper-nat-server.c 21 NATSERVER = gnunet-helper-nat-server.c
14 NATCLIENT = gnunet-helper-nat-client.c 22 NATCLIENT = gnunet-helper-nat-client.c
15install-exec-hook: 23install-exec-hook:
16 $(top_srcdir)/src/nat/install-nat-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_BINARY) || true 24 $(top_srcdir)/src/nat/install-nat-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_OR_DOAS_BINARY) || true
17else 25else
18if XFREEBSD 26if XFREEBSD
19 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client 27 NATBIN = gnunet-helper-nat-server gnunet-helper-nat-client
20 NATSERVER = gnunet-helper-nat-server.c 28 NATSERVER = gnunet-helper-nat-server.c
21 NATCLIENT = gnunet-helper-nat-client.c 29 NATCLIENT = gnunet-helper-nat-client.c
22install-exec-hook: 30install-exec-hook:
23 $(top_srcdir)/src/nat/install-nat-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_BINARY) || true 31 $(top_srcdir)/src/nat/install-nat-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_OR_DOAS_BINARY) || true
24endif 32endif
25else 33else
26install-exec-hook: 34install-exec-hook:
@@ -61,7 +69,7 @@ libgnunetnatnew_la_SOURCES = \
61 nat.h 69 nat.h
62libgnunetnatnew_la_LIBADD = \ 70libgnunetnatnew_la_LIBADD = \
63 $(top_builddir)/src/util/libgnunetutil.la \ 71 $(top_builddir)/src/util/libgnunetutil.la \
64 $(GN_LIBINTL) @EXT_LIBS@ 72 $(GN_LIBINTL) @EXT_LIBS@
65libgnunetnatnew_la_LDFLAGS = \ 73libgnunetnatnew_la_LDFLAGS = \
66 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 74 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
67 -version-info 2:0:0 75 -version-info 2:0:0
@@ -94,25 +102,25 @@ endif
94# test_nat.c 102# test_nat.c
95#test_nat_LDADD = \ 103#test_nat_LDADD = \
96# libgnunetnat.la \ 104# libgnunetnat.la \
97# $(top_builddir)/src/util/libgnunetutil.la 105# $(top_builddir)/src/util/libgnunetutil.la
98 106
99#test_nat_mini_SOURCES = \ 107#test_nat_mini_SOURCES = \
100# test_nat_mini.c 108# test_nat_mini.c
101#test_nat_mini_LDADD = \ 109#test_nat_mini_LDADD = \
102# libgnunetnat.la \ 110# libgnunetnat.la \
103# $(top_builddir)/src/util/libgnunetutil.la 111# $(top_builddir)/src/util/libgnunetutil.la
104 112
105#test_nat_test_SOURCES = \ 113#test_nat_test_SOURCES = \
106# test_nat_test.c 114# test_nat_test.c
107#test_nat_test_LDADD = \ 115#test_nat_test_LDADD = \
108# libgnunetnat.la \ 116# libgnunetnat.la \
109# $(top_builddir)/src/util/libgnunetutil.la 117# $(top_builddir)/src/util/libgnunetutil.la
110 118
111#test_stun_SOURCES = \ 119#test_stun_SOURCES = \
112# test_stun.c 120# test_stun.c
113#test_stun_LDADD = \ 121#test_stun_LDADD = \
114# libgnunetnat.la \ 122# libgnunetnat.la \
115# $(top_builddir)/src/util/libgnunetutil.la 123# $(top_builddir)/src/util/libgnunetutil.la
116 124
117EXTRA_DIST = \ 125EXTRA_DIST = \
118 test_nat_data.conf \ 126 test_nat_data.conf \