aboutsummaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index 14a4d4e92..c47348b7c 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -1,4 +1,4 @@
1SUBDIRS = miniupnp libnatpmp 1SUBDIRS = .
2 2
3INCLUDES = -I$(top_srcdir)/src/include 3INCLUDES = -I$(top_srcdir)/src/include
4 4
@@ -12,7 +12,9 @@ endif
12 12
13if !MINGW 13if !MINGW
14 14
15if HAVE_EXPERIMENTAL
15lib_LTLIBRARIES = libgnunetnat.la 16lib_LTLIBRARIES = libgnunetnat.la
17endif
16 18
17libgnunetnat_la_SOURCES = \ 19libgnunetnat_la_SOURCES = \
18 upnp.c upnp.h \ 20 upnp.c upnp.h \
@@ -24,16 +26,16 @@ libgnunetnat_la_CFLAGS = \
24 26
25libgnunetnat_la_LIBADD = \ 27libgnunetnat_la_LIBADD = \
26 $(top_builddir)/src/util/libgnunetutil.la \ 28 $(top_builddir)/src/util/libgnunetutil.la \
27 $(top_builddir)/src/nat/miniupnp/libminiupnp.la \ 29 $(GN_LIBINTL) @EXT_LIBS@
28 $(top_builddir)/src/nat/libnatpmp/libnatpmp.la \
29 $(GN_LIBINTL) @EXT_LIBS@
30 30
31libgnunetnat_la_LDFLAGS = \ 31libgnunetnat_la_LDFLAGS = \
32 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 32 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
33 -version-info 0:0:0 33 -version-info 0:0:0
34 34
35if HAVE_EXPERIMENTAL
35check_PROGRAMS = \ 36check_PROGRAMS = \
36 test-nat 37 test-nat
38endif
37 39
38if !DISABLE_TEST_RUN 40if !DISABLE_TEST_RUN
39TESTS = $(check_PROGRAMS) 41TESTS = $(check_PROGRAMS)
@@ -46,4 +48,4 @@ test_nat_LDADD = \
46 $(top_builddir)/src/nat/libgnunetnat.la \ 48 $(top_builddir)/src/nat/libgnunetnat.la \
47 $(top_builddir)/src/util/libgnunetutil.la 49 $(top_builddir)/src/util/libgnunetutil.la
48 50
49endif \ No newline at end of file 51endif