aboutsummaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am70
1 files changed, 28 insertions, 42 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index 456ddfb62..3dc001dd7 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -60,22 +60,8 @@ if USE_COVERAGE
60endif 60endif
61 61
62lib_LTLIBRARIES = \ 62lib_LTLIBRARIES = \
63 libgnunetnat.la \
64 libgnunetnatnew.la 63 libgnunetnatnew.la
65 64
66libgnunetnat_la_SOURCES = \
67 nat.c nat.h \
68 nat_auto.c \
69 nat_test.c \
70 nat_mini.c \
71 nat_stun.c
72libgnunetnat_la_LIBADD = \
73 $(top_builddir)/src/util/libgnunetutil.la \
74 $(GN_LIBINTL) @EXT_LIBS@
75libgnunetnat_la_LDFLAGS = \
76 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
77 -version-info 1:1:1
78
79libgnunetnatnew_la_SOURCES = \ 65libgnunetnatnew_la_SOURCES = \
80 nat_api.c \ 66 nat_api.c \
81 nat_api_stun.c nat_stun.h \ 67 nat_api_stun.c nat_stun.h \
@@ -100,40 +86,40 @@ gnunet_service_nat_LDADD = \
100 -lgcrypt \ 86 -lgcrypt \
101 $(GN_LIBINTL) 87 $(GN_LIBINTL)
102 88
103check_PROGRAMS = \ 89#check_PROGRAMS = \
104 test_nat \ 90# test_nat \
105 test_nat_mini \ 91# test_nat_mini \
106 test_nat_test \ 92# test_nat_test \
107 test_stun 93# test_stun
108 94
109if ENABLE_TEST_RUN 95if ENABLE_TEST_RUN
110 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 96 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
111 TESTS = $(check_PROGRAMS) 97 TESTS = $(check_PROGRAMS)
112endif 98endif
113 99
114test_nat_SOURCES = \ 100#test_nat_SOURCES = \
115 test_nat.c 101# test_nat.c
116test_nat_LDADD = \ 102#test_nat_LDADD = \
117 libgnunetnat.la \ 103# libgnunetnat.la \
118 $(top_builddir)/src/util/libgnunetutil.la 104# $(top_builddir)/src/util/libgnunetutil.la
119 105
120test_nat_mini_SOURCES = \ 106#test_nat_mini_SOURCES = \
121 test_nat_mini.c 107# test_nat_mini.c
122test_nat_mini_LDADD = \ 108#test_nat_mini_LDADD = \
123 libgnunetnat.la \ 109# libgnunetnat.la \
124 $(top_builddir)/src/util/libgnunetutil.la 110# $(top_builddir)/src/util/libgnunetutil.la
125 111
126test_nat_test_SOURCES = \ 112#test_nat_test_SOURCES = \
127 test_nat_test.c 113# test_nat_test.c
128test_nat_test_LDADD = \ 114#test_nat_test_LDADD = \
129 libgnunetnat.la \ 115# libgnunetnat.la \
130 $(top_builddir)/src/util/libgnunetutil.la 116# $(top_builddir)/src/util/libgnunetutil.la
131 117
132test_stun_SOURCES = \ 118#test_stun_SOURCES = \
133 test_stun.c 119# test_stun.c
134test_stun_LDADD = \ 120#test_stun_LDADD = \
135 libgnunetnat.la \ 121# libgnunetnat.la \
136 $(top_builddir)/src/util/libgnunetutil.la 122# $(top_builddir)/src/util/libgnunetutil.la
137 123
138EXTRA_DIST = \ 124EXTRA_DIST = \
139 test_nat_data.conf \ 125 test_nat_data.conf \