aboutsummaryrefslogtreecommitdiff
path: root/src/nse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nse/Makefile.am')
-rw-r--r--src/nse/Makefile.am110
1 files changed, 0 insertions, 110 deletions
diff --git a/src/nse/Makefile.am b/src/nse/Makefile.am
deleted file mode 100644
index 824aa10d4..000000000
--- a/src/nse/Makefile.am
+++ /dev/null
@@ -1,110 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9pkgcfgdir= $(pkgdatadir)/config.d/
10
11libexecdir= $(pkglibdir)/libexec/
12
13pkgcfg_DATA = \
14 nse.conf
15
16bin_PROGRAMS = gnunet-nse
17
18gnunet_nse_SOURCES = gnunet-nse.c
19gnunet_nse_LDADD = \
20 libgnunetnse.la \
21 $(top_builddir)/src/util/libgnunetutil.la \
22 $(XLIB) $(GN_LIBINTL)
23
24lib_LTLIBRARIES = libgnunetnse.la
25
26libgnunetnse_la_SOURCES = \
27 nse_api.c nse.h
28libgnunetnse_la_LIBADD = \
29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(GN_LIBINTL) $(XLIB)
31libgnunetnse_la_LDFLAGS = \
32 $(GN_LIB_LDFLAGS) \
33 -version-info 0:0:0
34
35
36libexec_PROGRAMS = \
37 gnunet-service-nse
38
39if HAVE_TESTING
40noinst_PROGRAMS = \
41 gnunet-nse-profiler
42endif
43
44gnunet_nse_profiler_SOURCES = \
45 gnunet-nse-profiler.c
46gnunet_nse_profiler_LDADD = -lm \
47 libgnunetnse.la \
48 $(top_builddir)/src/util/libgnunetutil.la \
49 $(top_builddir)/src/statistics/libgnunetstatistics.la \
50 $(top_builddir)/src/testing/libgnunettesting.la \
51 $(top_builddir)/src/testbed/libgnunettestbed.la \
52 $(GN_LIBINTL)
53
54gnunet_service_nse_SOURCES = \
55 gnunet-service-nse.c
56gnunet_service_nse_LDADD = \
57 libgnunetnse.la \
58 $(top_builddir)/src/util/libgnunetutil.la \
59 $(top_builddir)/src/core/libgnunetcore.la \
60 $(top_builddir)/src/statistics/libgnunetstatistics.la \
61 $(LIBGCRYPT_LIBS) \
62 -lm -lgcrypt \
63 $(GN_LIBINTL)
64if ENABLE_NSE_HISTOGRAM
65 gnunet_service_nse_LDADD += \
66 $(top_builddir)/src/testbed-logger/libgnunettestbedlogger.la
67endif
68
69
70if HAVE_BENCHMARKS
71 MULTIPEER_TEST = test_nse_multipeer
72endif
73
74if HAVE_TESTING
75check_PROGRAMS = \
76 test_nse_api \
77 perf_kdf \
78 $(MULTIPEER_TEST)
79endif
80
81if ENABLE_TEST_RUN
82AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
83TESTS = $(check_PROGRAMS)
84endif
85
86test_nse_api_SOURCES = \
87 test_nse_api.c
88test_nse_api_LDADD = \
89 libgnunetnse.la \
90 $(top_builddir)/src/testing/libgnunettesting.la \
91 $(top_builddir)/src/util/libgnunetutil.la
92
93test_nse_multipeer_SOURCES = \
94 test_nse_multipeer.c
95test_nse_multipeer_LDADD = \
96 libgnunetnse.la \
97 $(top_builddir)/src/util/libgnunetutil.la \
98 $(top_builddir)/src/testbed/libgnunettestbed.la \
99 -lm
100
101perf_kdf_SOURCES = \
102 perf_kdf.c
103perf_kdf_LDADD = \
104 $(top_builddir)/src/util/libgnunetutil.la \
105 $(LIBGCRYPT_LIBS) \
106 -lgcrypt
107
108EXTRA_DIST = \
109 test_nse.conf \
110 nse_profiler_test.conf