aboutsummaryrefslogtreecommitdiff
path: root/src/nt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nt/Makefile.am')
-rw-r--r--src/nt/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/nt/Makefile.am b/src/nt/Makefile.am
new file mode 100644
index 000000000..68b6a55e7
--- /dev/null
+++ b/src/nt/Makefile.am
@@ -0,0 +1,36 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if MINGW
5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
6endif
7
8if USE_COVERAGE
9 AM_CFLAGS = --coverage
10endif
11
12lib_LTLIBRARIES = libgnunetnt.la
13
14libgnunetnt_la_SOURCES = \
15 nt.c
16
17libgnunetnt_la_LIBADD = \
18 $(top_builddir)/src/util/libgnunetutil.la
19libgnunetnt_la_LDFLAGS = \
20 $(GN_LIB_LDFLAGS) \
21 -version-info 0:0:0
22
23#if ENABLE_TEST_RUN
24#TESTS = \
25# test_nt
26#endif
27
28#check_PROGRAMS= \
29# test_nt
30#
31#test_nt_SOURCES = \
32# test_nt.c
33#test_nt_LDADD = \
34# libgnunetnt.la \
35# $(top_builddir)/src/util/libgnunetutil.la \
36# $(XLIB)