aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo-tool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerinfo-tool/Makefile.am')
-rw-r--r--src/peerinfo-tool/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/peerinfo-tool/Makefile.am b/src/peerinfo-tool/Makefile.am
index 648957a05..6f9a3360c 100644
--- a/src/peerinfo-tool/Makefile.am
+++ b/src/peerinfo-tool/Makefile.am
@@ -10,6 +10,8 @@ if USE_COVERAGE
10 XLIB = -lgcov 10 XLIB = -lgcov
11endif 11endif
12 12
13plugindir = $(libdir)/gnunet
14
13bin_PROGRAMS = \ 15bin_PROGRAMS = \
14 gnunet-peerinfo 16 gnunet-peerinfo
15 17
@@ -24,6 +26,27 @@ gnunet_peerinfo_LDADD = \
24 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 26 $(top_builddir)/src/statistics/libgnunetstatistics.la \
25 $(top_builddir)/src/util/libgnunetutil.la 27 $(top_builddir)/src/util/libgnunetutil.la
26 28
29if HAVE_MHD
30if HAVE_JSON
31plugin_LTLIBRARIES = \
32 libgnunet_plugin_rest_peerinfo.la
33endif
34endif
35
36
37libgnunet_plugin_rest_peerinfo_la_SOURCES = \
38 plugin_rest_peerinfo.c
39libgnunet_plugin_rest_peerinfo_la_LIBADD = \
40 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
41 $(top_builddir)/src/transport/libgnunettransport.la \
42 $(top_builddir)/src/rest/libgnunetrest.la \
43 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
44 $(LTLIBINTL) -ljansson -lmicrohttpd
45libgnunet_plugin_rest_peerinfo_la_LDFLAGS = \
46 $(GN_PLUGIN_LDFLAGS)
47
48
49
27if HAVE_PYTHON 50if HAVE_PYTHON
28check_SCRIPTS = \ 51check_SCRIPTS = \
29 test_gnunet_peerinfo.py 52 test_gnunet_peerinfo.py