aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo-tool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerinfo-tool/Makefile.am')
-rw-r--r--src/peerinfo-tool/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/peerinfo-tool/Makefile.am b/src/peerinfo-tool/Makefile.am
new file mode 100644
index 000000000..b9e6d7d07
--- /dev/null
+++ b/src/peerinfo-tool/Makefile.am
@@ -0,0 +1,24 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols -lole32 -lshell32 -luuid -liconv -lstdc++ -lcomdlg32 -lgdi32
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12bin_PROGRAMS = \
13 gnunet-peerinfo
14
15gnunet_peerinfo_SOURCES = \
16 gnunet-peerinfo.c
17gnunet_peerinfo_LDADD = \
18 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
19 $(top_builddir)/src/transport/libgnunettransport.la \
20 $(top_builddir)/src/util/libgnunetutil.la
21
22
23#check_SCRIPTS = \
24# test_gnunet_peerinfo.sh