aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerinfo/Makefile.am')
-rw-r--r--src/peerinfo/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/peerinfo/Makefile.am b/src/peerinfo/Makefile.am
index eeb5ee54e..5e96250b1 100644
--- a/src/peerinfo/Makefile.am
+++ b/src/peerinfo/Makefile.am
@@ -5,6 +5,8 @@ pkgcfgdir= $(pkgdatadir)/config.d/
5 5
6libexecdir= $(pkglibdir)/libexec/ 6libexecdir= $(pkglibdir)/libexec/
7 7
8plugindir = $(libdir)/gnunet
9
8pkgcfg_DATA = \ 10pkgcfg_DATA = \
9 peerinfo.conf 11 peerinfo.conf
10 12
@@ -25,6 +27,8 @@ libgnunetpeerinfo_la_SOURCES = \
25libgnunetpeerinfo_la_LIBADD = \ 27libgnunetpeerinfo_la_LIBADD = \
26 $(top_builddir)/src/hello/libgnunethello.la \ 28 $(top_builddir)/src/hello/libgnunethello.la \
27 $(top_builddir)/src/util/libgnunetutil.la \ 29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(top_builddir)/src/json/libgnunetjson.la \
31 $(top_builddir)/src/transport/libgnunettransport.la \
28 $(XLIB) \ 32 $(XLIB) \
29 $(LTLIBINTL) 33 $(LTLIBINTL)
30libgnunetpeerinfo_la_LDFLAGS = \ 34libgnunetpeerinfo_la_LDFLAGS = \
@@ -35,12 +39,30 @@ libgnunetpeerinfo_la_LDFLAGS = \
35libexec_PROGRAMS = \ 39libexec_PROGRAMS = \
36 gnunet-service-peerinfo 40 gnunet-service-peerinfo
37 41
42if HAVE_MHD
43if HAVE_JSON
44plugin_LTLIBRARIES = \
45 libgnunet_plugin_rest_peerinfo.la
46endif
47endif
48
38gnunet_service_peerinfo_SOURCES = \ 49gnunet_service_peerinfo_SOURCES = \
39 gnunet-service-peerinfo.c 50 gnunet-service-peerinfo.c
40gnunet_service_peerinfo_LDADD = \ 51gnunet_service_peerinfo_LDADD = \
41 $(top_builddir)/src/hello/libgnunethello.la \ 52 $(top_builddir)/src/hello/libgnunethello.la \
42 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 53 $(top_builddir)/src/statistics/libgnunetstatistics.la \
43 $(top_builddir)/src/util/libgnunetutil.la 54 $(top_builddir)/src/util/libgnunetutil.la
55
56
57libgnunet_plugin_rest_peerinfo_la_SOURCES = \
58 plugin_rest_peerinfo.c
59libgnunet_plugin_rest_peerinfo_la_LIBADD = \
60 libgnunetpeerinfo.la \
61 $(top_builddir)/src/rest/libgnunetrest.la \
62 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
63 $(LTLIBINTL) -ljansson -lmicrohttpd
64libgnunet_plugin_rest_peerinfo_la_LDFLAGS = \
65 $(GN_PLUGIN_LDFLAGS)
44 66
45if HAVE_BENCHMARKS 67if HAVE_BENCHMARKS
46 PEERINFO_BENCHMARKS = \ 68 PEERINFO_BENCHMARKS = \