aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerinfo/Makefile.am')
-rw-r--r--src/peerinfo/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/src/peerinfo/Makefile.am b/src/peerinfo/Makefile.am
new file mode 100644
index 000000000..294ff5cca
--- /dev/null
+++ b/src/peerinfo/Makefile.am
@@ -0,0 +1,56 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols -lole32 -lshell32 -luuid -liconv -lstdc++ -lcomdlg32 -lgdi32
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = -fprofile-arcs -ftest-coverage
9endif
10
11lib_LTLIBRARIES = libgnunetpeerinfo.la
12
13libgnunetpeerinfo_la_SOURCES = \
14 peerinfo_api.c peerinfo.h
15libgnunetpeerinfo_la_LIBADD = \
16 $(top_builddir)/src/hello/libgnunethello.la \
17 $(top_builddir)/src/util/libgnunetutil.la
18libgnunetpeerinfo_la_LDFLAGS = \
19 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
20 -version-info 0:0:0
21
22
23bin_PROGRAMS = \
24 gnunet-peerinfo \
25 gnunet-service-peerinfo
26
27gnunet_peerinfo_SOURCES = \
28 gnunet-peerinfo.c
29gnunet_peerinfo_LDADD = \
30 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
31 $(top_builddir)/src/util/libgnunetutil.la
32
33gnunet_service_peerinfo_SOURCES = \
34 gnunet-service-peerinfo.c
35gnunet_service_peerinfo_LDADD = \
36 $(top_builddir)/src/hello/libgnunethello.la \
37 $(top_builddir)/src/util/libgnunetutil.la
38
39
40check_PROGRAMS = \
41 test_peerinfo_api
42
43TESTS = $(check_PROGRAMS) # $(check_SCRIPTS)
44
45test_peerinfo_api_SOURCES = \
46 test_peerinfo_api.c
47test_peerinfo_api_LDADD = \
48 $(top_builddir)/src/hello/libgnunethello.la \
49 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
50 $(top_builddir)/src/util/libgnunetutil.la
51
52EXTRA_DIST = \
53 test_peerinfo_api_data.conf
54
55#check_SCRIPTS = \
56# test_gnunet_peerinfo.sh