aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerinfo/Makefile.am')
-rw-r--r--src/peerinfo/Makefile.am107
1 files changed, 0 insertions, 107 deletions
diff --git a/src/peerinfo/Makefile.am b/src/peerinfo/Makefile.am
deleted file mode 100644
index e61e5a13d..000000000
--- a/src/peerinfo/Makefile.am
+++ /dev/null
@@ -1,107 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10pkgcfg_DATA = \
11 peerinfo.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIB = -lgcov
16endif
17
18lib_LTLIBRARIES = libgnunetpeerinfo.la
19
20
21libgnunetpeerinfo_la_SOURCES = \
22 peerinfo_api.c peerinfo.h \
23 peerinfo_api_notify.c
24libgnunetpeerinfo_la_LIBADD = \
25 $(top_builddir)/src/hello/libgnunethello.la \
26 $(top_builddir)/src/util/libgnunetutil.la \
27 $(XLIB) \
28 $(LTLIBINTL)
29libgnunetpeerinfo_la_LDFLAGS = \
30 $(GN_LIB_LDFLAGS) \
31 -version-info 0:0:0
32
33
34libexec_PROGRAMS = \
35 gnunet-service-peerinfo
36
37gnunet_service_peerinfo_SOURCES = \
38 gnunet-service-peerinfo.c
39gnunet_service_peerinfo_LDADD = \
40 $(top_builddir)/src/hello/libgnunethello.la \
41 $(top_builddir)/src/statistics/libgnunetstatistics.la \
42 $(top_builddir)/src/util/libgnunetutil.la
43gnunet_service_peerinfo_LDFLAGS = \
44 $(GN_LIBINTL)
45
46if HAVE_BENCHMARKS
47 PEERINFO_BENCHMARKS = \
48 perf_peerinfo_api
49endif
50
51if HAVE_TESTING
52check_PROGRAMS = \
53 test_peerinfo_shipped_hellos \
54 test_peerinfo_api \
55 test_peerinfo_api_friend_only \
56 test_peerinfo_api_notify_friend_only \
57 $(PEERINFO_BENCHMARKS)
58endif
59
60
61if ENABLE_TEST_RUN
62AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
63TESTS = $(check_PROGRAMS)
64endif
65
66test_peerinfo_shipped_hellos_SOURCES = \
67 test_peerinfo_shipped_hellos.c
68test_peerinfo_shipped_hellos_LDADD = \
69 $(top_builddir)/src/hello/libgnunethello.la \
70 libgnunetpeerinfo.la \
71 $(top_builddir)/src/testing/libgnunettesting.la \
72 $(top_builddir)/src/util/libgnunetutil.la
73
74test_peerinfo_api_SOURCES = \
75 test_peerinfo_api.c
76test_peerinfo_api_LDADD = \
77 $(top_builddir)/src/hello/libgnunethello.la \
78 libgnunetpeerinfo.la \
79 $(top_builddir)/src/testing/libgnunettesting.la \
80 $(top_builddir)/src/util/libgnunetutil.la
81
82test_peerinfo_api_friend_only_SOURCES = \
83 test_peerinfo_api_friend_only.c
84test_peerinfo_api_friend_only_LDADD = \
85 $(top_builddir)/src/hello/libgnunethello.la \
86 libgnunetpeerinfo.la \
87 $(top_builddir)/src/testing/libgnunettesting.la \
88 $(top_builddir)/src/util/libgnunetutil.la
89
90test_peerinfo_api_notify_friend_only_SOURCES = \
91 test_peerinfo_api_notify_friend_only.c
92test_peerinfo_api_notify_friend_only_LDADD = \
93 $(top_builddir)/src/hello/libgnunethello.la \
94 libgnunetpeerinfo.la \
95 $(top_builddir)/src/testing/libgnunettesting.la \
96 $(top_builddir)/src/util/libgnunetutil.la
97
98perf_peerinfo_api_SOURCES = \
99 perf_peerinfo_api.c
100perf_peerinfo_api_LDADD = \
101 $(top_builddir)/src/hello/libgnunethello.la \
102 libgnunetpeerinfo.la \
103 $(top_builddir)/src/testing/libgnunettesting.la \
104 $(top_builddir)/src/util/libgnunetutil.la
105
106EXTRA_DIST = \
107 test_peerinfo_api_data.conf