aboutsummaryrefslogtreecommitdiff
path: root/src/peerinfo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerinfo/Makefile.am')
-rw-r--r--src/peerinfo/Makefile.am20
1 files changed, 0 insertions, 20 deletions
diff --git a/src/peerinfo/Makefile.am b/src/peerinfo/Makefile.am
index 5e96250b1..3f68becb5 100644
--- a/src/peerinfo/Makefile.am
+++ b/src/peerinfo/Makefile.am
@@ -27,8 +27,6 @@ libgnunetpeerinfo_la_SOURCES = \
27libgnunetpeerinfo_la_LIBADD = \ 27libgnunetpeerinfo_la_LIBADD = \
28 $(top_builddir)/src/hello/libgnunethello.la \ 28 $(top_builddir)/src/hello/libgnunethello.la \
29 $(top_builddir)/src/util/libgnunetutil.la \ 29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(top_builddir)/src/json/libgnunetjson.la \
31 $(top_builddir)/src/transport/libgnunettransport.la \
32 $(XLIB) \ 30 $(XLIB) \
33 $(LTLIBINTL) 31 $(LTLIBINTL)
34libgnunetpeerinfo_la_LDFLAGS = \ 32libgnunetpeerinfo_la_LDFLAGS = \
@@ -39,13 +37,6 @@ libgnunetpeerinfo_la_LDFLAGS = \
39libexec_PROGRAMS = \ 37libexec_PROGRAMS = \
40 gnunet-service-peerinfo 38 gnunet-service-peerinfo
41 39
42if HAVE_MHD
43if HAVE_JSON
44plugin_LTLIBRARIES = \
45 libgnunet_plugin_rest_peerinfo.la
46endif
47endif
48
49gnunet_service_peerinfo_SOURCES = \ 40gnunet_service_peerinfo_SOURCES = \
50 gnunet-service-peerinfo.c 41 gnunet-service-peerinfo.c
51gnunet_service_peerinfo_LDADD = \ 42gnunet_service_peerinfo_LDADD = \
@@ -53,17 +44,6 @@ gnunet_service_peerinfo_LDADD = \
53 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 44 $(top_builddir)/src/statistics/libgnunetstatistics.la \
54 $(top_builddir)/src/util/libgnunetutil.la 45 $(top_builddir)/src/util/libgnunetutil.la
55 46
56
57libgnunet_plugin_rest_peerinfo_la_SOURCES = \
58 plugin_rest_peerinfo.c
59libgnunet_plugin_rest_peerinfo_la_LIBADD = \
60 libgnunetpeerinfo.la \
61 $(top_builddir)/src/rest/libgnunetrest.la \
62 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
63 $(LTLIBINTL) -ljansson -lmicrohttpd
64libgnunet_plugin_rest_peerinfo_la_LDFLAGS = \
65 $(GN_PLUGIN_LDFLAGS)
66
67if HAVE_BENCHMARKS 47if HAVE_BENCHMARKS
68 PEERINFO_BENCHMARKS = \ 48 PEERINFO_BENCHMARKS = \
69 perf_peerinfo_api 49 perf_peerinfo_api