aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/peerstore/Makefile.am')
-rw-r--r--src/peerstore/Makefile.am147
1 files changed, 0 insertions, 147 deletions
diff --git a/src/peerstore/Makefile.am b/src/peerstore/Makefile.am
deleted file mode 100644
index d9904e59d..000000000
--- a/src/peerstore/Makefile.am
+++ /dev/null
@@ -1,147 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6pkgcfgdir= $(pkgdatadir)/config.d/
7
8libexecdir= $(pkglibdir)/libexec/
9
10dist_pkgcfg_DATA = \
11 peerstore.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = -fprofile-arcs -ftest-coverage
15endif
16
17bin_PROGRAMS = \
18 gnunet-peerstore
19
20libexec_PROGRAMS = \
21 gnunet-service-peerstore
22
23lib_LTLIBRARIES = \
24 libgnunetpeerstore.la
25
26gnunet_peerstore_SOURCES = \
27 gnunet-peerstore.c
28gnunet_peerstore_LDADD = \
29 $(top_builddir)/src/util/libgnunetutil.la \
30 libgnunetpeerstore.la \
31 $(GN_LIBINTL)
32
33gnunet_service_peerstore_SOURCES = \
34 gnunet-service-peerstore.c \
35 peerstore_common.c peerstore_common.h \
36 peerstore.h
37gnunet_service_peerstore_CFLAGS = $(AM_CFLAGS)
38gnunet_service_peerstore_LDADD = \
39 $(top_builddir)/src/util/libgnunetutil.la \
40 $(GN_LIBINTL)
41
42libgnunetpeerstore_la_SOURCES = \
43 peerstore_api.c \
44 peerstore_common.c
45libgnunetpeerstore_la_LIBADD = \
46 $(top_builddir)/src/util/libgnunetutil.la
47libgnunetpeerstore_la_LDFLAGS = \
48 $(GN_LIBINTL) \
49 $(GN_LIB_LDFLAGS)
50
51if HAVE_EXPERIMENTAL
52FLAT_PLUGIN = libgnunet_plugin_peerstore_flat.la
53FLAT_TESTS = test_plugin_peerstore_flat
54libgnunet_plugin_peerstore_flat_la_SOURCES = \
55 plugin_peerstore_flat.c
56libgnunet_plugin_peerstore_flat_la_LIBADD = \
57 libgnunetpeerstore.la \
58 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
59 $(LTLIBINTL)
60libgnunet_plugin_peerstore_flat_la_LDFLAGS = \
61 $(GN_PLUGIN_LDFLAGS)
62endif
63
64if HAVE_SQLITE
65SQLITE_PLUGIN = libgnunet_plugin_peerstore_sqlite.la
66SQLITE_TESTS = test_plugin_peerstore_sqlite
67libgnunet_plugin_peerstore_sqlite_la_SOURCES = \
68 plugin_peerstore_sqlite.c
69libgnunet_plugin_peerstore_sqlite_la_LIBADD = \
70 libgnunetpeerstore.la \
71 $(top_builddir)/src/sq/libgnunetsq.la \
72 $(top_builddir)/src/util/libgnunetutil.la \
73 $(XLIBS) -lsqlite3 \
74 $(LTLIBINTL)
75libgnunet_plugin_peerstore_sqlite_la_LDFLAGS = \
76 $(GN_PLUGIN_LDFLAGS)
77endif
78
79plugin_LTLIBRARIES = \
80 $(SQLITE_PLUGIN) \
81 $(FLAT_PLUGIN)
82
83test_plugin_peerstore_sqlite_SOURCES = \
84 test_plugin_peerstore.c
85test_plugin_peerstore_sqlite_LDADD = \
86 $(top_builddir)/src/testing/libgnunettesting.la \
87 $(top_builddir)/src/util/libgnunetutil.la
88
89test_plugin_peerstore_flat_SOURCES = \
90 test_plugin_peerstore.c
91test_plugin_peerstore_flat_LDADD = \
92 $(top_builddir)/src/testing/libgnunettesting.la \
93 $(top_builddir)/src/util/libgnunetutil.la
94
95check_PROGRAMS = \
96 test_peerstore_api_store \
97 test_peerstore_api_iterate \
98 test_peerstore_api_watch \
99 test_peerstore_api_sync \
100 perf_peerstore_store \
101 $(SQLITE_TESTS) \
102 $(FLAT_TESTS)
103
104EXTRA_DIST = \
105 test_peerstore_api_data.conf \
106 test_plugin_peerstore_flat.conf \
107 test_plugin_peerstore_sqlite.conf
108
109if ENABLE_TEST_RUN
110AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
111TESTS = $(check_PROGRAMS)
112endif
113
114test_peerstore_api_store_SOURCES = \
115 test_peerstore_api_store.c
116test_peerstore_api_store_LDADD = \
117 libgnunetpeerstore.la \
118 $(top_builddir)/src/testing/libgnunettesting.la \
119 $(top_builddir)/src/util/libgnunetutil.la
120
121test_peerstore_api_iterate_SOURCES = \
122 test_peerstore_api_iterate.c
123test_peerstore_api_iterate_LDADD = \
124 libgnunetpeerstore.la \
125 $(top_builddir)/src/testing/libgnunettesting.la \
126 $(top_builddir)/src/util/libgnunetutil.la
127
128test_peerstore_api_watch_SOURCES = \
129 test_peerstore_api_watch.c
130test_peerstore_api_watch_LDADD = \
131 libgnunetpeerstore.la \
132 $(top_builddir)/src/testing/libgnunettesting.la \
133 $(top_builddir)/src/util/libgnunetutil.la
134
135test_peerstore_api_sync_SOURCES = \
136 test_peerstore_api_sync.c
137test_peerstore_api_sync_LDADD = \
138 libgnunetpeerstore.la \
139 $(top_builddir)/src/testing/libgnunettesting.la \
140 $(top_builddir)/src/util/libgnunetutil.la
141
142perf_peerstore_store_SOURCES = \
143 perf_peerstore_store.c
144perf_peerstore_store_LDADD = \
145 libgnunetpeerstore.la \
146 $(top_builddir)/src/testing/libgnunettesting.la \
147 $(top_builddir)/src/util/libgnunetutil.la