aboutsummaryrefslogtreecommitdiff
path: root/src/pq/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/pq/Makefile.am')
-rw-r--r--src/pq/Makefile.am42
1 files changed, 0 insertions, 42 deletions
diff --git a/src/pq/Makefile.am b/src/pq/Makefile.am
deleted file mode 100644
index d3a2ce9ac..000000000
--- a/src/pq/Makefile.am
+++ /dev/null
@@ -1,42 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS)
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage
6endif
7
8if HAVE_POSTGRESQL
9lib_LTLIBRARIES = libgnunetpq.la
10endif
11
12libgnunetpq_la_SOURCES = \
13 pq.c \
14 pq.h \
15 pq_connect.c \
16 pq_eval.c \
17 pq_event.c \
18 pq_exec.c \
19 pq_prepare.c \
20 pq_query_helper.c \
21 pq_result_helper.c
22libgnunetpq_la_LIBADD = -lpq \
23 $(top_builddir)/src/util/libgnunetutil.la
24libgnunetpq_la_LDFLAGS = \
25 $(POSTGRESQL_LDFLAGS) \
26 $(GN_LIB_LDFLAGS) \
27 -version-info 2:0:0
28
29if ENABLE_TEST_RUN
30TESTS = \
31 test_pq
32endif
33
34check_PROGRAMS= \
35 test_pq
36
37test_pq_SOURCES = \
38 test_pq.c
39test_pq_LDADD = \
40 libgnunetpq.la \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 -lpq $(XLIB)